Notes de version 1.0

From FreeCAD Documentation
This page is a translated version of the page Release notes 1.0 and the translation is 100% complete.
Other languages:
FreeCAD 1.0 est en cours de développement, il n'y a pas encore de date de sortie prévue.
Des fonctions sont manquantes? Faites en part dans le fil du forum Release notes for v1.0.

Voir Contribuer à FreeCAD pour savoir comment contribuer à FreeCAD.

Toutes les images de cette page doivent utiliser le suffixe _relnotes_1.0


FreeCAD 1.0 a été publié le JJ MM 2024, téléchargez la depuis la page Téléchargement. Cette page liste toutes les nouvelles fonctions et les changements.

Les notes de versions plus anciennes de FreeCAD sont disponibles dans la liste des notes de versions.

L'endroit pour une image accrocheuse sélectionnée par les administrateurs sur le forum des modèles des utilisateurs.

Général

Le problème de longue date du Problème de dénomination topologique a finalement été corrigé grâce aux efforts conjoints et au travail acharné de plusieurs développeurs. La solution de Realthunder a été soigneusement implémentée et améliorée pour fonctionner dans la version maître de FreeCAD. Le projet a pris plus d'un an et l'implémentation a été finalisée avec le PR suivant qui active le correctif. Des tests approfondis et des corrections de bogues suivront.

Pull request #13705

FreeCAD a un nouveau logo. Il a été sélectionné parmi les 5 gagnants du concours public.

Pull request #14284

Interface utilisateur

Un indicateur de centre de rotation a été ajouté. Cet indicateur s'affiche lorsque la vue a pivoté en faisant glisser la souris. Il peut être désactivé dans les préférences. Il est également possible de régler sa couleur, sa transparence et sa taille.

Pull request #9909 et Pull request #10790

.
Cliquez sur l'image si l'animation ne démarre pas.
Des filtres de sélection ont été ajoutés, facilitant la sélection des sommets, des arêtes et des faces.

Pull request #10271

Pour plus de flexibilité, le panneau des tâches est désormais un widget autonome et ancrable, mais l'ancienne disposition est conservée par défaut.

Pull request #10681 et Pull request #10848

L'apparence de l'outil de déplacement Transformer a été améliorée. Il dispose maintenant aussi d'un ensemble d'outils de déplacement des objets le long des 3 plans par défaut.

Pull request #10706

La fonction de Realthunder permettant la superposition des widgets d'ancrage (transparence de la vue en arborescence et des tâches) a été ajoutée.

Pull request #7888

La position de la source lumineuse peut désormais être définie dans les préférences (Préférences → Affichage).

Pull request #11146

La fenêtre Préférences a été redessinée pour remplacer les onglets par une vue arborescente.

Pull request #11018

Un sélecteur d'atelier pour la barre d'onglets a été ajouté. Il peut être activé et configuré dans Préférences → Ateliers.

Pull request #12270

Un nouvel outil de mesure universel a été ajouté, remplaçant les anciens outils de mesure de Part.

Pull request #9750 et suivant


Cliquez sur l'image si l'animation ne démarre pas.
L'outil d'affichage Aligner sur la sélection a été ajouté, ce qui permet de saisir des vues normales aux faces ou suivant des directions d'arêtes.

Pull request #13906

Autres améliorations de l'interface utilisateur

  • Un système d'unités de projet a été introduit. Pull request #9521
  • L'outil Coupe persistante fonctionne maintenant aussi dans une vue en perspective. Pull request #10143
  • Une option permettant de trier les ateliers par ordre alphabétique (disponible après un clic droit dans Préférences → Ateliers) a été ajoutée. Pull request #10363
  • Un filtre Rechercher un fichier et un filtre Rechercher dans les fichiers ont été ajoutés à la boîte de dialogue de Std Exécuter une macro. Pull request #10714
  • Le menu Affichage et la barre d'outils de l'Affichage ont été révisés. Pull request #10761
  • Le bouton stop a été supprimé de la barre d'outils des macros. Le bouton Enregistrer est désormais remplacé par un bouton d'arrêt lorsque l'enregistrement est en cours. Pull request #10836
  • Le bouton de réinitialisation dans les Préférences affiche maintenant un menu avec des options pour réinitialiser les paramètres à différents niveaux : tous, dans le groupe actuel ou dans l'onglet actuel. Pull request #10688 et Pull request #11038
  • Le module d'Aide a été fusionné de sorte qu'il n'est plus nécessaire de télécharger une extension pour l'utiliser. Pull request #11008
  • Des préférences pour personnaliser le thème utilisé ont été ajoutées. Pull request #10238
  • Les paramètres de sélection par défaut ont été modifiés pour faciliter la sélection des objets dans la fenêtre 3D. Pull request #11187
  • Un système d'unités en mètres seulement nommé Mètre décimal a été ajouté car le système MKS (m/kg/s/degré) n'entraîne pas toujours l'affichage des dimensions en mètres - les millimètres sont toujours utilisés pour les valeurs inférieures à 0,1 m alors que pour certaines applications (par exemple le génie civil) un système d'unités qui change l'affichage de toutes les dimensions en mètres est utile. Pull request #11365
  • Des tailles de marqueurs supplémentaires (20, 25 et 30px) ont été ajoutées aux Préférences → Affichage → Vue 3D → Taille des marqueurs afin d'aider les utilisateurs d'écrans 4K. Pull request #11524
  • Une option Basculer la transparence a été ajoutée au menu Affichage et au menu contextuel pour activer ou désactiver rapidement la transparence des objets sélectionnés. Pull request #10805
  • Une commande Verrouiller les barres d'outils a été ajoutée. Elle permet de verrouiller ou de déverrouiller les positions des barres d'outils. Elle est disponible dans le menu Affichage et dans le menu contextuel de la barre d'outils. Pull request #11596
  • La couleur de la forme par défaut a été ajustée pour améliorer l'apparence des modèles. Pull request #12380 et Pull request #12488
  • Les éléments dans les conteneurs de pièces et de groupes peuvent maintenant être triés par glisser-déposer. Pull request #12293
  • Les icônes de visibilité (symbole de l'œil) sont ajoutées aux objets de l'arborescence si l'option Afficher l'icône de visibilité est cochée dans Préférences → Affichage → Interface utilisateur. Pull request #12298
  • Un statut de figeage (option Activer/désactiver le figeage dans le menu contextuel de la vue en arborescence) a été ajouté, permettant de désactiver le comportement paramétrique d'un objet (de sorte qu'il ne change pas même si les objets dont il dépend changent). Pull request #12580
  • Une propriété Supprimé a été ajoutée pour désactiver temporairement une fonction. Actuellement, elle est cachée dans l'atelier PartDesign (cliquez avec le bouton droit de la souris dans l'éditeur de propriétés et sélectionnez Afficher tout pour la voir) jusqu'à ce que la correction du problème de dénomination topologique soit terminée. Pull request #12096 et Pull request #12412
  • Les animations de navigation ont été améliorées. Les animations utilisent maintenant une fonction de facilitation et ont une durée fixe qui peut être modifiée dans Préférences → Affichage → Navigation. Pull request #10881 et Pull request #12205
  • Les boutons pour les vues par défaut sont maintenant regroupés sous un seul bouton. Les boutons individuels sont toujours disponibles dans la barre d'outils supplémentaire Vues individuelles. Pull request #12878
  • Le nom du document actif est maintenant également affiché dans la barre de titre de la fenêtre. Pull request #12035
  • Une commande pour afficher le panneau de l'éditeur de propriétés a été ajoutée. Pull request #12024
  • L'intégration des périphériques 3Dconnexion avec FreeCAD sous Windows a été améliorée. Pull request #12929
  • Une fonction de mesure rapide a été ajoutée. Elle utilise la barre d'état pour afficher les principales informations de mesure (longueur des arêtes, surface de la face, distance/angle entre les points/arêtes) concernant la sélection en cours dans la vue 3D. Pull request #12217
  • Les barres d'outils peuvent désormais être glissées et déposées dans les barres d'état et de menu. Pull request #13571
  • Un bouton Recharger la feuille de style a été ajouté pour faciliter le développement des feuilles de style. Il ne fait partie d'aucune barre d'outils par défaut, il doit être ajouté manuellement depuis Outils → Personnaliser → Barres d'outils → Vue. Pull request #13982
  • Les icônes des documents (y compris celles de Ouvrir et Enregistrer, entre autres) ont été améliorées et unifiées. Pull request #13865
  • L'icône Std Tout afficher a été remplacée pour plus de clarté. Pull request #14180
  • Les icônes multiples (telles que Std Nouveau) ont été améliorées. Pull request #14278 et Pull request #14434
  • Les icônes des en-têtes des panneaux de tâches Sketcher et PartDesign ont été améliorées. Pull request #13968
  • En mode FreeCAD sans GUI, la console interactive Python propose désormais la complétion par tabulation, à condition que le module readline soit disponible. Pull request #14213
  • Une option permettant d'afficher les noms internes dans l'arborescence a été ajoutée. Elle est désactivée par défaut et peut être activée dans Préférences → Affichage → Interface utilisateur → Masquer les noms internes. Pull request #14237

Noyau et API

Noyau

  • Les fonctions vectorielles de Vector API peuvent maintenant être utilisées dans des Expressions. Pull request #8603.
  • L'éditeur en Python prend désormais en compte l'indentation de la ligne précédente lorsque l'on appuie sur la touche Entrée. Pull request #11356.
  • Le nom de la propriété contenant le(s) objet(s) de référence d'une pièce jointe a changé de DonnéesSupport à DonnéesAttachmentSupport. Pull request #12714.

API

Nouvelles API en Python

  • getUpDirection : permet d'obtenir la direction vers le haut d'une vue View3DInventor. Pull request #10060

Suppression d'API en Python

API en Python changée

  • Pour sauvegarder/restaurer des données personnalisées à partir d'une fonction en Python, les méthodes jusque là appelées __getstate__/__setstate__ ont été renommées en dumps/loads. Ceci est dû à des changements internes à Python-3.11. Pull request #10769 et Pull request #12243.

Gestionnaire des extensions

Atelier Assembly

Un atelier Assembly intégré a finalement été ajouté à FreeCAD. Il utilise le solveur d'Ondsel open-source. Les fonctions de base (joints) sont déjà disponibles. D'autres développements sont en cours.

Pull request #10427, Pull request #10764, Pull request #12406 et plus encore.

Autres améliorations d'Assembly

  • Les icônes d'Assembly ont été mises à jour et les fonctions expérimentales ont été présentées. Pull request #13866
  • Les liaisons d'angule, perpendiculaire et parallèle ont été ajoutées. Pull request #14008

Atelier BIM

Autres améliorations de BIM

Atelier CAM

Autres améliorations de CAM

  • L'usinage au repos a été réimplémenté pour prendre en compte le G-code des opérations précédentes (au lieu d'utiliser les éléments internes des opérations de zone). Cela permet de prendre en charge l'usinage au repos dans les opérations de surface après les opérations de non surface (notamment Adaptive). Pull request #11939
  • La compensation de la hauteur d'outil G43 a été ajoutée au post-processeur CAM centroïde. Pull request #12652
  • Une option Retrait de l'avance a été ajoutée aux paramètres de l'opération de perçage pour l'alésage et le perçage. Pull request #13254
  • Un nouveau simulateur CAM basé sur des fonctions OpenGL de bas niveau (plus rapide et plus précis) a été ajouté. Pull request #13884
  • L'opération Gravure en V a été retravaillée pour inclure des fonctions communément disponibles dans d'autres logiciels de FAO (Descente, Passe de finition, Optimisation du mouvement de la tête et Méthode débogage de Voronoï) permettant d'améliorer drastiquement la qualité de la surface sculptée tout en augmentant la vitesse de sculpture jusqu'à 50%. Pull request #14093

Atelier Draft

Autres améliorations de Draft

Atelier FEM

La position des étiquettes de la légende des couleurs a été ajustée pour que celles du haut soient moins susceptibles d'être couvertes par le cube de navigation. La police et la couleur par défaut des étiquettes ont été modifiées pour augmenter la visibilité et des préférences ont été ajoutées pour permettre la modification de la couleur et de la taille des étiquettes.

Pull request #10552

La commande FEM Graphique de linéarisation des critères peut désormais utiliser les composantes du tenseur des contraintes pour les calculs de critères linéarisés. Auparavant, seules les critères de von Mises, de Tresca et les contraintes principales (majeures/intermédiaires/mineures) pouvaient être utilisées à cette fin.

Pull request #11724

La prise en charge de la symétrie cyclique via la contrainte de liaison dans CalculiX a été ajoutée, rendant possible l'analyse de modèles avec une symétrie périodique de rotation en utilisant un seul secteur répétitif.

Pull request #12289

La prise en charge des analyses 2D (contraintes planes, déformations planes et axisymétriques) a été ajoutée au solveur CalculiX. Elles sont configurées de la même manière que les simulations avec des éléments de coque, mais il y a quelques restrictions supplémentaires décrites sur la page wiki mentionnée ci-dessus. La nouvelle option Model Space doit être configurée correctement. Pull request #12562
En tant que première étape vers la prise en charge des éléments hexaédriques, leur génération à l'aide de la technique de subdivision de Gmsh est désormais possible grâce à la nouvelle propriété Subdivision Algorithm de Gmsh. Elle peut également être utilisée pour créer des éléments quadrilatéraux. Pull request #12698
De nouvelles propriétés d'affichage ont été ajoutées aux objets du pipeline de résultats. La couleur et la largeur des arêtes des maillages peuvent maintenant être modifiées pour le mode d'affichage Surface avec arêtes. La taille des nœuds peut être modifiée pour le mode Nœuds. Il y a également un paramètre de transparence pour tous les modes. Pull request #13066
Les contraintes FEM peuvent désormais être désactivées (clic droit sur une contrainte et sélection de Désactiver) et donc ignorées par les solveurs. De cette façon, il est possible de modifier la configuration de l'analyse sans avoir à supprimer les contraintes qui ne sont pas nécessaires. Pull request #12359
La prise en charge de la contrainte de corps rigide de CalculiX a été ajoutée, ce qui permet enfin de simuler la torsion de composants arbitraires et d'appliquer des charges à distance, entre autres. Pull request #13900

Autres améliorations de FEM

  • Le menu Modèle → Contraintes sans solveur a été supprimé de l'interface graphique. Les contraintes listées ne pouvaient pas être utilisées. Pull request #10457 et Pull request #10459
  • Le mot contrainte a été supprimé des noms et des descriptions de la plupart des fonctions de l'atelier FEM afin de garantir une nomenclature correcte. Les noms ont été modifiés de manière à correspondre aux normes de l'industrie de l'analyse par éléments finis et à les rendre intuitifs pour les nouveaux utilisateurs. Pull request #10519 et Pull request #10799
  • De nouvelles icônes ont été ajoutées pour le Solveur CalculiX standard, Réglage du solveur et Résolution pour une plus grande intuitivité. Ses exemples ont également été supprimés. Pull request #10823 et Pull request #12876
  • Le solveur CalculiX (expérimental) a été supprimé de l'interface graphique car il n'est pas terminé et inutile pour le moment. Pull request #10823
  • La disposition de certains panneaux de tâches des outils de post-traitement a été améliorée afin de réduire la taille de l'espace horizontal qu'ils occupaient. Pull request #11066
  • Le panneau de tâches de FEM Condition limite de température a été retravaillé pour résoudre des problèmes lors de l'édition de cette fonction. Pull request #11126
  • Un ancien problème avec le FEM Filtre d'écrêtage selon une ligne ne pouvant tracer que la magnitude et non les composantes vectorielles d'une variable de sortie sélectionnée a finalement été corrigé. Pull request #10992
  • La FEM Charge d'effort et la FEM Charge de pression ont été révisées afin d'améliorer leur fonctionnement du côté du code source. Pull request #10935 et Pull request #10923
  • Le FEM Données au point a maintenant une propriété PointSize pour définir la taille du symbole du point pour plus de visibilité. Pull request #11054
  • Pour plus de clarté, la commande de FEM Région de maillage FEM a été renommée en Mailler plus finement FEM dans l'interface graphique (le nom de la commande reste inchangé). Pull request #11489
  • La magnitude de l'accélération de la gravité peut maintenant être modifiée en utilisant les propriétés de FEM Charge de gravité. Pull request #12044
  • Contrainte de contact et Contrainte de liaison ont été améliorées de manière significative. La rigidité du contact utilise maintenant la bonne unité et la valeur de la pente de contact peut être spécifiée pour le frottement dans le contact. De plus, l'ajustement du jeu peut être spécifié pour le contact tandis que la contrainte de liaison peut avoir l'ajustement activé ou désactivé. Pull request #12133
  • PaStiX et Pardiso ont été ajoutés aux solveurs matriciels de CalculiX supportés. Ce sont les solveurs ccx les plus rapides mais la possibilité de les utiliser dépend de la version binaire de CalculiX et des bibliothèques additionnelles disponibles. Pull request #12478
  • La propriété Beam Reduced Integration (fixée à true par défaut) a été ajoutée aux paramètres du solveur CalculiX. Elle permet un schéma d'intégration réduit pour les éléments de type poutre, rendant possible l'utilisation de la section de type poutre tubulaire et éliminant les problèmes de précision dans les analyses avec plasticité, entre autres. Pull request #12513
  • L'outil inachevé Ensemble de nœuds a été supprimé de l'interface graphique. Il ne pouvait pas être utilisé. Pull request #12611
  • La procédure d'analyse Vérification du maillage de CalculiX génère désormais correctement le maillage des résultats. Pull request #12612
  • Le panneau des tâches précise que le diamètre utilisé pour la section de tuyau est le diamètre extérieur. Pull request #12609
  • La propriété Beam Shell Result Output 3D du solveur CalculiX est maintenant définie à true par défaut pour fournir des résultats pour les éléments de type poutre et fournir des résultats significatifs pour les éléments de type coque. Pull request #12493
  • Les symboles des fonctions d'analyse sont désormais correctement positionnés lorsque le corps (ou le conteneur de pièce) a eu modifié sa propriété de placement. Pull request #12527
  • Charge de pression fonctionne désormais correctement pour les coques, quel que soit le réglage des groupes de maillage. Ce paramètre peut être modifié dans les préférences. Pull request #12437
  • L'écrouissage simple dans FEM Matériau mécanique non linéaire a été renommé en écrouissage isotrope. De plus, l'écrouissage cinématique a été ajouté. Pull request #12666
  • La non-linéarité géométrique n'est plus automatiquement activée et requise lorsqu'un matériau non-linéaire est utilisé. Il s'agit de formes indépendantes de non-linéarité. Pull request #12703
  • Les maillages mixtes composés d'éléments triangulaires et quadrilatéraux sont désormais affichés correctement dans le pipeline de résultats. Pull request #12740
  • La propriété Output Frequency a été ajoutée aux paramètres du solveur CalculiX. Elle définit la fréquence d'écriture des sorties par incréments. Pull request #12672
  • Les éléments quadrilatéraux de second ordre peuvent maintenant être générés. Auparavant, le paramètre Gmsh d'ordre 2 générait des éléments quadrilatéraux d'ordre 1 en raison de l'absence d'une commande Gmsh SecondOrderIncomplete qui est maintenant utilisée en interne. Ces éléments peuvent également être utilisés pour les analyses 2D. Pull request #12698 et Pull request #12774
  • La détermination de l'orientation de la section transversale d'un élément de type poutre a été partiellement corrigée. En raison d'un bogue dans la version actuelle de CalculiX, il peut encore y avoir des problèmes avec certaines orientations. Pull request #12833
  • Les exemples Cantilever FEM sur la page de démarrage ont été mis à jour et un nouvel exemple utilisant des éléments 1D a été ajouté. Pull request #12871
  • Le format dans lequel FreeCAD écrit la charge d'effort est maintenant compatible avec le format CalculiX, éliminant les rares problèmes avec des nombres trop longs. Pull request #12932
  • Il est maintenant possible d'exporter les résultats du pipeline au format VTK. Pull request #12987
  • De nouvelles propriétés de contrôle de l'incrémentation ont été ajoutées aux paramètres du solveur CalculiX. Actuellement, en plus de la taille de l'incrément initial et de la périodicité de l'étape, on peut spécifier la taille minimale et maximale de l'incrément. De plus, la propriété Itérations Thermo Mech Maximum a été renommée en Itérations Maximum car elle peut maintenant être utilisée pour les analyses statiques (non thermomécaniques) également. Pull request #12662
  • L'[[FEM_ElementGeometry2D/fr|épaisseur par défaut d'éléments] 2D] a été changée de 20 mm à 1 mm, ce qui est plus logique dans la pratique. Pull request #13077
  • De nombreuses icônes de FEM ont été améliorées de manière significative afin de réduire leur similarité et de rendre plus clair ce que font les outils. Pull request #13130
  • La propriété Thermo Mech Type a été ajoutée aux paramètres du solveur CalculiX. Elle permet de passer d'une analyse thermomécanique classique (couplée) à une analyse découplée ou à une analyse de pur transfert de chaleur. Pull request #13296
  • La propriété Taille minimum a été ajoutée au mailleur Netgen afin d'éviter la génération d'éléments trop petits lors du maillage de géométries plus complexes. Pull request #12794
  • Un ancien problème avec une propriété d'échelle de symbole non fonctionnelle pour les contraintes FEM a finalement été corrigé et la propriété Scale peut maintenant être utilisée pour ajuster la taille des symboles d'une contrainte sélectionnée. Pull request #13274
  • La mise à l'échelle automatique des contraintes FEM a été améliorée pour mieux gérer les objets très petits et très grands. Pull request #13586
  • Charge de flux de chaleur dispose désormais d'un mode de flux de chaleur par rayonnement pour modéliser le rayonnement de la surface vers l'environnement. Pull request #13466
  • Quelques propriétés inutilisées du symbole de contrainte View ont été supprimées. Pull request #13569
  • De nouvelles propriétés d'affichage (dont la principale est Mode couleur) ont été ajoutées aux objets de maillage FEM afin que les paramètres personnalisés de couleur et de transparence pour les maillages puissent être sauvegardés et restaurés. Pull request #13698
  • Maintenant, seul le dernier filtre ajouté sous chaque objet du pipeline de résultats est visible par défaut. Pull request #13820
  • Les astuces du panneau de tâches de plusieurs contraintes ont été modifiées afin de refléter les règles de sélection de la géométrie pour ces contraintes. Pull request #13921 et Pull request #14002
  • La prise en charge des résultats de flux de chaleur provenant d'analyses thermomécaniques a été ajoutée au pipeline de résultats. Pull request #14019
  • L'affichage des variables de sortie a été amélioré, en ajoutant la prise en charge des résultats de flux de chaleur et de contrainte de traînée (pas encore disponible car les analyses de fluides 3D avec CalculiX n'ont pas encore été implémentées). Pull request #14046
  • Source de chaleur du corps peut maintenant être utilisé avec CalculiX et a deux modes d'entrée : taux de dissipation [W/kg] et puissance totale [W]. Pull request #14417
  • Les propriétés de rotation du Système de coordonnées locales ont été remplacées par une seule propriété Rotation pour des raisons de cohérence. Pull request #14353

Matériau

Le système de gestion des matériaux, y compris l'éditeur, a été entièrement retravaillé. D'autres améliorations à cet égard suivront.

Pull request #10690

L'aperçu de l'apparence a été ajouté pour montrer les matériaux de la même manière qu'ils seront montrés dans les documents.

Pull request #11628

Le nouveau système de matériaux est maintenant utilisé pour les propriétés d'apparence.

Pull request #13294

Autres améliorations de Material

  • Des boîtes de dialogue permettant de visualiser les propriétés d'apparence et de matériau d'un objet ont été ajoutées et sont disponibles en tant qu'outils Inspecter l'apparence et Inspecter le matériau. Pull request #13967

Mesh

Autres améliorations de Mesh

Atelier OpenSCAD

Autres améliorations de OpenSCAD

Atelier Part

L'outil Part Échelle a été ajouté pour faciliter la mise à l'échelle des formes sans avoir à utiliser les outils de l'atelier Draft.

Pull request #10583

Part Miroir prend désormais en charge les objets de référence, tel qu'un Part Plan pour définir un plan miroir arbitraire en plus des plans XY, XZ et YZ standard.

Pull request #11535

Autres améliorations de Part

  • La propriété Frenet est désormais activée par défaut pour l'outil Part Balayage afin d'éviter un problème de rendu courant. Pull request #11590
  • Toutes les icônes de Part utilisent maintenant le thème bleu et les primitives utilisent la même icône pour la barre d'outils et la vue en arborescence. Pull request #14074
  • La commande Create sketch a été ajoutée à la barre d'outils et au menu de Part car des opérations telles que l'extrusion utilisent généralement des esquisses en entrée. Pull request #14318
  • Un nouveau mode d'ancrage appelé XY parallèle au plan a été ajouté. Il permet d'obtenir un accrochage similaire à XY de l'objet, mais avec le plan XY translaté pour passer par un sommet sélectionné. Contrairement au mode d'accrochage Translater l'origine, il ne déplace pas l'origine dans une esquisse/2D. Il peut être utilisé avec les plans d'origine, les plans de référence et les esquisses, mais aussi avec tout objet ayant une propriété Placement. Pull request #14372

Atelier PartDesign

Des modes supplémentaires ont été ajoutés aux fonctions Révolution et Rainure, vers la première/dernière face, jusqu'à la face et deux dimensions.

Pull request #7193

Les panneaux de tâches de Protrusion et de Cavité ont été améliorés (réorganisation des éléments de l'interface utilisateur. L'option Sélectionner une face est cachée lorsqu'elle n'est pas nécessaire et ainsi de suite).

Pull request #10392

Le mode décalage a été ajouté à Répétition linéaire et Répétition circulaire. Le mode précédent a été renommé Longueur totale.

Pull request #10377

Une prise en charge expérimentale pour plusieurs solides dans un corps a été ajoutée. Elle peut être activée dans les préférences (pour les nouveaux corps) ou dans les propriétés d'un corps existant.

Pull request #13960

Le mode Jusqu'à la forme a été ajouté pour les protrusions, permettant de terminer l'extrusion sur plusieurs faces, contrairement au mode Jusqu'à la face qui ne permet de sélectionner qu'une seule face.

Pull request #11392 et Pull request #14433

Autres améliorations de PartDesign

  • L'option Générer un évidement vers l'intérieur est maintenant activée par défaut pour l'outil Évidement. Pull request #7488
  • Les points de référence changent désormais de couleur lorsqu'ils sont mis en évidence ou sélectionnés (comme les autres points de référence). Pull request #12439
  • Les icônes de PartDesign ont été légèrement améliorées pour plus de cohérence. Pull request #13109
  • Une propriété Désactiver a été ajoutée pour désactiver temporairement une fonction. Pull request #12096 et Pull request #12412
  • Les barres d'outils de PartDesign ont été mises à jour : les référentiels et les actions basées sur les esquisses sont désormais regroupés, Part Vérifier la géométrie a été ajouté à la barre d'outils et au menu. Les barres d'outils ont été divisées en plusieurs barres individuelles pour permettre de les réorganiser. Pull request #13833
  • Un nouveau mode Transformer le corps a été ajouté aux outils de miroir et de motif de PartDesign, permettant de transformer la forme de l'élément de base au lieu de chaques formes des outils des éléments additifs et soustractifs. Pull request #12589

Atelier Points

Autres améliorations de Points

Atelier Sketcher

L'implémentation d'une superposition de cercles pour les arcs (pour résoudre le problème des contraintes apparaissant loin d'eux) a été complétée avec une commande pour les interchanger.

Pull request #9703


Cliquez sur l'image si l'animation ne démarre pas.
Un outil de contrainte contextuelle de Dimension a été ajouté pour permettre un dimensionnement rapide et intuitif à l'aide d'un seul outil polyvalent.

Pull request #9810


Cliquez sur l'image si l'animation ne démarre pas.
Des paramètres d'outils ont été ajoutés pour permettre l'ajout de dimensions lors du dessin des formes. En fonction du réglage des préférences de Paramètres dans la vue, ils peuvent être désactivés, réduits aux dimensions uniquement (pas de coordonnées initiales) ou entièrement activés. De plus, des modes ont été ajoutés pour les outils de forme. Ils peuvent être sélectionnés à l'aide de la touche M ou d'une liste déroulante dans le panneau des tâches. Certains outils disposent de paramètres supplémentaires sous la forme de cases à cocher dans le panneau des tâches et de raccourcis clavier supplémentaires. Actuellement, les nouvelles fonctions sont disponibles pour les points, les lignes, les arcs, les ellipses, les rectangles, les polygones et les rainures. En cours de réalisation.

Pull request #11048, Pull request #11174 et suivants

Un outil de décalage a été ajouté pour permettre le décalage de courbes.

Pull request #11174

Le mode rectangle à trois points a été ajouté en deux versions : 3 coins, centre ou 2 coins.

Pull request #11174

Un outil de rainure en arc a été ajouté avec deux modes (extrémités en arc et extrémités plates) pour permettre la création de rainures courbes.

Pull request #11174


Cliquez sur l'image si l'animation ne démarre pas.
Une contrainte horizontale/verticale a été ajoutée. Elle applique automatiquement une contrainte horizontale si une ligne est plus proche de l'orientation horizontale ou une contrainte verticale si elle est plus proche de l'orientation verticale.

Pull request #11538

Le rendu des contraintes d'angle et de rayon a été amélioré. Les contraintes d'angle ont maintenant des lignes d'extension complètes.

Pull request #11507

Un outil de transformation polaire a été ajouté pour permettre la rotation et les motifs circulaires des géométries de l'esquisse.

Pull request #11264


Cliquez sur l'image si l'animation ne démarre pas.
Il est désormais possible de copier/couper et coller une géométrie d'esquisse (avec des contraintes) en utilisant les raccourcis clavier habituels : Ctrl+C, Ctrl+X et Ctrl+V. Non seulement à l'intérieur d'une même esquisse, mais aussi entre différentes esquisses ou même différentes instances de FreeCAD. La géométrie est copiée sous forme de commandes Python, de sorte qu'elle peut être utilisée d'autres manières (par exemple, partagée sur le forum).

Pull request #11537

Un outil de transformation de mise à l'échelle a été ajouté, permettant de mettre à l'échelle la géométrie dans l'esquisse en utilisant un point central sélectionné et un facteur d'échelle ou deux points de référence.

Pull request #11265


Cliquez sur l'image si l'animation ne démarre pas.
La tangence au bord des B-splines a été ajoutée, éliminant le besoin d'utiliser les points d'extrémité et divers contournements à la place.

Pull request #11853

Les outils de répétition linéaire, déplacement, Copie et clonage ont été remplacés par un seul outil Déplacer/dupliquer.

Pull request #11267

Un outil Chanfrein a été ajouté avec une option permettant de passer en mode Congé. De plus, il n'y a plus d'outil séparé pour les congés préservant l'angle. Une option Conserver le coin (cochée par défaut) a été ajoutée à l'outil Congé.

Pull request #12898


Cliquez sur l'image si l'animation ne démarre pas.
L'outil Symétriser a été retravaillé. Il fonctionne désormais en présélectionnant la géométrie et en choisissant une ligne ou un point autour duquel la géométrie sera symétrisée. Un aperçu est affiché et le comportement de l'outil peut être contrôlé par les paramètres de l'outil.

Pull request #11853


Cliquez sur l'image si l'animation ne démarre pas.
La Contrainte symétrique est désormais applicable automatiquement lorsque le point médian d'une ligne est choisi.

Pull request #13147

La Contrainte de distance peut maintenant être utilisée pour les contraintes de longueur d'arc (l'arc circulaire doit être présélectionné).

Pull request #12602

La couleur de rendu des points est maintenant différente selon qu'il s'agit d'un point normal/terminal (blanc, maintenant créé par défaut lors de l'utilisation de l'outil Point), d'un point de construction/centre (bleu) ou d'un point coïncidant avec un autre (rouge).

Pull request #13098


Cliquez sur l'image si l'animation ne démarre pas.
L'outil Ajuster peut maintenant être utilisé en mode maintenir et faire glisser.

Pull request #13188

Autres améliorations de Sketcher

Atelier Spreadsheet

Autres améliorations de Spreadsheet

  • Double-cliquer sur une feuille de calcul dans la vue en arborescence permet désormais de basculer vers cet atelier. Pull request #13137
  • Les icônes de Spreadsheet ont été améliorées. Pull request #13996

Atelier Start

Une section Nouveau fichier comprenant un certain nombre de boutons de démarrage rapide a été ajoutée à la page de démarrage.

Pull request #10171

La page d'accueil a été revue. Elle est désormais plus moderne et plus cohérente.

Pull request #10391

Un widget simple au démarrage a été ajouté et sera étendu dans un futur proche.

Pull request #13650

Autres améliorations de Start

  • La page des préférences de l'atelier Start a été réorganisée. Pull request #10520
  • Il y a maintenant une option CSS personnalisé pour la page de démarrage qui vous permet de personnaliser le style CSS de la page de démarrage à partir des préférences de l'atelier Start. Pull request #10520
  • La préférence Masquer les barres de défilement a été supprimée. Les barres de défilement de la page d'accueil prenent le style en fonction du thème et sont beaucoup plus fines. Pull request #10520
  • Il y a maintenant des préférences pour cacher et changer la taille des icônes des vignettes des fichiers sur la page d'accueil. Pull request #10410
  • La page Start est désormais une application basée sur les QtWidgets et non plus un atelier. Elle peut être affichée en utilisant l'option Aide → Start. Pull request #13134

Atelier Surface

Autres améliorations de Surface

Atelier TechDraw

L'outil Cercle cosmétique a été ajouté pour permettre la création de cercles cosmétiques en sélectionnant le centre et en saisissant le rayon.

Pull request #10763

L'outil Longueur d'arc d'arêtes a été ajouté pour créer des annotations de type dimensionnel de la longueur d'arc d'arêtes sélectionnées.

Pull request #11532

L'outil Sommets décalés a été ajouté pour créer des sommets cosmétiques en décalage par rapport aux sommets sélectionnés.

Pull request #11655

L'outil Vue interrompue a été ajouté pour représenter facilement les objets longs.

Pull request #13331


Cliquez sur l'image si l'animation ne démarre pas.
Un nouvel outil de dimension contextuel a été ajouté, basé sur celui introduit dans Sketcher.

Pull request #13525

Autres améliorations de TechDraw

  • Les sections basées sur d'autres sections utilisent désormais par défaut la forme originale (non coupée). Ceci peut être modifié dans les paramètres de la section pour utiliser la section précédente à la place. Pull request #10281
  • Les objets cosmétiques et les lignes centrales peuvent désormais être supprimés en les sélectionnant et en appuyant sur la touche Suppr. Auparavant, cela entraînait la suppression de la vue entière. Pull request #10695 et Pull request #10813
  • Une nouvelle icône plus intuitive a été ajoutée pour l'outil Soudure. Pull request #10936
  • Le comportement du mode point + arête de l'outil Cote de longueur a été corrigé. Pull request #10860
  • Un état vérifié a été ajouté pour le bouton Bascule des cadres afin qu'un utilisateur puisse voir si le bouton est activé ou non. Pull request #11240
  • Le comportement de l'outil Apparence des lignes a été amélioré. Maintenant, double-cliquer sur une ligne appelle cet outil. Et les styles de lignes sont correctement restaurés si l'utilisateur appuie sur « Annuler ». Auparavant, il n'y avait aucune différence entre appuyer sur « OK » et « Annuler ». Pull request #11188
  • La couleur et la transparence des faces peuvent désormais être définies par vue. Pull request #11315
  • Le mode multisélection a été ajouté et peut être activé dans les préférences. Dans ce mode, plusieurs sommets, arêtes et faces peuvent être sélectionnés en cliquant dessus avec le bouton gauche de la souris, sans avoir à maintenir la touche Ctrl enfoncée. Pull request #11417
  • Surface peut maintenant calculer les surfaces de faces arbitraires. Pull request #11473
  • Les lignes non continues suivront désormais les normes ISO/ANSI au lieu du style des lignes de Qt. Une nouvelle préférence a été ajoutée pour sélectionner la norme. Pull request #11594
  • Le comportement de l'outil Cote axonométrique a été amélioré. Désormais, lors de la cotation d'arêtes parallèles aux axes du système de coordonnées global, la valeur réelle (3D) est calculée automatiquement et insérée dans la propriété Format Spec (sous forme de texte). Pull request #11678
  • L'outil Positionner une vue en coupe peut maintenant être utilisé en sélectionnant une arête dans une vue de coupe et un sommet dans la vue source. Pull request #11797
  • Des améliorations mineures mais importantes ont été apportées à l'utilisation : un double-clic sur la page TechDraw permet désormais d'accéder à cet atelier et l'outil TechDraw Déplacer une vue a été remplacé par un simple glisser-déposer dans la vue en arborescence. Les outils TechDraw Ajout vue dans une fenêtre de rognage et TechDraw Suppression vue d'une fenêtre de rognage ont également été remplacés par un simple glisser-déposer dans l'arborescence. Pull request #13063
  • L'outil Projection de forme a été supprimé de TechDraw car il provenait de l'ancien atelier Drawing et n'avait rien à voir avec une page TechDraw. Pull request #13655
  • L'outil Vue a été amélioré afin qu'il puisse gérer plus de types d'objets et de paramètres. Cela a permis de supprimer les outils suivants de la barre d'outils : Vue d'un objet Spreadsheet, Vue d'un objet Arch, Symbole, Image et Groupe de projections. Pull request #13219
  • L'accrochage a été ajouté pour permettre l'alignement automatique des vues et des dimensions. Pull request #13659
  • La gestion des cosmétiques a été améliorée de diverses manières. Pull request #14216

Compilation

Limitations connues