Jump to content

Std Nouveau document

From FreeCAD Documentation
This page is a translated version of the page Std New and the translation is 100% complete.

Std Nouveau

Emplacement du menu
Fichier → Nouveau document
Ateliers
Tous
Raccourci par défaut
Ctrl+N
Introduit dans la version
-
Voir aussi
Std Ouvrir, Std Importer

Description

La commande Std Nouveau document crée un nouveau document vide et en fait le document actif.

Utilisation

  1. Lancez la commande de plusieurs manières :
  2. * Sélectionnez l'option Fichier → Nouveau document du menu.
  3. * Utilisez le raccourci clavier : Ctrl+N.

Préférences

Voir aussi : Réglage des préférences.

  • Par défaut, FreeCAD démarre sans nouveau document. Cochez l'option Édition → Préférences → Général → Document → Créer un nouveau document au démarrage pour modifier ce comportement.
  • Certaines propriétés du document : nom de l'auteur, nom de la société et informations de licence, peuvent être prédéfinies : Édition → Préférences → Général → Document → Création et licence.

Propriétés

Voir aussi : Éditeur de propriétés

La plupart des propriétés peuvent également être modifiées dans la boîte de dialogue de la commande Std Informations sur le document.

Données

Base

  • DonnéesComment (String) : tout commentaire éventuel.
  • DonnéesCompany (String) : nom de l'entreprise.
  • DonnéesCreated By (String) : nom de l'auteur.
  • DonnéesCreation Date (String) : horodatage automatique (en lecture seule).
  • DonnéesNom du fichier (Chaîne) : chemin complet du fichier. Blanc si le document n'a pas été enregistré (lecture seule).
  • DonnéesId (String) : pas encore implémenté.
  • DonnéesLabel (String) : le nom qui apparaîtra dans l'arborescence. Remplacé par le nom du document après réouverture.
  • DonnéesLast Modified By (String) : nom de l'auteur.
  • DonnéesLast Modified Date (String) : horodatage automatique (en lecture seule).
  • DonnéesLicense (String) : type de licence.
  • DonnéesLicense URL (String) : URL de la licence.
  • Données (Hidden)Material (Map) : associé aux propriétés des matériaux.
  • Données (Caché)Meta (Map) : associé à des méta-informations supplémentaires.
  • DonnéesShow Hidden (Bool) : si true, les éléments qui ont été cachés dans l'arborescence seront quand même affichés. Cacher des éléments dans l'arborescence peut s'avérer utile lorsque l'on travaille sur des modèles de grande taille.
  • DonnéesTip (Link) : pas encore implémenté.
  • DonnéesTip Name (String) : pas encore implémenté.
  • DonnéesTransient Dir (String) : répertoire de transition utilisé pour les données de récupération (en lecture seule).
  • Données (Hidden)Uid (UUID) : UUID du document (en lecture seule).
  • DonnéesUnit System (Enumeration) : système d'unité du document. La valeur initiale dépend du système d'unités par défaut. introduit dans la version 1.0
  • DonnéesUse Hasher (Bool) : si la valeur est true, un hasher est utilisé pour atténuer le problème de dénomination topologique. introduit dans la version 1.0

Script

Voir aussi : Autogenerated API documentation et FreeCAD Débuter avec les scripts.

Pour créer un nouveau document, utilisez la méthode newDocument([name], [hidden=False]) de l'application FreeCAD. Le nom du document doit être unique, ce qui est vérifié automatiquement. Si aucun nom n'est fourni, le document sera nommé « Sans titre ». Si hidden=True est utilisé, le nouveau document ne sera pas affiché dans l'interface graphique et aucun onglet n'apparaîtra pour ce document.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = "D:/testfiles/"
fnm = fld + "test.FCStd"

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)