Note di rilascio della versione 1.0

From FreeCAD Documentation
This page is a translated version of the page Release notes 1.0 and the translation is 100% complete.
FreeCAD 1.0 è in fase di sviluppo, non è ancora prevista una data di rilascio.

Mancano funzionalità? Menzionarle nel thread del forum Release notes for v1.0.

Vedere Help FreeCAD per le modalità con cui contribuire a FreeCAD.

Tutte le immagini in questa pagina devono utilizzare il suffisso _relnotes_1.0


FreeCAD 1.0 è stato rilasciato il DD MM 2024, scaricalo dalla pagina Download. Questa pagina elenca tutte le nuove funzionalità e modifiche.

Le note di rilascio delle versioni precedenti di FreeCAD sono disponibili alla pagina Funzionalità.

Segnaposto per un'immagine accattivante selezionata dagli amministratori dal forum delle vetrine degli utenti.

Aspetti generali

L'annoso Problema di denominazione topologica è stato finalmente affrontato grazie allo sforzo congiunto e al duro lavoro di diversi sviluppatori. La Realthunder algorithm è stata attentamente implementata e migliorata per funzionare nella versione master di FreeCAD. Il progetto ha richiesto più di un anno, e l'implementazione iniziale è stata finalizzata con la seguente PR che ne ha consentito il miglioramento. Seguiranno test approfonditi e correzione di bug.

Pull request #13705

FreeCAD ha un nuovo logo. È stato selezionato tra i 5 vincitori del concorso pubblico.

Pull request #14284

Interfaccia utente

È stato aggiunto un indicatore del centro di rotazione. Questo indicatore viene visualizzato quando la vista viene ruotata trascinando il mouse. Facoltativamente può essere disabilitato nelle preferenze.

Ci sono anche impostazioni per colore, trasparenza e dimensione. Pull request #9909 e Pull request #10790


Clicca sull'immagine se l'animazione non si avvia.
Sono stati aggiunti filtri di selezione, facilitando la selezione di vertici, bordi e facce.

Pull request #10271

Per una maggiore flessibilità, il pannello delle attività è ora un widget agganciabile autonomo, ma il vecchio layout viene mantenuto per impostazione predefinita.

Pull request #10681 e Pull request #10848

L'aspetto dello strumento Trasforma è stato migliorato. Ora dispone anche di una serie di trascinatori planari per spostare gli oggetti lungo i 3 piani predefiniti.

Pull request #10706

È stata aggiunta la funzionalità di Realthunder che consente la sovrapposizione dei widget del dock (trasparenza dell'albero e delle attività).

Pull request #7888

La posizione della sorgente luminosa può ora essere impostata nelle preferenze (Preferenze → Display).

Pull request #11146

La finestra Preferenze è stata ridisegnata per sostituire le schede con una visualizzazione ad albero.

Pull request #11018

È stato aggiunto il selettore TabBar degli ambienti di lavoro. Può essere abilitato e configurato in Preferenze → Ambienti di lavoro.

Pull request #12270

È stato aggiunto un nuovo strumento di misurazione universale , in sostituzione dei vecchi Strumenti di misurazione Part.

Pull request #9750 e seguenti


Clicca sull'immagine se l'animazione non si avvia.
È stato aggiunto lo strumento di visualizzazione "Allinea alla selezione", che consente di inserire viste normali alle facce o seguendo le direzioni dei bordi.

Pull request #13906

Ulteriori miglioramenti dell'interfaccia utente

  • È stato introdotto un sistema di unità di progetto. Pull request #9521
  • Lo strumento Taglio sezione persistente ora funziona anche in una vista prospettica. Pull request #10143
  • È stata aggiunta un'opzione per ordinare gli ambienti di lavoro in ordine alfabetico (disponibile dopo aver fatto clic con il tasto destro in Preferenze → Ambienti di lavoro). Pull request #10363
  • Un filtro Trova file e un filtro Trova nei file sono stati aggiunti alla finestra di dialogo Esegui la macro. Pull request #10714
  • Il Menu Visualizza e la barra degli strumenti Visualizza sono stati rivisti. Pull request #10761
  • Il pulsante di arresto è stato rimosso dalla barra degli strumenti Macro. Il pulsante di registrazione ora è diventato un pulsante di arresto quando la registrazione è in corso. Pull request #10836
  • Il pulsante di ripristino nelle Preferenze ora mostra un menu con opzioni per ripristinare le impostazioni a diversi livelli: tutto, nel gruppo corrente o nella scheda corrente. Pull request #10688 e Pull request #11038
  • Il modulo Guida è stato unificato in modo che non sia più necessario scaricare un componente aggiuntivo per utilizzarlo. Pull request #11008
  • Sono state aggiunte le preferenze per personalizzare il tema corrente. Pull request #10238
  • Le impostazioni di selezione predefinite sono state modificate per rendere più semplice la selezione degli oggetti nella finestra 3D. Pull request #11187
  • È stato aggiunto uno schema di unità solo per metri denominato Metro decimale poiché il sistema MKS (m/kg/s/gradi) non sempre comporta la visualizzazione delle dimensioni in metri: i millimetri vengono ancora utilizzati per i valori inferiori 0,1 m mentre per alcune applicazioni (ad es. ingegneria civile) è utile un sistema di unità che converta effettivamente la visualizzazione di tutte le dimensioni in metri. Pull request #11365
  • Ulteriori dimensioni dei marcatori (20, 25 e 30px) sono state aggiunte a Preferenze → Display → Vista 3D → Dimensioni marcatore per assistere gli utenti di schermi 4K. Pull request #11524
  • Un'opzione "Attiva/disattiva trasparenza" è stata aggiunta ai menu Vista e contestuali per attivare o disattivare rapidamente la trasparenza per gli oggetti selezionati. Pull request #10805
  • È stato aggiunto il comando Blocca barre degli strumenti. Con esso le posizioni della barra degli strumenti possono essere bloccate o sbloccate. È disponibile nel menu Visualizza e nel menu contestuale dell'area degli strumenti. Pull request #11596
  • Il colore predefinito della forma (shape) è stato modificato per migliorare l'aspetto dei modelli. Pull request #12380 e Pull request #12488
  • Gli elementi all'interno dei contenitori Part e Gruppo ora possono essere ordinati trascinandoli. Pull request #12293
  • Le icone di visibilità (simbolo dell'occhio) vengono aggiunte agli oggetti dell'albero se l'opzione Mostra icona di visibilità è selezionata in Preferenze → Visualizzazione → IU. Pull request #12298
  • È stato aggiunto uno stato congelato (opzione Attiva/disattiva congelamento nel menu contestuale in vista ad albero), rendendo possibile disattivare il comportamento parametrico di un oggetto (in modo che non cambi nemmeno se gli oggetti da cui dipende cambiano). Pull request #12580
  • È stata aggiunta una proprietà "Soppresso" per disattivare temporaneamente una funzionalità. Attualmente, è nascosto nell'ambiente PartDesign (fare clic con il pulsante destro del mouse su Editor proprietà e selezionare Mostra tutto per vederlo) fino al completamento della correzione del TNP. Pull request #12096 e Pull request #12412
  • Le animazioni di navigazione sono state migliorate. Le animazioni ora utilizzano una funzione di andamento e hanno una durata fissa che può essere modificata in Preferenze → Visualizzazione → Navigazione. Pull request #10881 e Pull request #12205
  • I pulsanti per le visualizzazioni predefinite sono ora raggruppati sotto un unico pulsante. I singoli pulsanti sono ancora disponibili nella barra degli strumenti aggiuntiva Viste individuali. Pull request #12878
  • Il nome del documento attivo corrente viene ora visualizzato anche nella barra del titolo della finestra. Pull request #12035
  • È stato aggiunto un comando per visualizzare il pannello Vista proprietà. Pull request #12024
  • L'integrazione dei dispositivi 3Dconnexion con FreeCAD su Windows è stata migliorata. Pull request #12929
  • È stata aggiunta una funzione Misura Rapida. Utilizza la Barra di stato per visualizzare le informazioni chiave sulla misurazione (lunghezza del bordo, area della faccia, distanza/angolo tra punti/bordi e raggio di bordi circolari/facce cilindriche) sulla selezione corrente nella vista 3D. Pull request #12217
  • Le barre degli strumenti ora possono essere trascinate e rilasciate sulle barre di stato e dei menu. Pull request #13571
  • È stato aggiunto un pulsante Ricarica foglio di stile per facilitare lo sviluppo del foglio di stile. Per impostazione predefinita non appartiene a nessuna barra degli strumenti, deve essere aggiunto manualmente da Strumenti → Personalizza → Barre degli strumenti → Visualizza. Pull request #13982
  • Le icone dei documenti (incluse quelle Apri e Salva, tra le altre) sono state migliorate e unificate. Pull request #13865
  • L'icona Visualizza tutto è stata sostituita per maggiore chiarezza. Pull request #14180
  • Sono state migliorate ulteriori icone principali (come Nuovo). Pull request #14278, Pull request #14434 e .com/FreeCAD/FreeCAD/pull/14154 Pull request #14154
  • Le icone delle intestazioni dei pannelli attività Sketcher e Part Design sono state migliorate. Pull request #13968
  • In modalità headless la console interattiva Python ora dispone del completamento con tabulazioni, a condizione che il modulo readline sia disponibile. Pull request #14213
  • È stata aggiunta un'opzione per visualizzare i nomi interni nella visualizzazione ad albero. È disabilitata per impostazione predefinita e può essere attivata in Preferenze → Visualizzazione → Interfaccia utente → Nascondi nomi interni. Pull request #14237
  • Il pulsante Guida è stato rimosso dalle Preferenze perché non funzionante. Pull request #14695
  • I fogli di stile predefiniti sono stati migliorati in modo significativo e ora sono offerti in due varianti oltre a quelle classiche: chiara e scura. Pull request #13772
  • Le pagine Tema e UI nel gruppo Visualizzazione delle Preferenze sono state riorganizzate e combinate. Alcune preferenze sono state spostate nella nuova pagina Avanzate. Pull request #14974
  • Le preferenze di controllo e perfezionamento di Part/Part Design sono ora attivate per impostazione predefinita. Pull request #14406

Sistema principale e API

Sistema principale

  • Le funzioni vettoriali della API dei vettori ora possono essere utilizzate nelle Espressioni. Pull request #8603.
  • L'editor Python adesso, quando si preme il tasto Invio, fa corrispondere il rientro della riga precedente Pull request #11356.
  • Il nome della proprietà che contiene gli oggetti di riferimento di un allegato è cambiato da DatiSupport a DatiAttachmentSupport. Pull request #12714.
  • Un contenitore di proprietà, App::VarSet, è stato introdotto come funzionalità principale. Un VarSet consente agli utenti di definire proprietà che possono essere utilizzate nei modelli proprio come alias di fogli di calcolo e altri contenitori di proprietà precedenti (Dynamic Data, Path PropertyBags, e Assembly 4 Variables). Pull request #12135

API

API Python nuove

  • getUpDirection: Ottiene la direzione verso l'alto da una vista View3DInventor. Pull request #10060

API Python rimosse

API Python modificate

  • Per salvare/ripristinare dati personalizzati da una feature Python, i metodi precedentemente chiamati __getstate__/__setstate__ sono stati rinominati in dumps/loads. Ciò è dovuto a cambiamenti interni in Python-3.11. Pull request #10769 e Pull request #12243.

Addon Manager

Ambiente Assembly

Un ambiente di lavoro Assembly integrato è stato finalmente aggiunto a FreeCAD. Utilizza il risolutore open source Ondsel. Le funzionalità di base (giunti) sono già disponibili. Ulteriori sviluppi sono in corso.

Pull request #10427, Pull request #10764, Pull request #12406 and more

Ulteriori miglioramenti di Assembly

Ambiente BIM

Ulteriori miglioramenti di BIM

  • Le barre degli strumenti e i menu dell'Ambiente BIM sono stati rielaborati. Pull request #14087

Ambiente CAM

Ulteriori miglioramenti di CAM

  • La lavorazione del materiale residuo (Rest machining) è stata reimplementata per prendere input dal G-code delle operazioni precedenti (invece di utilizzare gli interni delle operazioni Area). Ciò abilita il supporto per la lavorazione del materiale residuo nelle operazioni di area dopo quelle non di area (in particolare adattiva). Pull request #11939
  • La compensazione dell'altezza utensile G43 è stata aggiunta al post-processore CAM del baricentro. Pull request #12652
  • È stata aggiunta l'opzione "Feed retract" alle impostazioni delle operazioni di alesatura e foratura. Pull request #13254
  • È stato aggiunto un nuovo simulatore CAM basato su funzioni OpenGL di basso livello (più veloce e preciso). Pull request #13884
  • L'operazione Vcarve è stata rielaborata per includere funzionalità comunemente disponibili in altri software CAM (Step down, passaggio di finitura, ottimizzazione del movimento della testa e metodo debugVoronoi) rendendo possibile migliorare drasticamente la qualità della superficie scolpita aumentando la velocità di intaglio fino a 50%. Pull request #14093
  • Sono stati aggiunti modelli di materiali lavorabili e diversi materiali. Richiesta pull n. 14460

Ambiente Draft

Ulteriori miglioramenti di Draft

Ambiente FEM

La posizione delle etichette della legenda dei colori è stata modificata per rendere meno probabile che quelle in alto vengano coperte dal cubo di navigazione. Il carattere e il colore predefiniti delle etichette sono stati modificati per aumentare la visibilità e sono state aggiunte preferenze per consentire la modifica del colore e delle dimensioni dell'etichetta.

Pull request #10552

Il comando FEM PostFilterLinearizedStresses ora può utilizzare i componenti del tensore di sollecitazione per i calcoli di sollecitazione linearizzata. In precedenza, a questo scopo potevano essere utilizzate solo le sollecitazioni Von Mises, Tresca e principali (maggiori/intermedie/minori).

Pull request #11724

È stato aggiunto il supporto per la simmetria ciclica tramite Legame di vincolo in CalculiX, rendendo possibile l'analisi di modelli con simmetria periodica rotazionale utilizzando un singolo settore ripetitivo.

Pull request #12289

È stato aggiunto il supporto per le analisi 2D (sollecitazione piana, deformazione piana e assialsimmetrica) per il Solutore CalculiX. Sono configurate allo stesso modo delle simulazioni con elementi shell ma ci sono alcune restrizioni aggiuntive descritte nella pagina wiki sopra menzionata. La nuova opzione Spazio modello deve essere impostata correttamente. Pull request #12562
Come primo passo verso il supporto degli elementi esaedrici, la loro generazione utilizzando la tecnica di suddivisione Gmsh è ora possibile grazie alla nuova proprietà Gmsh Algoritmo di suddivisione. Può essere utilizzata anche per creare elementi quadrilateri. Pull request #12698
Sono state aggiunte nuove proprietà di visualizzazione agli oggetti della pipeline dei risultati. Il colore e la larghezza del bordo della mesh ora possono essere modificati per la modalità di visualizzazione "Superficie con bordi". La dimensione del nodo può essere modificata per la modalità Nodi. C'è anche un'impostazione di trasparenza per tutte le modalità. Pull request #13066
I vincoli FEM possono ora essere soppressi (fare clic con il tasto destro su un vincolo e selezionare Sopprimi) e quindi ignorati dai solutori. In questo modo è possibile modificare l'impostazione dell'analisi senza dover eliminare i vincoli attualmente non necessari. Pull request #12359
È stato aggiunto il supporto per il vincolo del corpo rigido di CalculiX, rendendo finalmente possibile simulare la torsione di componenti arbitrari e applicare carichi remoti, tra gli altri. Pull request #13900

Ulteriori miglioramenti di FEM

  • Il menu Model → Vincoli senza risolutore è stato rimosso dalla GUI. Non è stato possibile utilizzare i vincoli elencati. Pull request #10457 e Pull request #10459
  • La parola "vincolo" è stata rimossa dai nomi e dalle descrizioni della maggior parte delle funzionalità nell'ambiente FEM per garantire la nomenclatura corretta. I nomi sono stati modificati in modo tale da adattarsi agli standard del settore FEA e renderli intuitivi per i nuovi utenti. Pull request #10519 e Pull request #10799
  • Sono state aggiunte nuove icone per Solver CalculiX Standard, Controllo lavoro risolutore e Esegui calcoli risolutore per una maggiore intuitività.
  • Il risolutore CalculiX (nuovo framework) è stato rimosso dalla GUI poiché al momento non è completato e non è necessario. Pull request #10823
  • Il layout di alcuni pannelli attività degli strumenti di postelaborazione è stato migliorato per ridurre la dimensione dello spazio orizzontale da essi occupato. Pull request #11066
  • Il pannello delle attività FEM ConstraintTemperature è stato rielaborato per risolvere i problemi durante la modifica di questa funzionalità. Pull request #11126
  • Un vecchio problema relativo alla capacità di FEM PostFilterDataAlongLine di tracciare solo la grandezza e non i componenti vettoriali di una variabile di output selezionata è stato finalmente risolto. Pull request #10992
  • Il FEM ConstraintForce e il FEM ConstraintPressure sono stati revisionati per farli funzionare meglio sul lato del codice sorgente. Pull request #10935 e Pull request #10923
  • Il FEM PostFilterDataAtPoint ora ha una proprietà PointSize per impostare la dimensione del simbolo del punto per una maggiore visibilità. Pull request #11054
  • Per chiarezza, il comando Regione mesh FEM è stato rinominato in Rifinimento mesh FEM nella GUI (il nome del comando rimane invariato). Pull request #11489
  • L'entità dell'accelerazione di gravità ora può essere modificata utilizzando le proprietà di FEM Vincolo peso proprio. Pull request #12044
  • Vincolo contatto e vincolo di collegamento sono stati notevolmente migliorati. La rigidità del contatto ora utilizza l'unità corretta ed è possibile specificare il valore della pendenza dell'asta per l'attrito nel contatto. Inoltre, è possibile specificare la regolazione del gioco per il contatto mentre il vincolo di vincolo può avere la regolazione abilitata o disabilitata. Pull request #12133
  • PaStiX e Pardiso sono stati aggiunti ai Solutori di matrici CalculiX supportati. Sono i solutori ccx più veloci ma la possibilità di utilizzarli dipende dalla versione binaria di CalculiX e dalle librerie aggiuntive disponibili. Pull request #12478
  • La proprietà Integrazione fascio ridotto (impostata su true per impostazione predefinita) è stata aggiunta a Impostazioni risolutore CalculiX. Consente uno schema di integrazione ridotto per gli elementi della trave, rendendo possibile l'utilizzo della sezione della trave tubolare ed eliminando, tra gli altri, problemi di precisione nelle analisi con la plasticità. Pull request #12513
  • Lo strumento incompleto Set di nodi è stato rimosso dalla GUI. Non poteva essere utilizzato. Pull request #12611
  • La procedura di analisi Check Mesh CalculiX ora genera correttamente la mesh dei risultati. Pull request #12612
  • È stato chiarito nel pannello delle azioni che il diametro utilizzato dalla sezione della trave tubolare è il diametro esterno. Pull request #12609
  • La proprietà Beam Shell Result Output 3D del Risolutore CalculiX è ora impostata su true per impostazione predefinita per fornire risultati per gli elementi trave e fornire risultati significativi per gli elementi shell. Pull request #12493
  • I simboli delle funzionalità di analisi ora vengono posizionati correttamente quando il corpo (o il contenitore di parti) ha modificato la proprietà di posizionamento. Pull request #12527
  • Vincolo di pressione ora funziona correttamente per le shell indipendentemente dall'impostazione dei gruppi di mesh. Questa impostazione può essere modificata nelle Preferenze. Pull request #12437
  • L'indurimento semplice in FEM MaterialMechanicalNonlinear è stato rinominato in indurimento isotropico. Inoltre, è stato aggiunto l'indurimento cinematico. Pull request #12666
  • Ora la non linearità geometrica non viene attivata automaticamente e non è richiesta quando viene utilizzato un materiale non lineare. Queste sono forme indipendenti di non linearità. Pull request #12703
  • Le mesh miste costituite da elementi sia triangolari che quadrilateri ora vengono visualizzate correttamente nella pipeline dei risultati. Pull request #12740
  • La proprietà Frequenza di output è stata aggiunta a Impostazioni risolutore CalculiX. Definisce la frequenza di scrittura dell'output in incrementi. Pull request #12672
  • Ora è possibile generare elementi quadrilateri del secondo ordine. In precedenza, l'impostazione Gmsh di 2° ordine generava elementi quad di 1° ordine a causa della mancanza di un comando Gmsh SecondOrderIncomplete che ora viene utilizzato internamente. Questi elementi possono essere utilizzati anche per analisi 2D. Pull request #12698 e Pull request #12774
  • La determinazione dell'orientamento della sezione trasversale della trave è stata parzialmente corretta. A causa di un bug nell'attuale versione di CalculiX, potrebbero esserci ancora problemi con alcuni orientamenti. Pull request #12833
  • Gli esempi FEM di cantilever nella pagina iniziale sono stati aggiornati ed è stato aggiunto uno nuovo che utilizza elementi 1D. Pull request #12871
  • Il formato in cui FreeCAD scrive il vincolo di forza è ora compatibile con il formato CalculiX, eliminando rari problemi con numeri troppo lunghi. Pull request #12932
  • Ora è possibile esportare la pipeline dei risultati nel formato VTK. Pull request #12987
  • Nuove proprietà di controllo dell'incremento sono state aggiunte a Impostazioni del risolutore CalculiX. Attualmente, oltre alla dimensione dell'incremento iniziale e al periodo di tempo del passaggio, è possibile specificare la dimensione dell'incremento minima e massima. Inoltre, la proprietà "Iterations Thermo Mech Maximum" è stata rinominata "Iterations Maximum" poiché ora può essere utilizzata anche per analisi statiche (non termomeccaniche). Pull request #12662
  • Il valore predefinito Spessore elemento 2D è stato modificato da 20 mm a 1 mm perché ha più senso nella pratica. Pull request #13077
  • Molte icone FEM sono state notevolmente migliorate per ridurre la loro somiglianza e rendere più chiaro cosa fanno gli strumenti. ​​Pull request #13130
  • La proprietà Thermo Mech Type è stata aggiunta a Impostazioni risolutore CalculiX. Permette di passare da un'analisi termomeccanica regolare (accoppiata) a un'analisi disaccoppiata o di puro trasferimento di calore. Pull request #13296
  • Min. La proprietà Size è stata aggiunta per Netgen mesher per impedire la generazione di elementi troppo piccoli durante la mesh di geometrie più complesse. Pull request #12794
  • Un vecchio problema con una proprietà di scala dei simboli non funzionante per i vincoli FEM è stato finalmente risolto e la proprietà Scala ora può essere utilizzata per regolare la dimensione dei simboli di un vincolo selezionato. Pull request #13274
  • Il ridimensionamento automatico dei vincoli FEM è stato migliorato per gestire meglio oggetti molto piccoli e molto grandi. Pull request #13586
  • Vincolo del flusso di calore ora dispone di una modalità di flusso di calore per radiazione per modellare la radiazione superficiale rispetto all'ambiente. Pull request #13466
  • Sono state rimosse alcune proprietà della vista dei simboli di vincolo inutilizzati. Pull request #13569
  • Nuove proprietà di visualizzazione (di cui la principale è Modalità colore) sono state aggiunte agli oggetti mesh FEM in modo che le impostazioni personalizzate di colore e trasparenza per le mesh possano essere salvate e ripristinate. Pull request #13698
  • Ora solo l'ultimo filtro aggiunto sotto ciascun oggetto della pipeline dei risultati è visibile per impostazione predefinita. Pull request #13820
  • I suggerimenti del pannello azioni di diversi vincoli sono stati modificati per riflettere effettivamente le regole di selezione della geometria per tali vincoli. Pull request #13921 e Pull request #14002
  • Il supporto per i risultati del flusso di calore dalle analisi termomeccaniche è stato aggiunto alla pipeline dei risultati. Pull request #14019
  • La funzionalità di stampa della sezione è stata migliorata, aggiungendo il supporto per i risultati del flusso di calore e dello stress da trascinamento (non ancora disponibili poiché le analisi dei fluidi 3D con CalculiX non sono ancora state implementate). Pull request #14046
  • Fonte di calore corporea ora può essere utilizzato con CalculiX e dispone di due modalità di input: velocità di dissipazione [W/kg] e potenza totale [W]. Pull request #14417
  • Le proprietà di rotazione del Sistema di coordinate locali sono state sostituite con una singola proprietà Rotazione per coerenza. Pull request #14353
  • È stato aggiunto uno strumento Cancella elementi per poter nascondere gli elementi di una mesh selezionata con un poligono. Pull request #11492

Ambiente Material

Il sistema di gestione dei materiali, compreso l'editor, è stato completamente rielaborato. Seguiranno ulteriori miglioramenti in questo senso.

Pull request #10690

È stata aggiunta l'anteprima dell'aspetto per mostrare i materiali nello stesso modo in cui verranno visualizzati nei documenti.

Pull request #11628

Il nuovo sistema di materiali viene ora utilizzato per le proprietà estetiche.

Pull request #13294

Ulteriori miglioramenti di Material

  • Sono state aggiunte e rese disponibili finestre di dialogo per visualizzare le proprietà Aspetto e Materiale di un oggetto come strumenti "Ispeziona aspetto" e "Ispeziona materiale". Pull request #13967

Ambiente Part

Lo strumento Part Scala è stato aggiunto per consentire un facile ridimensionamento delle forme senza dover utilizzare gli strumenti dell'ambiente Draft.

Pull request #10583

Part Specchia ora supporta oggetti di riferimento, come un Part Piano per definire un piano speculare arbitrario oltre ai piani XY, XZ e YZ standard.

Pull request #11535

Ulteriori miglioramenti di Part

  • La proprietà Frenet è ora abilitata per impostazione predefinita per lo strumento Part Sweep per evitare un problema di rendering comune. Pull request #11590
  • Ora tutte le icone di Part utilizzano il tema blu e le primitive utilizzano la stessa icona per la barra degli strumenti e l'albero. Pull request #14074
  • Il comando Crea schizzo è stato aggiunto alla barra degli strumenti e al menu Part poiché operazioni come l'estrusione in genere utilizzano schizzi come input. Pull request #14318
  • È stata aggiunta una nuova modalità di attacco chiamata XY parallelo al piano. Il risultato è un collegamento simile a XY dell'oggetto ma con il piano XY traslato per passare attraverso un vertice selezionato. A differenza della modalità di collegamento "Traduci origine", non sposta l'origine in 2D/Sketcher. Può essere utilizzato con piani di origine, piani di Riferimento e schizzi, ma anche con qualsiasi oggetto dotato di proprietà Posizionamento. Pull request #14372

Ambiente Part Design

Sono state aggiunte altre modalità alle funzionalità rivoluzione e gola: dalla prima/ultima, fino alla faccia e due quote.

Pull request #7193

I pannelli attività Estrusione e Tasca sono stati migliorati (elementi dell'interfaccia utente riordinati, opzione Seleziona faccia nascosta quando non necessaria e così via).

Pull request #10392

La modalità offset è stata aggiunta per le Serie lineare e polare. La modalità precedente è stata rinominata Overall Length.

Pull request #10377

È stato aggiunto il supporto sperimentale per più solidi all'interno di un Corpo. Può essere abilitato nelle preferenze (per nuovi Corpi) o nelle proprietà di un Corpo esistente.

Pull request #13960

È stata aggiunta la modalità "Fino alla forma" per Pad, rendendo possibile terminare l'estrusione su più facce, in contrapposizione alla modalità "Fino alla faccia" che consente la selezione di una sola faccia.

Pull request #11392 e Pull request #14433

Ulteriori miglioramenti di PartDesign

  • L'opzione Crea spessore verso l'interno è ora abilitata per impostazione predefinita per lo strumento Spessore. Pull request #7488
  • I punti di Riferimento ora cambiano colore quando evidenziati o selezionati (come altri Datum). Pull request #12439
  • Le icone di Part Design sono state leggermente migliorate per coerenza. Pull request #13109
  • È stata aggiunta una proprietà "Soppresso" per disattivare temporaneamente una funzionalità. Richiesta pull n. 12096 e Pull request #12412
  • Le barre degli strumenti di Part Design sono state aggiornate: i riferimenti e le azioni basate sullo schizzo ora sono raggruppati, Part Controllo geometria è stato aggiunto alla barra degli strumenti e al menu e le barre degli strumenti sono state divise in singole barre per rendere possibile la riorganizzazione . Pull request #13833
  • Ora tutte le funzionalità di Part Design utilizzano le stesse icone per la barra degli strumenti e l'albero. Pull request #14074
  • Una nuova modalità "Trasforma corpo" è stata aggiunta agli strumenti di Serie e specchiatura di Part Design, rendendo possibile trasformare la forma dell'intera feature di base invece delle forme dei singoli strumenti delle feature additive e sottrattive. Pull request #12589
  • Il layout della finestra di dialogo dello strumento Foro è stato migliorato. Pull request #14031


Ambiente Sketcher

L'implementazione di una sovrapposizione di cerchi per gli archi (per risolvere il problema dei vincoli che appaiono lontani da essi) è stata completata con un comando comando per scambiarli.

Pull request #9703


Clicca sull'immagine se l'animazione non si avvia.
È stato aggiunto un vincolo di quota contestuale Quota per consentire una quotatura rapida e intuitiva con un unico strumento versatile.

Pull request #9810


Clicca sull'immagine se l'animazione non si avvia.
Sono stati aggiunti degli Strumenti parametri per consentire la quotatura in movimento (durante il disegno di forme). A seconda dell'impostazione delle preferenze, i parametri On-View, possono essere disabilitati, ridotti solo alle dimensioni (nessuna coordinata iniziale) o completamente abilitati. Inoltre, sono state aggiunte modalità per gli strumenti forma. Possono essere selezionati utilizzando il tasto M o un elenco a discesa nel pannello delle attività. Alcuni strumenti dispongono di impostazioni aggiuntive sotto forma di caselle di controllo nel pannello delle attività e scorciatoie da tastiera aggiuntive. Attualmente le nuove funzionalità sono disponibili per punti, linee, archi, ellissi, rettangoli, poligoni, asole e B-splines.

Pull request #11048, Pull request #11174 e seguenti

È stato aggiunto uno strumento Offset per consentire l'offset delle curve.

Pull request #11174

La modalità rettangolo da tre punti è stata aggiunta in due versioni: 3 angoli o centro e 2 angoli.

Pull request #11174

È stato aggiunto uno strumento Asola ad arco con due modalità (estremità ad arco ed estremità piatte) per consentire la creazione di asole curve

Pull request #11174


Clicca sull'immagine se l'animazione non si avvia.
È stato aggiunto un Vincolo orizzontale/verticale. Applica automaticamente il vincolo orizzontale se una linea è più vicina all'orientamento orizzontale o il vincolo verticale se è più vicino all'orientamento verticale.

Pull request #11538

Il rendering dei vincoli angolare e radiale è stato migliorato. I vincoli angolari ora hanno linee di estensione complete.

Pull request #11507

È stato aggiunto uno strumento di Trasformazione polare per consentire la rotazione e le serie circolari delle geometrie dello sketcher.

Pull request #11264


Fare clic sull'immagine se l'animazione non si avvia.
Ora è possibile copiare/tagliare e incollare la geometria dello schizzo (con vincoli) utilizzando le tipiche scorciatoie da tastiera: Ctrl+C, Ctrl+X e Ctrl+V. Non solo all'interno di un singolo schizzo ma anche tra diversi schizzi o addirittura diverse istanze di FreeCAD. La geometria viene copiata sotto forma di comandi Python in modo che possa essere utilizzata anche in altri modi (ad esempio condivisa sul forum).

Pull request #11537

È stato aggiunto uno strumento di trasformazioneScala, che rende possibile scalare la geometria nello schizzo utilizzando un punto centrale selezionato e un fattore di scala o due punti di riferimento.

Pull request #11265


Fare clic sull'immagine se l'animazione non si avvia.
È stata aggiunta la tangenza al bordo della B-spline, eliminando invece la necessità di utilizzare punti finali e varie soluzioni alternative.

Pull request #11853

Gli strumenti Serie rettangolare, Sposta, Copia e Clona sono stati sostituiti con un singolo strumento Array trasforma.

Pull request #11267

È stato aggiunto uno strumento Smusso con un'opzione per passare alla modalità Raccordo. Inoltre, non esiste più uno strumento di raccordo separato per la preservazione degli angoli. Un'opzione "Preserva angolo" (selezionata per impostazione predefinita) è stata aggiunta allo strumento Raccordo.

Pull request #12898


Clicca sull'immagine se l'animazione non si avvia.
Lo strumento Simmetria è stato rielaborato. Ora funziona preselezionando la geometria e selezionando una linea o un punto attorno al quale la geometria verrà specchiata. Viene mostrata un'anteprima e il comportamento dello strumento può essere controllato tramite le impostazioni dello strumento.

Pull request #11853


Clicca sull'immagine se l'animazione non si avvia.
Vincolo simmetrico viene ora applicato automaticamente quando viene selezionato il punto medio di una linea.

Pull request #13147

Vincolo distanza ora può essere utilizzato per i vincoli di lunghezza dell'arco (l'arco circolare deve essere preselezionato).

Pull request #12602

Il colore di rendering dei punti è ora diverso a seconda che si tratti di semplice punto/punto-finale (bianco, ora creato per impostazione predefinita quando si utilizza lo strumento Crea punto), un punto di costruzione/punto-centrale (blu) o un punto coincidente con un altro (rosso).

Pull request #13098


Clicca sull'immagine se l'animazione non si avvia.
Lo strumento Ritaglia bordo ora può essere utilizzato in modalità premi e trascina.

Pull request #13188

Ulteriori miglioramenti di Sketcher

Ambiente Spreadsheet

Ulteriori miglioramenti di Spreadsheet

  • Facendo doppio clic su un foglio di calcolo nella visualizzazione ad albero ora si passa a questo ambiente di lavoro. Pull request #13137
  • Le icone del Foglio di calcolo sono state migliorate. Pull request #13996

Ambiente Start

Alla pagina iniziale è stata aggiunta una sezione Nuovo file che include una serie di pulsanti di avvio rapido.

Pull request #10171

Il design visivo della pagina iniziale è stato revisionato. Ora sembra più moderno e coerente.

Pull request #10391

È stato aggiunto un semplice widget di primo avvio che verrà esteso nel prossimo futuro.

Pull request #13650

Ulteriori miglioramenti di Start

  • La pagina delle preferenze dell'ambiente Start è stata riorganizzata. Pull request #10520
  • Ora è disponibile un'opzione CSS personalizzato per la pagina iniziale che consente di personalizzare lo stile CSS della pagina iniziale dalle preferenze dell'ambiente Start. Pull request #10520
  • La preferenza Nascondi barre di scorrimento è stata rimossa. Le barre di scorrimento nella pagina iniziale ora hanno uno stile in base al tema e sono molto più sottili. Pull request #10520
  • Ora sono disponibili preferenze per nascondere e modificare la dimensione delle icone delle miniature dei file nella pagina iniziale. Pull request #10410
  • La pagina iniziale ora è un'app basata su QtWidgets e non un workbench. Può essere visualizzato utilizzando l'opzione Aiuto → Start. Pull request #13134

Ambiente Surface

Ulteriori miglioramenti di Surface

Ambiente TechDraw

Lo strumento Cerchio cosmetico è stato aggiunto per consentire la creazione di cerchi cosmetici selezionando il centro e inserendo il raggio.

Pull request #10763

Lo strumento ArcLengthAnnotation è stato aggiunto per creare annotazioni simili a quote della lunghezza dell'arco dei bordi selezionati.

Pull request #11532

Lo strumento AddOffsetVertex è stato aggiunto per creare vertici cosmetici come offset dai vertici selezionati.

Pull request #11655

Lo strumento Vista interrotta è stato aggiunto per rappresentare facilmente oggetti lunghi.

Pull request #13331


Fai clic sull'immagine se l'animazione non si avvia.
È stato aggiunto un nuovo strumento di quotatura contestuale basato su quello introdotto nello Sketcher.

Pull request #13525

Ulteriori miglioramenti di TechDraw

  • Le sezioni basate su altre sezioni ora utilizzano la forma originale (non tagliata) per impostazione predefinita. Questo può essere modificato nelle impostazioni della sezione per utilizzare invece la sezione precedente. Pull request #10281
  • Gli oggetti cosmetici e le linee centrali ora possono essere eliminati selezionandoli e premendo il tasto Elimina. In precedenza, ciò comportava la cancellazione dell'intera vista. Pull request #10695 e Pull request #10813
  • È stata aggiunta una nuova icona più intuitiva per lo strumento Saldatura. Pull request #10936
  • Il comportamento della modalità punto + bordo di Quotatura Lunghezza è stato corretto. Pull request #10860
  • È stato aggiunto un indicatore di selezione per il pulsante ToggleFrame in modo che un utente possa vedere se il pulsante è attivato o meno. Pull request #11240
  • Il comportamento dello strumento DecorateLine è stato migliorato. Ora facendo doppio clic su una riga si richiama questo strumento. E gli stili di linea vengono ripristinati correttamente se l'utente preme Annulla. In precedenza non c'era differenza tra premere "OK" e "Annulla". Pull request #11188
  • Ora è possibile impostare il colore e la trasparenza delle facce per la vista. Pull request #11315
  • È stata aggiunta la modalità di selezione multipla che può essere abilitata nelle Preferenze. In questa modalità, è possibile selezionare più vertici, bordi e facce facendo clic con il tasto sinistro su di essi, senza dover tenere premuto il tasto Ctrl. Pull request #11417
  • ExtensionAreaAnnotation ora può calcolare aree di facce arbitrarie. Pull request #11473
  • Le linee non continue ora seguiranno gli standard ISO/ANSI anziché uno stile di linea Qt. È stata aggiunta una nuova preferenza per selezionare lo standard. Pull request #11594
  • Il comportamento dello strumento AxoLengthDimension è stato migliorato. Ora, quando si quotano i bordi paralleli agli assi del sistema di coordinate globali, il valore effettivo (3D) viene calcolato automaticamente e inserito nella proprietà Format Spec (come testo). Pull request #11678
  • Lo strumento ExtensionPositionSectionView ora può essere utilizzato selezionando un bordo in una vista in sezione e un vertice nella vista di origine. Pull request #11797
  • Sono stati apportati piccoli ma importanti miglioramenti all'usabilità: facendo doppio clic sulla pagina TechDraw ora si accede a questo ambiente di lavoro e lo strumento TechDraw MoveView è stato sostituito dal semplice trascinamento della selezione nell' albero. Anche gli strumenti TechDraw ClipGroupAdd e TechDraw ClipGroupRemove sono stati sostituiti dal comportamento di trascinamento della selezione dell'albero. Pull request #13063
  • I modelli di disegno vengono ora compilati automaticamente con le informazioni disponibili (come data e titolo). Pull request #13005
  • Lo strumento Forma progetto è stato rimosso da TechDraw poiché è ereditato dal vecchio ambiente Drawing e non ha nulla a che fare con una pagina TechDraw. Pull request #13655
  • Lo strumento Inserisci vista è stato migliorato in modo che possa gestire più tipi di oggetti e impostazioni. Ciò ha consentito di rimuovere i seguenti strumenti dalla barra degli strumenti: SpreadsheetView, ArchView, Symbol, Image e [[TechDraw_ProjectionGroup|ProjectionGroup] ]. Pull request #13219
  • È stato aggiunto lo snap per consentire l'allineamento automatico di viste e quote. Lo snap può essere temporaneamente disabilitato con il tasto modificatore Alt. Pull request #13659
  • La gestione dei cosmetici è stata migliorata in vari modi. Pull request #14216
  • Molte icone TechDraw sono state migliorate. Pull request #14873 e seguenti

Compilazione

Limitazioni note