User talk:David69

From FreeCAD Documentation
Jump to navigation Jump to search

About usage of technical terms

Hi David, I got feedback from the community that we should use less technical terms in the Wiki. An example: - in the Web_Workbench you changed now the whole docnav to e.g. "BrowserSetURL" instead of human-friendly "Set URL". The criticism is that we are focused on technical terms but users want to know when clicking on something what this would be about.

Please also see the same discussion I have with roy: User_talk:Roy_043#FEM_ResultsPurge Let's please discuss this in the Forum. I will open a new thread there.

thanks and regards --uwestoehr (talk) 13:02, 14 June 2022 (UTC)

Hi Uwe, I have no issue to put more friendly wording but here I am only following the rules for the English wiki. If you switch to the French version, you'll see not only for matter of translation I have to adapt but also simply it is more understandable. You may have remark on the commands receive the exact wording of the command of the page which, if I am not wrong, is the mirror of the command itself in the code. For the little story, it happens couple yrs ago, I had switch barbarianEnglishwording in something easier to read and guess what?... So the central question is: what to follow knowing today Roy and me we are here but tomorrow somebody can interpret differently. I have no answer may be open a discussion. And if I can add something, IMO, FEM and Path are the two black points on Crowdin for the similar reasons. We will find a way. br - david

Please don't run bots without prior discussions

You make several changes within a minute: Can you please discuss before in the forum what you intend to change? For example your bot changes




which is no benefit, only creates more code. And even worse, your changed pages might now marked to be translated despite nothing visible was in effect changed. So many people invest now time to see that nothing happened.

--uwestoehr (talk) 20:22, 13 March 2022 (UTC)

it's because any links is built like this. when we translate, we need to write [[Placement/fr|Placement]], [[Placement/ru|Placement]] and so on.


Only in the translated pages need this and translators know this since they must e.g. translate also the term "Placement". The original ones don't need this. Therefore please don't make changes without a need.
--uwestoehr (talk) 22:57, 13 March 2022 (UTC)

If you want if it's a matter to save few lines of code. It won't help translators, and I have made couple translations. The wiki says It was a common agreement between writers and translators.


About your changes to the Draft command documentation

Your recent changes go against the GuiCommand_model. Example:

If you want to change the GuiCommand_model you should approach it differently and not bulk change 21 pages like this.

--Roy 043 (talk) 10:11, 25 November 2021 (UTC)

Yes I did it yesterday evening. Following translations on Draft workbench, I have noticed that the command for the button was not what we read on the button itself. I can cancel. I apologize.

You are translating the old Draft WB documentation

I notice that you have worked on translating the Draft WB documentation. As indicated on f.e. the Draft_Wire page this documentation is currently being rewritten. There is also a topic in the forum warning about this: I know it is taking a long time, but it would still be better to be patient and wait.

--Roy 043 (talk) 12:51, 29 April 2021 (UTC)

Thank you Roy for the notification and in particular the link. Yes I did small changes on Draft pages mainly on the location of the tools. I won't go further.

Please stop removing the WB prefix

You have taken on removing the WB prefix from the description of the toolbar button on many, many pages. As I understand it this does not match the current standard. Please stop for now. Let's discus this first.

--Roy 043 (talk) 08:27, 2 March 2021 (UTC)

I just read your comment now after my answer on the forum. I stop here waiting for our decision.

Sketcher WB: Removed Version=0.19

You have added Version=0.19 in the documentation for a number of Sketcher WB tools that already existed, and only were renamed. Your confusion is understandable when you read the banners that were added to the old pages.

I have corrected this now.

Regards, Roy_043.

Nommage des pages "GuiCommand" et autres...

Bonjour, J'ai corrigé le nom de page "Raytracing Export" que vous aviez appelé "Export de la vue vers Pov-Ray Raytracing" car il existe des conventions de nommage décrites dans WikiPages#Page_names_for_GuiCommand_help.

Nota: Il est par contre possible de mettre une description dans la boite GuiCommand affichée par le modèle.


Gnrc (du Rhône)