Visualizza: Vista ortografica

From FreeCAD Documentation
This page is a translated version of the page Std OrthographicCamera and the translation is 100% complete.

Vista ortografica

Posizione nel menu
Visualizza → Vista ortografica
Ambiente
Tutti
Avvio veloce
V O
Introdotto nella versione
-
Vedere anche
Vista in prospettiva

Descrizione

Il comando Vista ortografica commuta la vista 3D attiva nella modalità di visualizzazione ortografica. In questa modalità, gli oggetti più lontani dalla fotocamera non appaiono più piccoli di quelli più vicini.

Due cubi con le stesse dimensioni in vista ortografica

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Selezionare l'opzione Visualizza → Vista ortografica dal menu.
    • Selezionare l'opzione Vista ortografica dal menu Mini-cubo del Cubo di navigazione.
    • Usare la scorciatoia da tastiera: V e poi O.

Preferenze

Vedere anche: Editor delle Preferenze.

  • Il tipo di camera può essere modificato: Modifica → Preferenze... → Visualizzazione → Vista 3D → Tipo di camera. Il tipo selezionato verrà utilizzato per tutte le viste 3D di tutti i documenti aperti e anche per i nuovi documenti.

Script

Vedere anche: Autogenerated API documentation e Script di base per FreeCAD.

Utilizzare il metodo setCameraType dell'oggetto View per passare alla modalità ortografica o prospettica.

import FreeCADGui

view = FreeCADGui.ActiveDocument.ActiveView
view.setCameraType("Perspective")
view.setCameraType("Orthographic")
view.getCameraType()