Std Vue orthographique

From FreeCAD Documentation
This page is a translated version of the page Std OrthographicCamera and the translation is 100% complete.

Std Vue orthographique

Emplacement du menu
Affichage → Vue orthographique
Ateliers
Tous
Raccourci par défaut
V O
Introduit dans la version
-
Voir aussi
Std Vue en perspective

Description

La commande Std Vue orthographique fait passer la caméra du mode actif vue 3D en mode de vue orthographique. Dans ce mode, les objets qui sont plus éloignés de la caméra n'apparaissent pas plus petits que ceux qui sont plus proches.

Deux cubes de mêmes dimensions en vue orthographique

Utilisation

  1. Il existe plusieurs façons d'appeler la commande :
    • Sélectionnez l'option Affichage → Vue orthographique du menu.
    • Sélectionnez l'option Vue orthographique dans le menu Mini-cube de Cube de navigation.
    • Utilisez le raccourci clavier: V puis O.

Préférences

Voir aussi : Réglage des préférences.

  • Le type de caméra peut être modifié : Édition → Préférences... → Affichage → Vue 3D → Type de caméra. Le type sélectionné sera utilisé pour toutes les vues 3D de tous les documents ouverts et également pour les nouveaux documents.

Script

Voir aussi : Autogenerated API documentation et FreeCAD Débuter avec les scripts.

Utilisez la méthode setCameraType de l'objet Vue pour passer en vue orthographique ou en vue en perspective.

import FreeCADGui

view = FreeCADGui.ActiveDocument.ActiveView
view.setCameraType("Perspective")
view.setCameraType("Orthographic")
view.getCameraType()