File: Nuovo

From FreeCAD Documentation
This page is a translated version of the page Std New and the translation is 100% complete.

Nuovo

Posizione nel menu
File → Nuovo
Ambiente
Tutti
Avvio veloce
Ctrl+N
Introdotto nella versione
-
Vedere anche
Apri, Importa

Descrizione

Il comando Nuovo crea un nuovo documento vuoto e lo rende il documento attivo.

Utilizzo

  1. Esistono diversi modi per invocare il comando:
    • Premere il pulsante Nuovo.
    • Selezionare l'opzione File → Nuovo dal menu.
    • Usare la scorciatoia da tastiera: Ctrl+N.

Preferenze

Vedere anche: Editor delle Preferenze.

  • Per impostazione predefinita, FreeCAD si avvia senza un nuovo documento. Selezionare l'opzione Modifica → Preferenze... → Generale → Documento → Crea un nuovo documento all'avvio per modificare questo comportamento.
  • Alcune proprietà del documento: nome dell'autore, nome dell'azienda e informazioni sulla licenza, possono essere preimpostate: Modifica → Preferenze... → Generale → Documento → Diritti d'autore e Licenza.

Proprietà

Vedere anche: Editor delle proprietà.

Molte proprietà possono anche essere modificate nella finestra di dialogo del comando Informazioni sul progetto.

Dati

Base

  • DatiComment (String): qualsiasi commento applicabile.
  • DatiCompany (String): nome dell'azienda.
  • DatiCreated By (String): nome dell'autore.
  • DatiCreation Date (String): timbro data automatico (sola lettura).
  • DatiFile Name (String): il percorso completo del file. Vuoto se il documento non è stato salvato (sola lettura).
  • DatiId (String): non ancora implementato.
  • DatiLabel (String): il nome che apparirà nella Vista ad albero. Sostituito dal nome del documento dopo la riapertura.
  • DatiLast Modified By (String): nome dell'autore.
  • DatiLast Modified Date (String): timbro data automatico (sola lettura).
  • DatiLicense (String): tipo di licenza.
  • DatiLicense URL (String): URL della licenza.
  • Dati (Hidden)Material (Map): mappa con le proprietà del materiale.
  • Dati (Hidden)Meta (Map): mappa con metainformazioni aggiuntive.
  • DatiShow Hidden (Bool): Se vero, gli elementi che sono stati nascosti nella Vista ad albero verranno comunque visualizzati. Nascondere gli elementi nell'albero può essere utile quando si lavora su modelli più grandi.
  • DatiTip (Link): non ancora implementato.
  • DatiTip Name (String): non ancora implementato.
  • DatiTransient Dir (String): la directory temporanea utilizzata per i dati di ripristino (sola lettura).
  • Dati (Hidden)Uid (UUID): UUID del documento (sola lettura).
  • DatiUnit System (Enumeration): il sistema di unità del documento. Il valore iniziale dipende dal Sistema di unità predefinito. disponibile dalla versione 1.0

Script

Vedere anche: Autogenerated API documentation e Script di base per FreeCAD.

Per creare un nuovo documento usa il metodo newDocument([name], [hidden=False]) dell'applicazione FreeCAD. Il nome del documento deve essere univoco, che viene verificato automaticamente. Se non viene fornito alcun nome, il documento sarà denominato "Senza titolo". Se viene utilizzato hidden=True, il nuovo documento non verrà visualizzato nella GUI e non verrà visualizzata alcuna scheda.

import FreeCAD
from pathlib import Path

# The folder and filename we will use:
fld = 'D:/testfiles/'
fnm = fld + 'test.FCStd'

# Make sure fld exists:
Path(fld).mkdir(parents=True, exist_ok=True)

doc = FreeCAD.newDocument()
doc.saveAs(fnm)

FreeCAD.closeDocument(doc.Name)

doc = FreeCAD.open(fnm)
doc.save()

FreeCAD.closeDocument(doc.Name)