표준 가져오기(Std Import)
|
|
| 메뉴 위치 |
|---|
| 파일 → 가져오기... |
| 작업대 |
| 모두 |
| 기본 단축키 |
| Ctrl+I |
| 도입 버전 |
| - |
| 참조 |
| 표준 열기, 가져오기 내보내기, 가져오기 내보내기 환경 설정 |
설명
표준 가져오기(Std Import) 명령은 다른 형식의 파일에서 지오메트리를 활성 문서로 가져옵니다. 다양한 파일 형식이 지원되며 어떤 형식에는 가져오기 옵션이 여러 가지 존재합니다. 자세한 내용은 가져오기 내보내기를 참조하십시오.
If an image format is selected the command will create an Image Plane.
용법
선택 사항
- 명령을 중지하려면 Esc 키나 취소 버튼을 누릅니다.
비고
- 가져온 메시 개체를 솔리드로 변환하려면 STL이나 OBJ 가져오기 자습서를 참조하십시오.
- 새 문서로 가져오려면 표준 열기 명령을 사용할 수 있습니다.
- 일부 작업대에는 추가적인 가져오기 명령이 있습니다. 참조: 가져오기 내보내기.
환경 설정
- 참조: 가져오기 내보내기 환경 설정.
- 마지막으로 사용한 파일의 위치가 다음에 저장됩니다: 도구 → 파라미터 편집... → BaseApp → Preferences → General → FileOpenSavePath.
- 마지막으로 가져온 파일의 위치가 다음에 저장됩니다: 도구 → 파라미터 편집... → BaseApp → Preferences → General → FileImportFilter.
Image Plane
An Image Plane is a planar representation of an image in the 3D View. It can for example be used when creating a model based on photographs of an existing object.
By default an Image Plane is placed on the global XY-plane. The initial size of an Image Plane is calculated using a 96px/inch resolution.
Edit
- To edit an Image Plane do one of the following:
- Double-click the Image Plane in the Tree View.
- Right-click the Image Plane in the Tree View and select
Change Image from the context menu.
- If the Image Plane is not plane-parallel to the XY-, XZ- or YZ-plane of the global coordinate system, it is realigned to be plane-parallel to the XY-plane.
- The Image plane settings task panel opens.
- Optionally select the XY-plane, XZ-plane or YZ-plane of the global coordinate system.
- Check Reverse direction to rotate the Image Plane 180°. The rotation axis depends on the selected plane. For the XY-plane it is the global X-axis. For the XZ and YZ-plane it is the global Z-axis.
- The Offset, X distance and Y distance are relative to the coordinate system of the Image Plane. A small negative offset can be useful when tracing the image with a sketch or Draft geometry.
- Optionally change the Transparency.
- Image Size options:
- Scale by numerical input:
- Optionally uncheck Keep aspect ratio for unequal scaling.
- Enter a Width and/or Height.
- Scale by picking points:
- Press the Calibrate button.
- Optionally check Rotate to align to rotate the Image Plane so the calibration line becomes aligned to the nearest 45° angle (horizontal, vertical, or diagonal), or Center on midpoint to move the Image Plane so the midpoint of the calibration line coincides with the origin of the Image Plane. introduced in 26.3
- Pick the first point inside the image. Input hints for the available shortcuts are shown at this stage. introduced in 26.3
- Pick the second point inside the image. Hold Ctrl while picking to snap the line to 5° angle increments. introduced in 26.3
- A dimension line is displayed.
- Enter the desired dimension.
- Press Enter or the Apply button.
- Scale by numerical input:
While calibrating, the keyboard shortcuts R and C toggle the Rotate to align and Center on midpoint options respectively. introduced in 26.3
Properties
See also: Property View.
An Image Plane object is derived from an App GeoFeature object and inherits all its properties. It also has the following additional properties:
Data
Image Plane
- 데이터Image File (
FileIncluded): The image file used for the Image Plane. This file is stored in the .FCStd file. - 데이터XSize (
Length): The width of the Image Plane. - 데이터YSize (
Length): The height of the Image Plane.
View
Object Style
- 보기Lighting (
Enumeration): How the Image Plane is illuminated in the 3D View. Can beTwo sideorOne side.
- File: New Document, Open, Open Recent, Close, Close All, Save, Save As, Save Copy, Save All, Revert, Import, Export,Merge Document, Document Information, Print, Print Preview, Export PDF, Exit
- Edit:
- Miscellaneous: Undo, Redo, Cut, Copy, Paste, Duplicate Object, Delete, Recompute, Box Selection, Box Element Selection, Select All, Transform, Placement, Align To, Send to Python Console, Properties, Toggle Edit Mode, Edit Mode, Preferences
- Create: New Part, New Group, Variable Set, Annotation Label, Text Document
- Datums: Coordinate System, Datum Plane, Datum Line, Datum Point
- Link Actions: Make Link, Make Sub-Link, Replace With Link, Unlink, Import Link, Import All Links
- View:
- Miscellaneous: New 3D View, Orthographic View, Perspective View, Fullscreen, Bounding Box, Toggle Axis Cross, Clipping View, Texture Mapping, Toggle Navigation/Edit Mode, Material, Appearance, Random Color, Appearance per Face, Toggle Transparency, Workbench, Status Bar
- Standard Views: Fit All, Fit Selection, Align to Selection, Isometric, Dimetric, Trimetric, Home, Front, Top, Right, Rear, Bottom, Left, Rotate Left, Rotate Right, Store Working View, Recall Working View
- Freeze Display: Save Views, Load Views, Freeze View, Clear Views
- Draw Style: As Is, Points, Wireframe, Hidden Line, No Shading, Shaded, Flat Lines
- Stereo: Stereo Red/Cyan, Stereo Quad Buffer, Stereo Interleaved Rows, Stereo Interleaved Columns, Stereo Off, Issue Camera Position
- Zoom: Zoom In, Zoom Out, Box Zoom
- Document Window: Docked, Undocked, Fullscreen
- Visibility: Toggle Visibility, Show Selection, Hide Selection, Select Visible Objects, Toggle All Objects, Show All Objects, Hide All Objects, Toggle Selectability
- Toolbars: File, Edit, Clipboard, Workbench, Macro, View, Individual Views, Structure, Help, Lock Toolbars
- Panels: Tree View, Property View, Model, Selection View, Python Console, Report View, Tasks, DAG View
- Overlay Docked Panel: Toggle Overlay for All Panels, Toggle Transparent Panels, Toggle Overlay, Toggle Transparent Mode, Bypass Mouse Events in Overlay Panels, Toggle Left, Toggle Right, Toggle Top, Toggle Bottom
- Link Navigation: Go to Linked Object, Go to Deepest Linked Object, Select All Links
- Tree View Actions: Sync View, Sync Selection, Sync Placement, Preselection, Record Selection, Single Document, Multi Document, Collapse/Expand, Initiate Dragging, Go to Selection, Selection Back, Selection Forward
- Tools: Addon Manager, Measure, Clarify Selection, Quick Measure, Units Converter, Load Image, Save Image, View Turntable, Scene Inspector, Dependency Graph, Export Dependency Graph, Document Utility, Edit Parameters, Customize
- Macro: Record Macro, Macros, Recent Macros, Execute Macro, Attach to Remote Debugger, Debug Macro, Stop Debugging, Step Over, Step Into, Toggle Breakpoint
- Help: What's This, Start Page, Users Documentation, FreeCAD Forum, Report an Issue, Restart in Safe Mode, Developers Handbook, Python Modules Documentation, FreeCAD Website, Donate to FreeCAD, About FreeCAD
- Getting started
- Installation: Download, Windows, Linux, Mac, Additional components, Docker, AppImage, Ubuntu Snap
- Basics: About FreeCAD, Interface, Mouse navigation, Selection methods, Object name, Preferences, Workbenches, Document structure, Properties, Help FreeCAD, Donate
- Help: Tutorials, Video tutorials
- Workbenches: Std Base, Assembly, BIM, CAM, Draft, FEM, Inspection, Material, Mesh, OpenSCAD, Part, PartDesign, Points, Reverse Engineering, Robot, Sketcher, Spreadsheet, Surface, TechDraw, Test Framework
- Hubs: User hub, Power users hub, Developer hub