Std Importer

From FreeCAD Documentation
This page is a translated version of the page Std Import and the translation is 100% complete.

Std Importer

Emplacement du menu
Fichier → Importer...
Ateliers
Tous
Raccourci par défaut
Ctrl+I
Introduit dans la version
-
Voir aussi
Std Ouvrir, Import Export, Préférences d'Import Export

Description

La commande Std Importer importe la géométrie d'un format de fichier différent dans le document actif. De nombreux formats de fichiers sont pris en charge et pour certains formats, plusieurs options d'importation existent. Voir Import Export pour plus d'informations.

introduit dans la version 0.21 : si un format d'image est sélectionné, la commande créera un plan d'image.

Utilisation

  1. Il existe plusieurs façons d'appeler la commande:
    • Sélectionnez l'option Fichier → Importer... dans le menu.
    • Utilisez le raccourci clavier: Ctrl+I.
  2. Sélectionnez éventuellement le format de fichier correct dans la boîte de dialogue.
  3. Sélectionner un fichier.
  4. Appuyez sur le bouton Ouvrir.

Options

  • Appuyez sur Échap ou sur le bouton Annuler pour annuler la commande.

Remarques

Préférences

  • Voir : Préférences Import Export.
  • Le dernier emplacement de fichier utilisé est stocké : Outils → Éditer les paramètres... → BaseApp → Preferences → General → FileOpenSavePath.
  • Le dernier filtre d'importation utilisé est stocké : Outils → Éditer les paramètres... → BaseApp → Preferences → General → FileImportFilter.

Plan d'image

Un plan d'image est une représentation plane d'une image dans la vue 3D. Il peut par exemple être utilisé lors de la création d'un modèle basé sur des photographies d'un objet existant.

Par défaut, un plan d'image est placé sur le plan global XY. La taille initiale d'un plan d'image est calculée sur la base d'une résolution de 96 px/pouce.

Modifier

  1. Pour modifier un plan d'image, effectuez l'une des opérations suivantes :
    • Double-cliquez sur le plan d'image dans la vue en arborescence.
    • Cliquez avec le bouton droit de la souris sur le plan d'image dans la vue en arborescence et sélectionnez Modifier l'image... dans le menu contextuel.
  2. Si le plan de l'image n'est pas parallèle au plan XY, XZ ou YZ du système de coordonnées global, il est réaligné pour être parallèle au plan XY.
  3. Le panneau de tâches Réglages du plan de l'image s'ouvre.
  4. Sélectionnez Plan XY, Plan XZ ou Plan YZ du système de coordonnées global.
  5. Cochez Inverser le sens pour faire pivoter le plan de l'image de 180°. L'axe de rotation dépend du plan sélectionné. Pour le plan XY, il s'agit de l'axe X global. Pour les plans XZ et YZ, il s'agit de l'axe Z global.
  6. Les Décalage, Distance X et Distance Y sont relatifs au système de coordonnées du plan de l'image. Un petit décalage négatif peut être utile pour tracer l'image avec une esquisse ou une géométrie de Draft.
  7. Modifier éventuellement la Transparence.
  8. Options de Dimension de l'image :
    • Mise à l'échelle par entrée numérique :
      1. Décochez éventuellement Conserver les proportions pour une mise à l'échelle inégale.
      2. Entrez une Largeur et/ou une Hauteur.
    • Mettre à l'échelle en choisissant des points :
      1. Appuyez sur le bouton Calibrer.
      2. Choisissez deux points dans l'image.
      3. Une ligne de dimension est affichée.
      4. Saisissez la dimension souhaitée.
      5. Appuyez sur Entrée ou sur le bouton Appliquer.
  9. Appuyez sur le bouton OK pour confirmer les modifications et fermer le panneau de tâches.

Propriétés

Voir aussi : Éditeur de propriétés

Un objet Plan d'image est dérivé d'un objet App GeoFeature et hérite de toutes ses propriétés. Il possède également les propriétés supplémentaires suivantes :

Données

Image Plane

  • DonnéesImage File (FileIncluded) : le fichier d'image utilisé pour le plan d'image. Ce fichier est stocké dans le fichier .FCStd.
  • DonnéesXSize (Length) : largeur du plan de l'image.
  • DonnéesYSize (Length) : hauteur du plan de l'image.

Vue

Object Style

  • VueLighting (Enumeration) : comment le plan de l'image est éclairé dans la vue 3D. Peut être Two side ou One side.