Versionshinweise 1.0

From FreeCAD Documentation
(Redirected from Release notes 0.22/de)
This page is a translated version of the page Release notes 1.0 and the translation is 100% complete.
FreeCAD 1.0 ist in Entwicklung, es steht noch kein Veröffentlichungstermin fest.

Fehlen Funktionen? Das spricht man am besten im Forumsbeitrag Release notes for v1.0 an.

Siehe FreeCAD Unterstützen für Möglichkeiten etwas zu FreeCAD beizutragen.
Alle Bilder auf dieser Seite müssen das Suffix _relnotes_1.0 tragen.


FreeCAD 1.0 wurde am T Monat 2024 veröffentlicht, es kann von der Download-Seite heruntergeladen werden. Diese Seite listet alle Neuerungen und Änderungen auf.

Ältere FreeCAD-Versionshinweise findet man in der Funktionsliste.

Platzhalter für ein auffälliges Bild, das von den Admins im user showcases forum ausgesucht wird.

Allgemein

Das seit langem bestehende Problem der topologischen Benennung (TNP) wurde, dank der gemeisamen Anstrengung und harter Arbeit einiger Entwickler, endlich behoben. Der Realthunder-Fix wurde sorgfältig implementiert und so verbessert, dass er in FreeCADs Master-Version funktioniert. Das Projekt dauerte über ein Jahr und die Implementierung wurde mit dem folgenden PR abgeschlossen, der den Fix aktiviert. Umfangreiche Tests werden folgen.

Pull-Request #13705

FreeCAD hat ein neues Logo. Es wurde aus den 5 Gewinnern des öffentlichen Wettbewerbs ausgewählt.

Pull-Request #14284

Benutzeroberfläche

Ein Indikator für das Drehzentrum wurde hinzugefügt. Dieser Indikator wird angezeigt, wenn die Ansicht durch Ziehen mit der Maus gedreht wird. Er kann wahlweise in den Voreinstellungen deaktiviert werden. Außerdem gibt es Einstellungen für seine Farbe, Transparenz und Größe.

Pull-Request #9909 und Pull-Request #10790


Klick auf das Bild, wenn die Animation nicht automatisch startet.
Auswahlfilter wurden hinzugefügt; und grenzen die Auswahl auf Knoten, Kanten oder Flächen ein.

Pull-Request #10271

Für mehr Flexibilität ist der Aufgaben-Bereich jetzt ein eigenständiges, andockbares Widget, aber das alte Layout wird als Voreinstellung beibehalten.

Pull-Request #10681 und Pull-Request #10848

Die Darstellung der Anfasser des Werkzeugs Bewegen wurde verbessert. Es besitzt jetzt auch drei Ebenen-Anfasser, um Objekte entlang der 3 Hauptebenen zu bewegen.

Pull-Request #10706

Realthunders Funktion, die das Überlagern von Dock-Widgets ermöglicht (Baum- und Aufgaben-Transparenz) wurde hinzugefügt.

Pull-Request #7888

Die Lichtquelle kann jetzt in den Voreinstellungen eingestellt werden (Einstellungen... → Anzeige).

Pull-Request #11146

Das Voreinstellungsfenster wurde übrearbeitet um die Karteitreiter durch eine Baumstruktur zu ersetzen.

Pull-Request #11018

Für die Auswahl der Arbeitsbereiche wurde TabBar hinzugefügt. Es kann in unter Einstellungen → Arbeitsbereiche aktiviert und konfiguriert werden.

Pull-Request #12270

Ein neues universelles Messwerkzeug wurde hinzugefügt und ersetzt die alten Part Messwerkzeuge.

Pull-Request #9750 und folgende


Auf das Bild klicken, wenn die Animation nicht automatisch startet.
Das Werkzeug Align to selection wurde hinzugefügt und ermöglicht die Richtung von Ansichten normal auf Flächen oder an Kanten entlang festzulegen.

Pull-Request #13906

Weitere Verbesserungen der Benutzeroberfläche

  • Es wurde ein "project unit system" eingeführt. Pull-Request #9521
  • Das Werkzeug Part Schnittansicht funktioniert jetzt auch in einer perspektivischen Ansicht. Pull-Request #10143
  • Eine Option zum alphabetischen Sortieren von Arbeitsbereichen wurde hinzugefügt (steht nach einem Rechtsklick in Einstellungen → Arbeitsbereiche zur Verfügung). Pull-Request #10363
  • Ein Filter Datei suchen und ein Filter In Datei suchen wurden zum Dialog Std DlgMakroAusführen hinzugefügt. Pull-Request #10714
  • Das Menü Ansicht und die Symbolleiste Ansicht wurden überarbeitet. Pull-Request #10761
  • Die Stop-Schaltfläche wurde aus der Makro-Symbolleiste entfernt. Die Schaltfläche Makro aufzeichnen... Wandelt sich jetzt in eine Stop-Schaltfläche, während ein Makro aufgezeichnet wird. Pull-Request #10836
  • Die Reset-Schaltfläche in den Voreinstellungen zeigt jetzt ein Menü an, das Optionen für das Zurücksetzen der Einstellungen auf unterschiedlichen Ebenen enthält: alle, die der aktuellen Gruppe oder die im aktuellen Menüreiter. Pull-Request #10688 and Pull-Request #11038
  • Das Hilfe-Modul wurde integriert und muss nicht länger als Addon heruntergeladen werden, um es zu benutzen.Pull-Request #11008
  • Einstellungen zum Anpassen des aktuellen Themas wurden hinzugefügt. Pull-Request #10238
  • Die Standardeinstellungen für Auswahlen wurden geändert, um das Auswählen von Objekten in der 3D-Ansicht zu vereinfachen. Pull-Request #11187
  • Ein Einheitenschema Meter dezimal wurde hinzugefügt, da das MKS-System (m/kg/s/Grad) nicht immer Maßangaben in Metern anzeigt - Größen unter 0,1 m werden auch noch in Millimetern angezeigt, obwohl für einige Anwendungen (z.B. Bauwesen) ein Einheitssystem, das alle Maße in Metern anzeigt sinnvoller ist.Pull-Request #11365
  • Weitere Markergrößen (20, 25 and 30px) wurden zu Einstellungen → Anzeige → 3D-Viewer → Markergröße hinzugefügt, um Anwender mit 4K-Bildschirmen zu unterstützen. Pull-Request #11524
  • Eine Option Transparenzmodus umschalten wurde dem Menü Ansicht und den Kontextmenüs hinzugefügt um den Transparenzmodus für ausgewählte Objekte schnell ein- oder ausschalten zu können. Pull-Request #10805
  • Ein Befehl Symbolleisten sperren wurde hinzugefügt. Damit können die Positionen von Symbolleisten fixiert oder wieder freigegeben werden. Er steht im Menü Ansicht und im Kontextmenü des Symbolleistenbereichs zur Verfügung.Pull-Request #11596
  • Die Standardfarbe für Formen wurde angepasst, um die Darstellng der Modelle zu verbessern. Pull-Request #12380 and Pull-Request #12488
  • Elemente in Part- und Gruppencontainern können jetzt durch Ziehen und Ablegen sortiert werden. Pull-Request #12293
  • Sichtbarkeitssymbole (Auge-Symbol) werden den Baumobjekten hinzugefügt, wenn die Option Sichtbarkeitssymbol anzeigen unter Einstellungen... → Anzeige → Benutzeroberfläche aktiviert ist. Pull-Request #12298
  • Ein Status Eingefroren (Option Einfrieren ein-/ausschalten (Toggle freeze) im Kontextmenü der Baumansicht) wurde hinzugefügt und ermöglicht das parametrische Verhalten eines Objekts abzuschalten (so dass es sich nicht verändert, auch wenn die Objekte von denen es abhängt geändert werden). Pull-Request #12580
  • Eine Eigenschaft Unterdrückt (Suppressed) wurde hinzugefügt, um ein Formelement zeitweise zu deaktivieren. Derzeit ist sie im Arbeitsbereich PartDesign versteckt (Rechtsklick im Eigenschafteneditor und Alle anzeigen auswählen, um sie anzuzeigen) bis das Problem der typologischen Benennung komplett behoben ist. Pull-Request #12096 und Pull-Request #12412
  • Navigationsanimationen wurden verbessert. Animationen verwenden jetzt eine Vereinfachungsfunktion und haben eine festgelegte Dauer, die unter Einstellungen... → Anzeige → Navigation eingestellt werden kann. Pull-Request #10881 und Pull-Request #12205
  • Die Schaltflächen der voreingestellten Ansichten sind jetzt unter einer einzigen Schaltfläche gruppiert. Die einzelnen Schaltflächen stehen noch immer in der zusätzlichen Symbolleiste Einzelne Ansichten (Individual views) zur Verfügung. Pull-Request #12878 und Pull-Request #14434
  • Der Name des gerade aktiven Dokuments wird jetzt in der Titelleiste des Fensters angezeigt. Pull-Request #12035
  • Ein Befehl zum Anzeigen des Eigenschateneditors wurde hinzugefügt. Pull-Request #12024
  • Die Integration von 3Dconnexion-Geräten in FreeCAD unter Windows wurde verbessert. Pull-Request #12929
  • Eine Funktion Quick Measure wurde hinzugefügt. Sie verwendet die Statusleiste, um Informationen zu den Abmessungen (Kantenlänge, Flächeninhalt, Abstand zwischen Punkten und/oder Kanten oder Winkel zwischen Kanten) der aktuellen Auswahl in der 3D-Ansicht anzuzeigen. Pull-Request #12217
  • Symbolleisten können jetzt gezogen und auf der Statusleiste und den Menüleisten abgelegt werden. Pull-Request #13571
  • Eine Schaltfläche Reload stylesheet wurde hinzugefügt, um die Entwicklung von Stylesheets zu unterstützen. Sie gehört standardmäßig zu keiner Symbolleiste und muss manuell mit Werkzeuge → Benutzerdefiniert → Symbolleisten → Ansicht hinzugefügt werden. Pull-Request #13982
  • Dokumentsymbole (einschließlich von u.a. Öffnen und Speichern) wurden verbessert und vereinheitlicht. Pull-Request #13865
  • Das Einpassen-Symbol wurde ausgetauscht, für bessere Erkennbarkeit. Pull-Request #14180
  • Mehrere Symbole (wie z.B. Neu) wurden verbessert. Pull-Request #14278
  • Die Symbole der Aufgaben-Tafeln von Sketcher und PartDesign wurden verbessert. Pull-Request #13968
  • Im Headless-Modus enthält die interaktive Python-Konsole jetzt eine Tab-Vervollständigung, sofern das Modul readline zur Verfügung steht. Pull-Request #14213
  • Eine Option zur Darstellung der internen Namen in der Baumansicht wurde hinzugefügt. Sie ist standardmäßig deaktiviert und kann unter Einstellungen → Anzeige → Benutzeroberfläche → Hide Internal Names aktiviert werden. Pull-Request #14237

Kernsystem und API

Kern

  • Vektor-Funktionen der Vector-API können jetzt in Ausdrücken verwendet werden. Pull-Request #8603.
  • Der Python-Editor passt das Einrücken jetzt an die vorherige Zeile an, wenn die Enter-Taste gedrückt wird. Pull-Request.
  • Der Name der Eigenschaft, die die Referenzobjekte eines Anhangs enthält, wurde von DatenSupport zu DatenAttachmentSupport geändert. Pull-Request #12714.

API

Neue Python-API

  • getUpDirection: Ermittelt die Nach-oben-Richtung einer View3DInventor-Ansicht. Pull-Request #10060

Entfernte Python-API

Geänderte Python-API

  • Die Methoden zum Speichern bzw. Wiederherstellen von benutzerdefinierten Daten eines Python-Elements wurden von __getstate__ bzw. __setstate__ zu dumps bzw. loads umbenannt. Dies wurde erforderlich durch interne Änderungen in Python-3.11. Pull-Request #10769 and Pull-Request #12243.

Addon-Manager

Arbeitsbereich Assembly

Ein Arbeitsbereich Assembly (Zusammenbau, Baugruppe)wurde endlich als fester Bestandteil zu FreeCAD hinzugefügt. Er verwendet den quelloffenen Gleichungslöser Ondsel-Solver. Grundlegende Funktionen (Verbindungen - joints) stehen schon zur Verfügung, weitere Funktionen sind in der Entwicklung.

Pull-Request #10427, Pull-Request #10764, Pull-Request #12406 und weitere

Weitere Assembly-Verbesserungen

  • Assembly-Symbole wurden überarbeitet und die experimentellen Funktionen stehen jetzt zur Verfügung. Pull-Request #13866
  • Winkellage ausrichten, Rechtwinklig ausrichten und Parallel ausrichten wurden hinzugefügt. Pull-Request #14008

Arbeitsbereich BIM

  • Arch wurde in BIM integriert und zusammen ergeben sie den neuen Arbeitsbereich BIM. Pull-Request #13783
  • Der Befehl Arch Schnittebene wurde verbessert. Er beachtet jetzt Einbettungen sowie Verknüpfungen und die Auswahl ist flexibler. Es können jetzt auch Kanten ausgewählt werden, sodass der Befehl Arch Schnittlinie nicht mehr gebraucht wird. Pull-Request #11254 und Pull-Request #11792
  • Die BIM-Voreinstellungen wurden überprüft und verbessert. Die Seiten im Voreinstellungseditor haben ein neues Aussehen erhalten. Pull-Request #11940 und Pull-Request #12038
  • Eine Einstellung Nur Öffnung wurde zum Befehl Arch Fenster hinzugefügt. Pull-Request #12209
  • Das Arch-Dach-Objekt hat jetzt eine Eigenschaft Subvolume. Diese ermöglicht ein selbsterstelltes Festkörperobjekt als Abzugsvolumen für ein Dach zu verwenden. Pull-Request #12346
  • Außerdem wird für ein Arch-Dach-Objekt, das ein Festkörperobjekt als Base verwendet, automatisch ein geeignetes Abzugsvolumen erstellt. Wie ein Dach, das auf einem Linienzug basiert, kann so ein Dach von den Wänden eines Gebäudes mit Arch Entfernen abgezogen werden. Pull-Request #13221
  • Das Werkzeug Arch Referenz wurde aktualisiert: Referenzobjekte können jetzt komplette Dateiinhalte verwenden, anstatt ein Teil auswählen zu müssen; die Unterstützung für DXF- und IFC-Dateien (Wenn NativeIFC zur verfügung steht) wurde hinzugefügt. Pull-Request #13287

Weitere BIM-Verbesserungen

Arbeitsbereich CAM

Weitere CAM-Verbesserungen

  • Rest machining wurde reimplementiert, um Eingaben aus dem G-code früherer Arbeitsgänge aufzunehmen (anstatt die internen Inhalte von Area-Arbeitsabläufen zu verwenden). Dies ermöglicht die Unterstützung von rest machining in Area-Arbeitsabläufen nach Nicht-Area-Arbeitsabläufen (most notably Adaptive). Pull-Request #11939
  • G43-Werkzeughöhenausgleich (tool height compensation) wurde zum CAM-Post-Processor centroid hinzugefügt. Pull-Request #12652
  • Eine Option Feed retract wurde zu den Eigenschaften der Bohrvorgänge für Reiben und Bohren hinzugefügt.Pull-Request #13254
  • Ein neuer CAM-Simulator, der auf Low-level-OpenGL-Funktionen basiert (schneller und präziser), wurde hinzugefügt. Pull-Request #13884
  • Der Vorgang VGravur wurde überarbeitet um Funktionen hinzuzufügen, die in anderer CAM-Software normalerweise vorhanden sind (Step down, Finishing pass, Head movement optimization und die Methode debugVoronoi), die es ermöglichen die Qualität der gravierten Oberfläche erheblich zu verbessern und gleichzeitig die Graviergeschwindigkeit um 50% zu steigern. Pull request #14093

Arbeitsbereich Draft

Weitere Draft-Verbesserungen

Arbeitsbereich FEM

Die Position der Beschriftung der Farblegende wurde angepasst, damit die oberen weniger anfällig dafür sind, vom Navigationswürfel verdeckt zu werden. Die Voreinstellungen für Schriftart und Farbe der Beschriftung wurden für eine bessere Sichtbarkeit angepasst und Voreinstellungen wurden hinzugefügt, die eine Anpassung von Farbe und Größe der Beschriftung ermöglichen.

Pull-Request #10552

Der Befehl FEM PostFilterLinearizedStresses kann jetzt die Spannungstensor-Komponenten für linearisierte Spannungsberechnungen verwenden. Vorher konnten nur Von Mises- und Tresca-Spannung sowie (größte/mittlere/kleinste) Hauptspannungen hierfür verwendet werden.

Pull-Request #11724

Unterstützung für zyklische Symmetry über die Randbedingung Verbinder in CalculiX wurde hinzugefügt, und ermöglicht Modelle zu analysieren, die aus rotierend wiederholten Symmetrieobjekten eines einzelnen Sektors aufgebaut sind.

Pull-Request #12289

Unterstützung für 2D-Analysen (ebener Spannungszustand (plane stress), ebener Verformungszustand (plane strain) und achsensymmetrisch) wurde für den Gleichungslöser CalculiX hinzugefügt. Sie werden auf gleiche Weise konfiguriert, wie Simulationen mit Schalenelementen, aber es gibt ein paar zusätzliche Einschränkungen, die auf der zuvor erwähnten Wiki-Seite beschrieben werden. Die neue Option Model Space muss richtig gesetzt werden. Pull-Request #12562
Als ersten Schritt zur Unterstützung von Würfelelementen (Hexaeder-Elemente), ist ihre Erstellung mit der Unterteilungstechnik von Gmsh zu sehen, die jetzt Dank der neuen Gmsh-Eigenschaft Subdivision Algorithm zur Verfügung steht. Sie kann auch zur Erstellung von vierseitigen Elementen eingesetzt werden. Pull-Request #12698
Neue Ansicht-Eigenschaften wurden zu den Ergebnis-Pipeline-Objekten hinzugefügt. Farbe und Breite von Netzkanten können jetzt für den Modus Surface with Edges angepasst werden. Die Knotengröße kann jetzt für den Modus Nodes angepasst werden. Es gibt auch eine Transparenzeinstellung für jeden Modus. Pull-Request #13066
FEM-Randbedingungenkönnen jetzt unterdrückt werden (ein Rechtsklick auf eine Randbedingung und Suppress drücken) und werden dann von den Gleichungslösern ignoriert. Auf diesem Wege ist es möglich, den Analyseaufbau zu verändern, ohne die gerade nicht benötigten Randbedingungen löschen zu müssen. Pull-Request #12359
Unterstützung für CalculiX' Randbedingung Starrer Körper wurde hinzugefügt und ermöglicht es endlich die Verdrehung beliebiger Komponenten zu simulieren und u.a. fern angreifende Lasten anzuwenden.Pull-Request #13900

Weitere FEM-Verbesserungen

  • Der Menüeintrag Modell → Randbedingungen ohne Löser wurde aus der Benutzerschnittstelle (GUI) entfernt. die gelisteten Randbedingungen konnten nicht verwendet werden. Pull-Request #10457 and Pull-Request #10459
  • Das Wort "constraint" wurde aus den Namen und Beschreibungen der meisten Elemente des Arbeitsbereichs FEM entfernt, um eine korrekte Benennung sicherzustellen. Die (englischen) Namen wurden so geändert, dass sie den Normen der FEA-Industrie entsprechen und für neue Anwender intuitiv benutzbar sind. Pull-Request #10519 und Pull-Request #10799

(die Übersetzungen sind noch anzupassen)

  • Neue Symbole wurden für Solver CalculiX Standard, Solver job control und Run solver calculations hinzugefügt, um sie intuitiver bedinbar zu machen. Pull-Request #10885
  • Löser CalculiX (new framework) wurde aus der Benutzerschnittstelle entfernt, da er unfertig und im Moment unnötig ist. Die zugehörigen Beispiele wurden auch entfernt. Pull-Request #10823 und Pull-Request #12876
  • Das Layout einiger Aufgaben-Bereiche der Nachbereitungswerkzeuge wurde verbessert, um ihren horizontalen Platzverbrauch zu reduzieren. Pull-Request #11066
  • Der Aufgaben-Bereich von FEM RandbedingungTemperatur wurde überarbeitet, um Fehler bei der Bearbeitung dieser Funktion zu beheben.Pull-Request #11126
  • Ein alter Fehler der Funktion FEM NachbereitungDataAlongLine, der nur die Ausgabe der Größe aber nicht die der Vektorkomponenten ermöglichte wurde endlich behoben. Pull-Request #10992
  • FEM RandbedingungKraft and FEM RandbedingungDruck wurden überholt, damit sie quellcodeseitig besser funktionieren. Pull-Request #10935 and Pull request #10923
  • Der FEM NachbereitungDataAtPoint hat jetzt eine Eigenschaft PointSize, um die Größe des Punktsymbols für eine bessere Sichtbarkeit ändern zu können Pull-Request #11054
  • Der Befehl FEM Netzbereich wurde für bessere Verständlichkeit in der Benutzerschnittstelle (GUI) in FEM Netz aufbereiten umbenannt (der Name des Befehls bleibt unverändert). Pull-Request #11489
  • Die Größe der Schwerkraftbeschleunigung kann jetzt unter Verwendung der Eigenschaften von FEM RandbedingungEigengewicht angepasst werden. Pull-Request #12044
  • Randbedingung Kontakt und Randbedingung Verbinder wurden deutlich verbessert. Kontaktsteifigkeit (contact stiffness) verwendet jetzt die korrekte Einheit und ein Haftreibungswinkel (stick slope value) kann für Reibung (friction) in der Randbedingung Kontakt angegeben werden. Außerdem kann für die Randbedingung Kontakt eine Abstandskorrektur (clearance adjustment) angegeben werden, während für Randbedingung Verbinder ein () adjustment aktiviert oder deaktiviert werden kann. Pull-Request #12133
  • PaStiX und Pardiso wurden zu den unterstützten CalculiX-Matrizen-Lösern hinzugefügt. Sie sind die schnellsten ccx-Löser aber die Einsatzmöglichkeiten hängen von der Binärversion von CalculiX und zusätzlich verfügbaren Bibliotheken ab. Pull-Request #12478
  • Die Eigenschaft Beam Reduced Integration (standardmäßig auf true gesetzt) wurde zu den CalculiX-Löser-Einstellungen hinzugefügt. Sie stellt ein reduced integration scheme für Stabelemente zur Verfügung und ermöglicht so, den pipe beam-Abschnitt zu verwenden und Genauigkeitsprobleme bei Analysen mit u.a. Plastizität zu eliminieren. Pull-Request #12513
  • Das nicht fertiggestellte Werkzeug Nodes set wurde aus der Benutzerschnittstelle entfernt. Es konnte nicht verwendet werden. Pull-Request #12611
  • Das CalculiX-Analyseverfahren Check Mesh erstellt die Ergebnisnetze jetzt korrekt. Pull-Request #12612
  • Im Aufgaben-Dialog wurde verdeutlicht, dass der von pipe beam section verwendete Durchmesser der Außendurchmesser ist. Pull-Request #12609
  • Die Eigenschaft Beam Shell Result Output 3D des Gleichnungslösers CalculiX wird jetzt standardmäßig auf true gesetzt, um Ergebnisse für Balkenelemente und aussagekräftige Ergebnisse für Schalenelemente zu liefern. Pull-Request #12493
  • Symbole von Analyseelementen werden jetzt korrekt positioniert, wenn der Körper (oder Part-Behälter) eine geänderte Eigenschaft Placement enthält. Pull-Request #12527
  • Pressure load funktioniert jetzt korrekt für Schalenelemente, unabhängig von der Einstellung der Mesh-Groups. Diese Einstellung kann in den Voreinstellungen angepasst werden. Pull-Request #12437
  • Einfaches Härten (simple hardening) in FEM MaterialMechanicalNonlinear wurde in isotropes Härten (isotropic hardening) umbenannt. Außerdem wurde kinematisches Härten (kinematic hardening) hinzugefügt. Pull-Request #12666
  • Jetzt wird geometric nonlinearity automatisch aktiviert und ist erforderlich, wenn ein nicht lineares Material eingesetzt wird. Sie sind unabhängige Formen von Nichtlinearität. Pull-Request #12703
  • Gemischte Netze, die sowohl aus dreieckigen wie auch viereckigen Elementen bestehen, werden jetzt in der Ergebnis-Pipeline korrekt dargestellt. Pull-Request #12740
  • Die Eigenschaft Output Frequency wurde den Einstellungen des Gleichungslösers CalculiX hinzugefügt. Sie legt die Frequenz von output writing in increments fest. Pull-Request #12672
  • Es können jetzt vierseitige Elemente zweiter Ordnung erstellt werden. Zuvor hat die Gmsh-Einstellung 2nd order vierseitige Elemente erster Ordnung erstellt, da ein Gmsh -Befehl SecondOrderIncomplete fehlte, der jetzt intern eingesetzt wird. Diese Elemente können auch für 2D-Analysen eingesetzt werden. Pull-Request #12698 und Pull-Request #12774
  • Die Ermittlung der Ausrichtung von Balkenquerschnitten wurde teilweise korrigiert. Aufgrund eines Fehlers in der aktuellen Ausgabe von CalculiX können noch immer Probleme mit einigen Ausrichtungen auftreten. Pull-Request #12833
  • Die FEM-Kragbalken-Beispiele auf der Startseite wurden aktualisiert und ein neues, das 1D-Elemente verwendet, wurde hinzugefügt. Pull-Request #12871
  • Das Format in dem FreeCAD die Randbedingung Kraft schreibt, ist jetzt kompatibel mit dem CalculiX-Format und behebt seltene Probleme mit zu langen Zahlen. Pull-Request #12932
  • Es ist jetzt möglich, die Results-Pipeline im VTK-Format auszugeben. Pull-Request #12987
  • Neue Eigenschaften zur Steuerung der Schrittweite wurden den Einstellungen des Gleichungslösers CalculiX hinzugefügt. Zurzeit kann man zusätzlich zur Größe der Startschrittweite und der Dauer eines Schrittes die kleinste und die größte Schrittweite festlegen. Die Eigenschaft Iterations Thermo Mech Maximum wurde in Iterations Maximum umbenannt, da sie jetzt auch für statische (nicht thermomechanische) Analysen eingesetzt werden kann. Pull-Request #12662
  • Der Standardwert für Elementgeometrie2D wurde von 20 mm auf 1 mm geändert, da dies in der Praxis sinnvoller ist. Pull-Request #13077
  • Viele FEM-Symbole wurden erheblich verbessert, um Ähnlichkeiten zu reduzieren und zu verdeutlichen, was die Werkzeuge machen. Pull-Request #13130
  • Die Eigenschaft Thermo Mech Type wurde den Einstellungen des Gleichungslösers CalculiX hinzugefügt. Dies ermöglicht eine reguläre (gekoppelte) thermomechanische Analyse in eine entkoppelte umzustellen oder in eine mit reiner Wärmeübertragung. Pull-Request #13296
  • Die Eigenschaft Min. Size wurde für den Vernetzer Netgen hinzugefügt, um die Erzeugung zu kleiner Elemente während der Vernetzung komplexerer Geometrien zu verhindern. Pull-Request #12794
  • Ein altes Problem mit einer nicht funktionierenden Eigenschaft zum Skalieren von Symbolen für FEM-Randbedingungen wurde endlich behoben und die Eigenschaft Scale kann jetzt zum Einstellen der Größe von Symbolen einer ausgewählten Randbedingung eingesetzt werden.Pull-Request #13274
  • Das automatische Skalieren von FEM-Randbedingungen wurde verbessert, um besser mit sehr kleinen und sehr großen Objekten umgehen zu können. Pull-Request #13586
  • Wärmestrombelastung hat jetzt einen Strömungsmodus für Wärmestrahlung (radiation heat flux mode), um Oberflächenstrahlung in die Umgebung zu modellieren. Pull-Request #13466
  • Einige nicht verwendete Ansicht-Eigenschaften von Randbedingungssymbolen wurden entfernt. Pull-Request #13569
  • Neue Ansicht-Eigenschaften (mit der Haupteigenschaft Color Mode) wurden zu FEM-Netzobjekten hinzugefügt, so dass jetzt benutzerdefinierte Farben und Transparenzeinstellungen gespeichert und wiederhergestellt werden können. Pull-Request #13698
  • Jetzt wird standardmäßig nur noch der zuletzt hinzugefügte Filter jeder Ergebnis-Pipeline angezeigt. Pull-Request #13820
  • Die Tipps in den Aufgaben-Bereichen mehrerer Randbedingungen wurden geändert, um jetzt die Regeln zur Geometrieauswahl für die einzelnen Randbedingungen wiederzugeben. Pull-Request #13921 und Pull-Request #14002
  • Unterstützung für Wärmefluss-Ergebnisse aus thermomechanischen Analysen wurde den Ergebnis-Pipelines hinzugefügt. Pull-Request #14019
  • Die RandbedingungSectionPrint wurde verbessert und fügt die Unterstützung für Wärmefluss- und Zugspannungsergebnisse hinzu (steht noch nicht zur Verfügung, da 3D-Fluid-Analysen mit CalculiX noch nicht implementiert sind). Pull-Request #14046
  • Body heat source kann jetzt mit CalculiX verwendet werden und hat zwei Eingabemodi - dissipation rate [W/kg] und total power [W]. Pull-Request #14417
  • Die Rotations-Eigenschaften des lokalen Koordinatensystems wurden für eine vereinheitlichte Bedienung durch eine einzige Eigenschaft Rotation ersetzt. Pull-Request #14353

Material

Das System zum Verarbeiten von Materialdaten, inklusive des Editors, wurde komplett überarbeitet. Weitere diesbezügliche Verbesserungen werden folgen.

Pull request #10690

Eine Voransicht der Materialdarstellung wurde hinzugefügt, um Materialien auf dieselbe Weise wie im Dokument anzuzeigen.

Pull-Request #11628

Das neue Materialsystem wird jetzt für Darstellungseigenschaften eingesetzt.

Pull-Request #13294

Weitere Material-Verbesserungen

  • Dialoge zum Anzeigen der Darstellungs- und der Materialeigenschaften eines Objekts wurden hinzugefügt und stehen als Werkzeuge Appearance... und Material... zur Verfügung. Pull-Request #13967

Arbeitsbereich Mesh

Weitere Mesh-Verbesserungen

Arbeitsbereich OpenSCAD

Weitere OpenSCAD-Verbesserungen

Arbeitsbereich Part

Das Werkzeug Part Skalieren wurde hinzugefügt, um das einfache Skalieren von Formen zu ermöglichen, ohne die Werkzeuge des Arbeitsbereichs Draft verwenden zu müssen.

Pull-Request #10583

Part Spiegeln unterstützt jetzt auch Referenzobjekte wie Part Ebene, um eine beliebige Spiegelebene zusätzlich zu den XY-, XZ- und YZ-Standardebenen festzulegen.

Pull-Request #11535

Weitere Part-Verbesserungen

  • Die Eigenchaft Frenet ist jetzt die Standardeinstellung für das Werkzeug Part Sweep, um übliche Darstellungsprobleme zu vermeiden.Pull-Request #11590
  • Jetzt verwenden alle Part-Symbole ein blaues Aussehen und für Grundkörper werden dieselben Symbole in der Symbolleiste und in der Baumansicht eingesetzt Pull-Request #14074
  • Der Befehl Skizze erstellen wurde zu Part-Symbolleiste und -Menü hinzugefügt, da Vorgänge wie Extrudieren normalerweise Skizzen als Ausgangselemente verwenden. Pull-Request #14318
  • Ein neues Befestigungsverfahren, XY parallel to plane genannt, wurde hinzugefügt. Dieses ergibt eine Befestigung wie bei XY des Objekts aber mit der XY-Ebene so verschoben, dass sie durch einen gewählten Punkt verläuft. Im Gegensatz zum Befestigungsverfahren Ursprung versetzen, verschiebt er nicht den Ursprung in 2D bzw. in der Skizze. Er kann mit den Ursprungsebenen, Bezugsebenen und Skizzen verwendet werden aber auch mit jedem anderen Objekt, das eine Eigenschaft Placement besitzt. Pull-Request #14372

Arbeitsbereich Part Design

Weitere Modi wurden zu Drehkörper und Nut hinzugefügt - to first/last, up to face und two dimensions.

Pull-Request #7193

Die Aufgaben-Dialoge von Block und Tasche wurden verbessert (neu arrangierte UI-Elemente, die Option Fläche auswählen bleibt deaktiviert, wenn nicht benötigt usw.).

Pull-Request #10392

Ein Versetzen-Modus (offset-mode) wurde dem Linearen Muster und dem Polaren Muster hinzugefügt. Der bisherige Modus wurde in Overall Length/Angle (Gesamtlänge/-winkel) umbenannt.

Pull-Request #10377

Eine experimentelle Unterstützung für mehrteilige Festkörper innerhalb eines Körpers wurde hinzugefügt. Sie kann in den Voreinstellungen (für neue Körper) oder in den Eigenschaften eines existierenden Körpers aktiviert werden.

Pull-Request #10360

Der Modus Up to shape wurde dem Werkzeug Pad hinzugefügt und ermöglicht die Extrusion mit mehreren Flächen zu begrenzen, im Gegensatz zum Modus Up to face, der nur die Auswahl einer einzelnen Fläche erlaubt.

Pull-Request #11392 and Pull-Request #14433

Weitere PartDesign-Verbesserungen

  • Die Option Dicke nach innen auftragen im Werkzeug Dicke ist jetzt standardmäßig aktiviert. Pull-Request #7488
  • Bezugspunkte verändern jetzt ihre Farbe, wenn sie hervorgehoben oder ausgewählt werden (wie andere Bezugselemente). Pull-Request #12439
  • PartDesign-Symbole wurden leicht verbessert. for consistency. Pull-Request #13109
  • Eine Eigenschaft Unterdrückt wurde hinzugefügt, um ein Formelement zeitweilig zu deaktivieren. Pull-Request #12096 and Pull-Request #12412
  • Die PartDesign-Symbolleisten wurden überarbeitet; Bezugselemente und skizzenbasierte Funktionen wurden jetzt gruppiert, Part GeometryPrüfen wurde zur Symbolleiste und zum Menü hinzugefügt; die Symbolleisten wurden in mehrere aufgeteilt, um zu ermöglichen, sie neu anzuordnen.Pull-Request #13833
  • Jetzt verwenden alle PartDesign-Formelemente dieselben Symbole in der Symbolleiste und in der Baumansicht.Pull-Request #14074
  • Ein neuer Modus Transform body wurde den PartDesign-Werkzeugen zum Spiegeln und Muster Erstellen hinzugefügt, der ermöglicht, die gesamte Form des Basis-Formelements zu verwenden, anstatt nur die individuellen Formen der hinzuzufügenden bzw. abzuziehenden Formelemente.Pull-Request #12589

Arbeitsbereich Points

Weitere Points-Verbesserungen

Arbeitsbereich Sketcher

Es wurde ein Ergänzungskreis für Bögen implementiert (um das Problem der Randbedingungen, die scheinbar nicht mit diesen verbunden sind, zu lösen) einschließlich des Befehls zum Ein-bzw.Ausschalten.

Pull-Request #9703


Bild anklicken, wenn die Animation nicht automatisch startet.
Ein kontextabhängiges Werkzeug für maßliche Randbedingung wurde hinzugefügt, um schnell und intuitiv unterschiedliche maßliche Randbedingungen festzulegen, mit einem einzigen vielseitigen Werkzeug.

Pull-Request #9810


Das Bild anklicken, wenn die Animation nicht automatisch startet.
Werkzeugparameter wurden hinzugefügt, die ermöglichen, dass Maße nebenher (während Formen gezeichnet werden) hinzugefügt werden. Abhängig von der Voreinstellung In-Ansicht-Parameter können sie deaktiviert, reduziert auf nur Maße (keine initialen Koordinaten) oder vollständig aktiviert sein. Außerdem wurden Auswahlmöglichkeiten zu den Formwerkzeugen hinzugefügt. Sie können mit der Taste M oder aus einer Ausklappliste im Aufgaben-Bereich ausgewählt werden. Einige Werkzeuge haben zusätzliche Einstellungen in Form von Checkboxen im Aufgaben-Bereich und zusätzliche Tastaturkürzel. Gegenwärtig stehen die neuen Elemente für Punkte, Linien, Kreisbögen, Ellipsen Rechtecke, Vielecke und Nuten zur Verfügung. Dies ist noch in Arbeit.

Pull-Request #11048, Pull-Request #11174 und folgende

Ein Werkzeug Versatzkontur wurde hinzugefügt und ermöglicht Kurven mit konstantem Abstand zu erstellen.

Pull-Request #11174

Die Variante Rechteck über drei Punkte wurde in zwei Versionen hinzugefügt: 3 Eckpunkte oder Mittelpunkt und 2 Eckpunkte.

Pull-Request #11174

Ein Werkzeug Bogennut wurde mit zwei Varianten zum Erstellen gekrümmter Nuten (Runde Enden und gerade Enden) hinzugefügt

Pull-Request #11174


Abbildung anklicken, wenn die Animation nicht automatisch startet.
Eine Randbedingung Horizontal/Vertikal wurde hinzugefügt. Sie fügt automatisch eine Randbedingung HorizontalFestlegen ein, wenn eine Linie eher einer horizontal ausgerichtet ist oder eine Randbedingung VertikalFestlegen, wenn sie eher vertikal ausgerichtet ist.

Pull-Request #11538

Die Darstellung der Randbedingungen für Winkel und Radius wurde verbessert. Randbedingungen für Winkel haben jetzt richtige Maßhilfslinien.

Pull-Request #11507

Ein Werkzeug Schwenken wurde hinzugefügt, das das Schwenken von Sketcher-Geometrien ermöglicht sowie das Erstellen von kreisförmigen Mustern aus ihnen.

Pull-Request #11264


Auf die Abbildung klicken, wenn die Animation nicht startet.
Es ist jetzt möglich Skizzengeometrie (mit Randbedingungen) auszuschneiden bzw. zu kopieren und einzufügen, indem die üblichen Tastaturkürzel : Ctrl+C, Ctrl+X and Ctrl+V verwendet werden. Nicht nur innerhalb einer einzelnen Skizze, sondern auch zwischen verschiedenen Skizen oder sogar zwischen verschiedenen Instanzen von FreeCAD. Die Geometrie wird in Form von Python-Befehlen kopiert, so kann sie auch auf anderen Wegen verwendet werden (z.B. im Forum geteilt werden).

Pull-Request #11537

Ein Werkzeug zum Skalieren wurde hinzugefügt und ermöglicht, die Skalierung von Sketcher-Geometrie zu verändern, durch Auswahl eines Mittelpunktes und eines Skalierungsfaktors oder durch zwei Referenzpunkte.

Pull-Request #11265


Bild anklicken, wenn die Animation nicht startet.
Tangetialität zu B-Spline-Kanten wurde hinzugefügt, sodass die Notwendigkeit entfällt, stattdessen Endpunkte und verschiedene Hilfskonstruktionen zu verwenden.

Pull-Request #11853

Die Werkzeuge RechteckigeAnordnung, Verschieben, Kopieren und Klonen wurden durch ein einziges Werkzeug Array transform (Sketcher Anordnen) ersetzt.

Pull-Request #11267

Ein Werkzeug Fase wurde hinzugefügt, mit der Option in den Modus Verrundung zu wechseln. Außerdem gibt es das eck-erhaltende Verrundungswerkzeug nicht mehr. Eine Option Eckpunkt erhalten (Standardmäßig aktiviert) wurde dem Werkzeug Sketcher VerrundungErstellen hinzugefügt.

Pull-Request #12898


Auf das Bild klicken, wenn die Animation nicht automatisch startet.
Das Werkzeug Symmetry wurde überarbeitet. Es wird jetzt durch Auswählen der Geometrie und abschließend einer Linie oder eines Punktes, über die/den gespiegelt wird, gestartet. Eine Vorschau wird angezeigt und das Verhalten des Werkzeugs kann durch Werkzeugeinstellungen gesteuert werden.

Pull-Request #11853


Bild anklicken, wenn die Animation nicht startet.
Die Randbedingung SymmetrieFestlegen wird jetzt automatisch angelegt, wenn der Mittelpunkt einer Linie ausgewählt wird.

Pull-Request #13147

Die Randbedingung AbstandFestlegen Kann jetzt zum Festlegen von Bogenlängen eingesetzt werden (ein Kreisbogen muss vorausgewählt sein).

Pull-Request #12602

Die Farbdarstellung von Punkten wurde geändert und hängt jetzt davon ab, ob es ein normaler Punkt bzw, Endpunkt ist (weiß, jetzt Standardfarbe, wenn das Werkzeug PunktErstellen verwendet wird), ein Hilfspunkt bzw. Mittelpunk (blau) oder ein Punkt, der deckungsgleich (koinzident) mit einem anderen liegt (rot).

Pull-Request #13098


Bild anklicken, wenn die Animation nicht automatsch startet.
Das Werkzeug Trim edge kann jetzt im Modus Halten-und Ziehen verwendet werden.

Pull-Request #13188

Weitere Sketcher-Verbesserungen

Arbeitsbereich Spreadsheet

Weitere Spreadsheet-Verbesserungen

Arbeitsbereich Start

Ein Abschnitt Neue Datei, der einige Quick-Start-Schaltflächen enthält, wurde zur Startseite hinzugefügt.

Pull-Request #10171

Das visuelle Erscheinungsbild der Startseite wurde überholt. Sie sieht jetzt moderner und einheitlicher aus.

Pull-Request #10391

Ein einfaches Erst-Start-Widget wurde hinzugefügt und wird in naher Zukunft noch erweitert werden.

Pull-Request #13650

Weitere Start-Verbesserungen

  • Die Seite der Einstellungen des Arbeitsbereichs Start wurde umgestellt. Pull-Request #10520
  • Es gibt jetzt eine Option Custom CSS für die Startseite, die es dem Benutzer ermöglicht, den CSS-Stil der Startseite in den Einstellungen des Arbeitsbereichs Start anzupassen.Pull-Request #10520
  • Die Einstellung Hide scrollbars wurde entfernt. Die Scrollbars auf der Startseite sind jetzt passend zum Thema gestaltet und sind viel dünner. Pull-Request #10520
  • Es gibt jetzt Einstellungen für das Ausblenden und das Ändern der Göße von Datei-Thumbnail-Symbolen auf der Startseite.Pull-Request #10410
  • Die Startseite ist jetzt eine auf QtWidgets basierende App und kein Arbeitsbereich (mehr). Sie kann über den Menüeintrag Hilfe → Start angezeigt werden. Pull-Request #13134

Arbeitsbereich Surface

Weitere Surface-Verbesserungen

Arbeitsbereich TechDraw

Das Werkzeug Hilfskreis wurde hinzugefügt, um das Erstellen von Hilfskreisen durch Auswahl des Mittelpunktes und Festlegen des Radius zu ermöglichen.

Pull-Request #10763

Das Werkzeug HinweisBogenlänge wurde hinzugefügt, um einen maßähnlichen Hinweis für die Bogenlänge ausgewählter Kanten zu erstellen.

Pull-Request #11532

Das Werkzeug AddOffsetVertex wurde hinzugefügt, um Hilfspunkte relativ zu ausgewählten Knoten zu erstellen.

Pull-Request #11655

Das Werkzeug UnterbrocheneAnsicht wurde hinzugefügt, um einfacher lange Objekte darstellen zu können.

Pull-Request #13331


Bild anklicken, wenn die Animation nicht automatsch startet.
Ein neues kontextabhängiges Werkzeug für Maßeinträge, basierend auf dem im Sketcher eingeführten, wurde hinzugefügt.

Pull-Request #13525

Weitere TechDraw-Verbesserungen

  • Schnittansichten, die auf anderen Schnittansichten basieren, verwenden jetzt standardmäßig die originale (unbeschnittene) Form. Dies kann in den Einstellungen der Schnittansichten geändert werden, um stattdessen die vorhergehende beschnittene Form zu verwenden Pull-Request #10281
  • Hilfsobjekte und Mittellinien können jetzt ausgewählt und durch drücken der Löschtaste entfernt werden. Bisher wurde so die ganze Ansicht gelöscht.Pull-Request #10695 und Pull-Request #10813
  • Ein neues intuitiveres Symbol wurde für das Werkzeug Schweißsymbol hinzugefügt. Pull-Request #10936
  • Das Verhalten des Modus Punkt + Kante im Werkzeug Längenmaß wurde korrigiert. Pull-Request #10860
  • Der Schaltfläche Ansichtsrahmen ein- oder ausschalten wurde ein Aktiviert-Status hinzugefügt, damit der Anwender sehen kann, ob die Schaltfläche aktiviert ist oder nicht.Pull-Request #11240
  • Das Verhalten des Werkzeugs LiniendarstellungÄndern wurde verbessert. Jetzt wird das Werkzeug (auch) durch Doppelklicken auf einer Linie aufgerufen. Und die Linieneinstellungen werden korrekt wiederhergestellt, wenn der Anwender Abbrechen drückt. Vorher war kein Unterschied zwischen OK und Abbrechen. Pull-Request #11188
  • Farbe und Transparenz von Flächen können jetzt pro Ansicht eingetellt werden.Pull-Request #11315
  • Der Mehrfachauswahl-Modus wurde hinzugefügt und kann in den Einstellungen aktiviert werden. In diesem Modus können mehrere Knoten, Kanten oder Flächen durch klicken mit der linken Maustaste ausgewählt werden, ohne dass die Ctrl- bzw. Strg-Taste gedrückt gehalten werden muss. Pull-Request #11417
  • ErgänzungFlächenangabe kann jetzt auch beliebige Flächen berechnen. Pull-Request #11473
  • Unterbreochene Linien werden jetzt ISO-/ANSI-Normen entsprechend dargestellt, anstatt nach Qt-Linienstilen. Eine neue Voreinstellung zum Auswählen der Norm wurde hinzugefügt. Pull-Request #11594
  • Das Verhalten des Werkzeugs AxonometrischesLängenmaß wurde verbessert. Jetzt wird der tatsächliche (3D-) Wert automatisch berechnet und in die Eigenschaft Format Spec (als Text) eingefügt, wenn Kanten parallel zu den globalen Koordinatensystemachsen bemaßt werden. Pull-Request #11678
  • Das Werkzeug ErgänzungSchnittAusrichten kann jetzt verwendet werden, indem eine Kante in einer Schnittansicht und ein Knoten in der Quellansicht ausgewählt werden.Pull-Request #11797
  • Kleine aber wichtige Verbesserungen für die Bedienbarkeit wurden hinzugefügt - Ein Doppelklick auf ein TechDraw-Zeichnungsblatt öffnet jetzt den Arbeitsbereich und das Werkzeug TechDraw Ansicht verschieben wurde durch einfaches Zeihen und Ablegen in der Baumansicht ersetzt. Auch die Werkzeuge TechDraw Ansicht zur Ansichtsgruppe hinzufügen und TechDraw Ansicht aus Ansichtsgruppe entfernen wurden durch Zeihen und Ablegen in der Baumansicht ersetzt.Pull-Request #13063
  • Die Zeichnungsvorlagen werden jetzt automatisch mit vorhandenen Informationen ausgefüllt (z.B. Datum und Benennung). Pull-Request #13005
  • Das Werkzeug Form projizieren wurde aus TechDraw entfernt, da es ein Erbe des Arbeitsbereichs Drawing war und nichts mit einem TechDraw-Zeichnungsblatt zu tun hat. Pull-Request #13655
  • Das Werkzeug Ansicht einfügen wurde verbessert, und verwendet jetzt mehr Objektarten und Einstellungen. Dies ermöglicht folgende Werkzeuge aus der Symbolleiste zu entfernen: Tabellenansicht, ArchAnsicht, Symbol, Bild und Ansichtengruppe. Pull-Request #13219
  • Einrasten wurde hinzugefügt, um das automatische Ausrichten von Ansichten und Maßen zu ermöglichen. Pull-Request #13659
  • Der Umgang mit Hilfsgeometrie wurde in vielerlei Hinsicht verbessert. Pull-Request #14216

Kompilieren

Bekannte Einschränkungen