Poradnik dla Środowiska pracy Raytracing
Środowisko pracy Raytracing
| Temat |
|---|
| Raytracing |
| Poziom trudności |
| Początkujący |
| Czas wykonania |
| 10 minut + czas renderowania |
| Autorzy |
| Drei |
| Wersja FreeCAD |
| 0.16 do 0.20 |
| Pliki z przykładami |
| Zobacz również |
| - |
Wprowadzenie
Ten poradnik ma na celu zapoznanie czytelnika z podstawowym przepływem pracy w środowisku Raytracing, jak również z większością narzędzi, które są dostępne do tworzenia wyrenderowanego obrazu. Uwaga, środowisko Raytracing jest przestarzałe i nie jest już dołączone do programu FreeCAD po wersji 0.20. Dla obecnych wydań programu FreeCAD, użyj nowszego środowiska pracy Render, dostępnego poprzez Menedżer dodatków.
Wymagania
- FreeCAD w wersjach od 0.16 do 0.20 z dostępnym środowiskiem pracy Raytracing.
- POV-Ray i/lub LuxRender jest zainstalowany w systemie.
- W przypadku POV-Ray, nie wystarczy mieć tylko binarny plik wykonywalny na miejscu, ale również wymagana jest instalacja wspierających plików. W Ubuntu, są one dostarczane przez pakiet z flagą Recommends povray-includes. Potencjalne problemy były również widziane z instalacjami Linuksa wymagającymi lokalnych plików konfiguracyjnych do ręcznego utworzenia w folderze domowym użytkownika, jak omówiono na forum.
- W przypadku POV-Ray, zalecana jest instalacja makrodefinicji psicofil'a.
- Czytelnik posiada podstawową wiedzę do korzystania z środowisk pracy Część i Projekt Części.
Sposób postępowania
Modelowanie
W tym przykładzie jako obiekt badania używany jest sześcian, ale zamiast niego mogą być używane modele utworzone w Środowiskach pracy Part lub PartDesign.
- Utwórz nowy dokument.
- Aktywuj środowisko pracy Projekt Części.
- Utwórz sześcian. Możesz dowolnie zmieniać jego właściwości.
Teraz mamy model, z którym możemy pracować.
Przygotowanie do renderingu
- Przełącz się do środowiska Raytracing.
- Przełączyć widok na Perspektywę. Przejdź do menu Widok i wybierz Perspektywa.
- Ustaw lokalizację dla renderera. Przejdź do menu Edycja → Preferencje. Kliknij na Raytracing i ustaw lokalizację na plik wykonywalny.
- Ustaw rozmiar renderowanego obrazu. Przejdź do menu Edycja → Preferencje. Kliknij na Raytracing i ustaw żądany rozmiar obrazu.
POV-Ray
- Wybierz
Nowy projekt PovRay. Z menu głównego wybierz RadiosityNormal.
LuxRender
- Wybierz
Nowy projekt LuxRender. Z rozwijanego menu wybierz LuxClassic.
Ustawianie pozycji ujęcia widoku
- Ustaw widok 3D w żądanym miejscu i odległości od modelu. W tym przypadku używamy widoku aksonometrycznego.
- Wybierz Folder projektu w widoku drzewa.
- Wybierz
Resetuj ujęcie widoku.
Importowanie modelu
- Wybierz model do renderowania.
- Wybierz opcję
Wstaw część
Uruchomienie Renderowania
- Wybierz funkcję
Renderowanie.
- Ustaw ścieżkę przechowywania obrazu.
- Poczekaj na zakończenie renderowania. Może to chwilę potrwać.
Przeglądanie wyników
FreeCAD natychmiast otworzy obraz po zakończeniu renderowania.
Dzięki temu ćwiczeniu poznaliśmy podstawowy przepływ pracy dla środowiska pracy Raytracing.
- Przybory: Nowy projekt Raytracing, Nowy projekt Luxrender, Wstaw część, Resetuj ujęcie widoku, Eksport projektu, Renderowanie
- Narzędzia: Eksport widoku, Eksport ujęcia widoku, Eksport Części
- Dodatkowe: Ustawienia
- Jak zacząć
- Instalacja: Pobieranie programu, Windows, Linux, Mac, Dodatkowych komponentów, Docker, AppImage, Ubuntu Snap
- Podstawy: Informacje na temat FreeCAD, Interfejs użytkownika, Profil nawigacji myszką, Metody wyboru, Nazwa obiektu, Edytor ustawień, Środowiska pracy, Struktura dokumentu, Właściwości, Pomóż w rozwoju FreeCAD, Dotacje
- Pomoc: Poradniki, Wideo poradniki
- Środowiska pracy: Strona Startowa, Złożenie, BIM, CAM, Rysunek Roboczy, MES, Inspekcja, Siatka, OpenSCAD, Część, Projekt Części, Punkty, Inżynieria Wsteczna, Robot, Szkicownik, Arkusz Kalkulacyjny, Powierzchnia 3D, Rysunek Techniczny, Test Framework