Voreinstellungseditor

From FreeCAD Documentation
Jump to navigation Jump to search
This page is a translated version of the page Preferences Editor and the translation is 63% complete.
Outdated translations are marked like this.

Einleitung

Zum Start des Voreinstellungseditors wähl man den Menüeintrag Bearbeiten → Einstellungen.... Im Mac OS erscheint die Menüoption Einstellungen... im FreeCAD-Menü anstatt im Bearbeitungsmenü (ersteres ist der vorgegebene Ort für Einstellungen auf dem Mac).

FreeCAD verwendet ein Arbeitsbereich-Konzept, wobei jeder Arbeitsbereich für bestimmte Aufgaben und Funktionen zuständig ist. Ein Arbeitsbereich kann seine eigenen Voreinstellungen haben. Diese werden nur im Voreinstellungseditor erscheinen, falls der Arbeitsbereich in der aktuellen FreeCAD-Sitzung geladen ist. Siehe Arbeitsbereiche weiter unten für mehr Informationen.

Wenn kein Arbeitsbereich geladen ist, erscheinen fünf Abschnitte im Voreinstellungseditor: Allgemein, Anzeige, Arbeitsbereiche, Addon-Manager und Import/Export. Weitere dazugeladene Arbeitsbereiche mit eigenen Voreinstellungen erscheinen darunter.

Bitte beachte, dass das Drücken der Zurücksetzen-Schaltfläche in der unteren linken Ecke des Voreinstellungsdialogs alle FreeCAD-Einstellungen auf ihren FreeCAD-Standardwert zurücksetzt

Einige fortgeschrittene Einstellungen können nur im Parameter-Editor geändert werden. Die Seite Fine-tuning führt einige auf.

Allgemein

Dieser Abschnitt der Voreinstellungen hat 9 Registerkarten: Allgemein, Dokument, Auswahl, Cache, Editor, Python-Konsole, Ausgabefenster, Makro und Einheiten. Eine 10. Registerkarte, Help, wird hinzugefügt, wenn das Help-Addon verfügbar ist. Diese Erweiterung kann mit dem Addon-Manager installiert werden.

Allgemein

Auf der Registerkarte "Allgemein" kann Folgendes festgelegt werden:

Name Beschreibung
Sprache ändern Wähle die Sprache der Benutzeroberfläche von FreeCAD aus.
Größe der Liste der letzten Dateien Gib an, wie viele Dateien in der Liste der letzten Dateien aufgelistet werden sollen.
Aktivieren des gekachelten Hintergrunds Wenn diese Option aktiviert ist, besteht der Hintergrund des Hauptfensters von FreeCAD standardmäßig aus Kacheln dieses Bildes: Background.png

Diese Option hat nur dann einen Effekt, falls keine Formatvorlage ausgewählt ist.

Das Bild kann geändert werden, indem die Ordner Gui/Images im Ordner hinzufügt werden:

%APPDATA%/FreeCAD (in Windows),

$HOME/.FreeCAD (auf Linux) oder

$HOME/Library/Preferences/FreeCAD (auf MacOS).

Stelle eine Datei mit dem Namen background.png in den Ordner Images und die Option abwählen/wählen, um die geänderte Datei anzuzeigen.

Formatvorlage Die Formatvorlagen definieren, wie die Benutzeroberfläche von FreeCAD aussieht. Technische Einzelheiten über die Formatvorlagen sind unter Interface_Customization/de#Themen zu finden.
Größe der Werkzeugleistensymbole Auswahl der Größe für die Werkzeugleistensymbole
Baumansichtsmodus Anpassung, wie die Baumansicht im Paneel angezeigt wird (Neustart erforderlich). Die Optionen sind:
  • Combo Ansicht: Kombiniert die Baumansicht und die Eigenschaftsansicht in einem Paneel.
  • Baumansicht und Eigenschaftsansicht: teile die Baumansicht und die Eigenschaftsansicht in ein separates Paneel.
  • Beide': alle drei Paneele beibehalten, und du kannst zwei Sätze von Baumansicht und Eigenschaftsansicht haben.
Modul nach dem Start automatisch laden Auswahl, welcher Arbeitsbereich direkt nach dem Start von FreeCAD verwendet werden soll
Startbildschirm beim Start aktivieren Wenn diese Option angehakt ist, wird der Startbildschirm beim Start von FreeCAD angezeigt.

Das Begrüßungsbildschirmbild kann geändert werden, indem eine Datei namens splash_image.png in den Ordner Images} gestellt wird, der unter Gekachelten Hintergrund aktivieren bereits erwähnt wurde.

Preferences General Tab General de.png

Dokument

Auf der Registerkarte "Dokument" kann Folgendes festgelegt werden:

Name Description
Create new document at start up If checked, FreeCAD will create a new document when started.
Document save compression level Specifies the compression level for FCStd files. FCStd files are ZIP-compressed files. Therefore you can rename their suffix .FCStd to .zip and open them with a ZIP archive program.
Using Undo/Redo on documents If checked, all changes in documents are stored so that they can be undone/redone.
Maximum Undo/Redo steps Specifies how many Undo/Redo steps should be recorded.
Allow aborting recomputation If checked, recomputations can be aborted by pressing Esc. This may slightly increase the recomputation time.
Run AutoRecovery at startup If there is a recovery file available FreeCAD will automatically run a file recovery when it is started. This way files can be restored if a crash occurred.
Save AutoRecovery information every Specifies how often a recovery file is written.
Save thumbnail into project file when saving document If checked, a thumbnail will be stored when the document is saved. The thumbnail will for example be shown in the list of recent files in the Start Workbench. It is possible to select a Size between 128×128 and 512×512 pixels for the thumbnail. Common sizes are powers of two: 128, 256, 512.
Add the program logo to the generated thumbnail If checked, the FreeCAD program logo Freecad.svg will be added to the thumbnail.
Maximum number of backup files to keep when resaving document If checked, backup files will be kept when saving the document. You can specify the number of backup files to keep. Backup files are previously saved versions of the document. The first backup file will have the file suffix .FCStd1, the second .FCStd2 and so on.
Use date and FCBak extension If checked, backup files will get the extension .FCbak and their file names get a date suffix according to the specified Date format. For a description of the date format see Date & time formats cheatsheet.

With the default settings a backup file will for example get this name TD-Cube.20200315-215654.FCBak (original filename is TD-Cube.FCStd).

Allow duplicate object labels in one document If checked, objects can have the same label.
Disable partial loading of external linked objects If partial loading of external linked objects is enabled, only the referenced objects and their dependencies will be loaded when the linked document is auto opened together with the main document. Such a partially loaded document cannot be edited. Double click the document icon in the tree view to reload it in full. A more detailed explanation of this feature can be found on the Assembly3 documentation page.
Author name All created documents will get the specified author name. Keep the author field blank if you do not want to include this information. If the option Set on save is checked, the field Last modified by will be set to the specified author when saving the file. This field can be viewed using the File → Project information menu option.
Company All created documents will get the specified company name.
Default license Specifies the license for new documents. For predefined licenses the License URL will automatically be set accordingly. Select Other for a custom license.
License URL Specifies an URL describing the license selected in Default license.

Preferences General Tab Document.png

Auswahl

Auf der Registerkarte "Auswahl" (eingeführt mit Version 0.19) kann Folgendes festgelegt werden:

Name Description
Auto switch to the 3D view containing the selected item Enables the Tree view SyncView mode.
Auto expand tree item when the corresponding object is selected in 3D view Enables the Tree view SyncSelection mode.
Preselect the object in 3D view when mouse over the tree item Enables the Tree view PreSelection mode.
Record selection in tree view in order to go back/forward using navigation button Enables the Tree view RecordSelection mode.
Add checkboxes for selection in document tree Each Tree view item will get a checkbox. This is for example useful for selecting multiple items on a touchscreen.

Preferences General Tab Selection.png

Cache

These preferences are related to the cache directory where FreeCAD stores temporary files.

Auf der Registerkarte Cache (eingeführt mit Version 0.20) kann Folgendes eingestellt werden:

Name Description
Location Specifies the path of the cache directory.
Check periodically at program start Controls the frequency with which the directory size is checked. The options are:
  • Always
  • Daily
  • Weekly
  • Monthly
  • Yearly
  • Never
Cache size limit Specifies the maximum size of the directory. You will be notified if a check is performed and the size exceeds this value. The options are:
  • 100 MB
  • 300 MB
  • 500 MB
  • 1 GB
  • 2 GB
  • 3 GB
Current cache size Shows the current size of the directory, if available. Press the Check now... button to update the value.

Preferences General Tab Cache.png

Editor

Diese Einstellungen steuern das Verhalten des Makroeditors. Dieser Editor kann über den Menüeintrag Makro → Makros... → Erstellen geöffnet werden.

Die Farb- und Schrifteinstellungen werden auch von der Python-Konsole verwendet.

Auf der Registerkarte Editor kann Folgendes eingestellt werden:

Name Beschreibung
Elemente anzeigen Auswahl des Codetyps. Die Farb- und Schrifteinstellungen werden auf den ausgewählten Typ angewendet. Das Ergebnis ist im Feld Vorschau zu sehen.
Familie Angabe der Schriftfamilie, die für den gewählten Codetyp verwendet werden soll
Größe Angabe der Schriftgröße, die für den gewählten Codetyp verwendet werden soll
Farbe Angabe der Farbe, die für den gewählten Codetyp verwendet werden soll
Zeilennummern einschalten Wenn markiert, werden die Codezeilen nummeriert
Tabulator Größe Angabe des Tabulatorrasters (wie viele Leerzeichen). Wenn es z.B. auf '6' gesetzt ist, wird durch Drücken von Tab zum Zeichen 7 oder 13 oder 19 usw. gesprungen, abhängig von der aktuellen Cursorposition. Diese Einstellung wird nur verwendet, wenn Tabulatoren behalten ausgewählt ist.
Einrückungsgröße Angabe, wie viele Leerzeichen eingefügt werden, wenn Tab gedrückt wird. Diese Einstellung wird nur verwendet, wenn Einfügen Leerzeichen ausgewählt ist.
Tabulatoren behalten Falls ausgewählt, wird durch Drücken von Tab ein Tabulator mit dem durch Tabulatorgröße definierten Raster eingefügt
Leerzeichen einfügen Falls ausgewählt, wird durch Drücken von Tab die durch Einrückungsgröße definierte Anzahl von Leerzeichen eingefügt

Preferences General Tab Editor.png

Python-Konsole

These preferences control the behavior of the Python console. This console can be opened using the View → Panels → Python console menu option.

Note that the color and font settings for the console are defined on the Editor tab.

Auf der Registerkarte Python-Konsole (eingeführt mit Version 0.20) kann Folgendes eingestellt werden:

Name Description
Enable word wrap If checked, words will be wrapped if they exceed the available horizontal space in the console.
Enable block cursor If checked, the cursor will have a block shape.
Save history If checked, Python history is saved across sessions.

Preferences General Tab Python console.png

Ausgabefenster

Important note: this tab has been renamed from Output window to Report view. introduced in version 1.0

Die Ausgabeeinstellungen beeinflussen das Verhalten der Berichtansicht. Dieses Paneel wird über das Menü Ansicht → Paneele → Berichtansicht angezeigt.

Auf der Registerkarte Ausgabefenster kann Folgendes eingestellt werden:

Name Description
Record normal messages If checked, normal messages will be recorded. They will be displayed in the Report view with the color set in Normal messages.
Record log messages If checked, log messages will be recorded. They will be displayed in the Report view with the color set in Log messages.
Record warnings If checked, warnings will be recorded. They will be displayed in the Report view with the color set in Warnings.
Record error messages If checked, error messages will be recorded. They will be displayed in the Report view with the color set in Errors.
Show report view on error If checked, the Report view will be shown automatically when an error is recorded.
Show report view on warning If checked, the Report view will be shown automatically when a warning is recorded.
Show report view on normal message If checked, the Report view will be shown automatically when a normal message is recorded.
Show report view on log message If checked, the Report view will be shown automatically when a log message is recorded.
Include a timecode for each entry If checked, each message and warning will receive a timecode.
Normal messages Specifies the font color for normal messages.
Log messages Specifies the font color for log messages.
Warnings Specifies the font color for warning messages.
Errors Specifies the font color for error messages.
Redirect internal Python output to report view If checked, internal Python output will be redirected from the Python console to the Report view.
Redirect internal Python errors to report view If checked, internal Python error messages will be redirected from the Python console to the Report view.

Preferences General Tab Output window.png

Makro

Auf der Registerkarte Makro kann Folgendes eingestellt werden:

Name Beschreibung
Makros in lokaler Umgebung ausführen Wenn angehakt, werden durch Makros definierte Variablen als lokale Variablen erstellt, andernfalls als globale Python Variable
Makro Pfad Angabe eines Pfades zu Makro Dateien
Aufzeichnung von GUI Befehlen Wenn angehakt, enthält Aufgezeichnete Makros auch Benutzeroberflächenbefehle
Aufzeichnung als Kommentar Wenn diese Option angehakt ist, enthält Aufgezeichnete Makros auch Benutzeroberflächenbefehle, jedoch als Kommentare. Dies ist nützlich, wenn du beim Ausführen des Makros keine sichtbaren Aktionen ausführen willst, sondern sehen willst, was sichtbar getan werden könnte.
Skriptbefehle in der Python Konsole anzeigen Wenn diese Option aktiviert ist, werden die von den Makroskripten ausgeführten Befehle in der Python Konsole angezeigt. Diese Konsole wird über das Menü Ansicht → Paneele → Python Konsole angezeigt.
Länge der Liste der aktuellen Makros Steuert die Anzahl der aktuellen Makros im Menu
Verknüpfungsanzahl Steuert die Anzahl der aktuellen Makros, denen dynamisch Kurzbefehle zugeordnet werden
Tastatur Modifikatoren Steuert, welche Tastatur-Modifikatoren für die Kurzbefehle verwendet werden, z.B. erstellt Strg+Shift+ Kurzbefehle in der Form Strg+Shift+1, Strg+Shift+2, etc.

Preferences General Tab Macro.png

Einheiten

Auf der Registerkarte Einheiten kann Folgendes eingestellt werden:

Name Beschreibung
Benutzer System Auswahl eines Einheitensystems, das für alle Teile von FreeCAD verwendet werden soll
Anzahl der Dezimalstellen Die Anzahl der Dezimalstellen, die für Zahlen und Abmessungen in FreeCAD angezeigt werden sollen
Minimaler Bruchteil eines Zolls Minimaler Zoll Bruchteil , der angezeigt werden sollte. Diese Einstellung ist nur verfügbar, wenn das Einheitensystem Building US (ft-in/sqft/cuft)' verwendet wird.

Preferences General Tab Units.png

Help

This tab is only available if the Help Addon has been installed.

Auf der Registerkarte Help kann Folgendes eingestellt werden:

Name Description
Help location Specifies the location of the Help files. The options are:
  • Online: Enter the URL or leave blank to use the automatic GitHub URL.
Translation suffix: If https://wiki.freecad.org/ is used, a language suffix can be specified. Use for example fr for the French translation. Must be blank for the GitHub URL.
  • From disk location: Enter the path where the downloaded FreeCAD documentation can be found. To download the documentation select the offline-documentation addon from the Workbenches list in the Addon Manager.
Display Specifies where the documentation should be displayed. The options are:
  • In a new FreeCAD tab: The documentation is displayed on a new tab in the Main view area.
  • In your default web browser: The documentation is displayed in the default web browser.
  • In a separate, embeddable, dialog: The documentation is displayed in a separate dialog. This dialog can be docked on top of the Combo view for example.
Custom stylesheet Specifies an optional custom stylesheet. Not used for the Wiki URL.

Preferences General Tab Help.png

Anzeige

Dieser Einstellungsabschnitt enthält drei allgemeine Registerkarten, 3D-Ansicht, Navigation und Farben. Eine vierte, Netze, wird hinzugefügt, wenn der Netze-Arbeitsbereich geladen wurde.

3D-Viewer

Auf der Registerkarte 3D-Viewer kann Folgendes eingestellt werden:

Name Beschreibung
Show coordinate system in the corner / Koordinatensystem in Ecke anzeigen Wenn aktiviert, wird das Haupkoordinatensystem in der rechten unteren Ecke der 3D-Ansicht angezeigt.

Die Eigenschaft Relative Größe (eingeführt mit Version 0.20) legt die Größe der Darstellung als prozentuale Größe der Ansicht fest (das Minimum ihrer Höhe und Breite).

Show axis cross by default / Achsenkreuz standardmäßig anzeigen eingeführt mit Version 0.19 Wenn aktiviert, wird das Achsenkreuz standardmäßig in der 3D-Ansicht angezeigt.
Show counter of frames per second / Anzeigen der Datenrate pro Sekunde Wenn aktiviert, wird die für die letzte Aktion benötigte Zeit und die sich ergebende Bildrate in der unteren linken Ecke der 3D-Ansicht angezeigt.
Remember active workbench by tab / Aktiven Arbeitsbereich je Reiter merken eingeführt mit Version 0.19 Wenn aktiviert, merkt sich die Anwendung unabhängig für jede Registerkarte den aktiven Arbeitsbereich im Hauptansichtsbereich. Wenn zu einer Registerkarte gewechselt wird, wird der zugehörige Arbeitsbereich automatisch wiederhergestellt.
Use software OpenGL / Sofware OpenGL verwenden eingeführt mit Version 0.19 Wenn aktiviert, verwendet OpenGL die CPU anstatt der GPU. Diese Möglichkeit hilft bei der Fehlerbehebung bei Graphikkarten- und Treiberproblemen. Die Änderung dieser Möglichkeit erfordert einen Neustart der Anwendung.
Use OpenGL VBO (Vertex Buffer Object) / OpenGL VBO (Vertex Buffer Object) verwenden Wenn aktiviert, werden Vertex-Buffer-Objects (VBO) verwendet. Ein VBO ist ein OpenGL-Bestandteil, der Methoden zum Hochladen von Vertex-Daten (Position, Normalenvektor, Farbe usw.) zur Grafikkarte bereitstellt. VBOs bieten ordentliche Performance-Gewinne, da sich die Daten eher im Grafikspeicher befinden als im Hauptspeicher und so der GPU direkt zur verarbeitung bereit stehen. Für mehr Hintergrundinformation siehe Understanding OpenGL Objects.
Render Cache / Render Cache-Speicher eingeführt mit Version 0.19 "Render Cache" oder "Render Acceleration" wird etwas umfangreicher unter FreeCAD_assembly3 render-caching erläutert. Es gibt drei Wahlmöglichkeiten:
  • Automatisch: Man lässt Coin3D entscheiden, wo zwischengespeichert wird (voreingestellt).
  • Verteilt: Manuelles Einschalten des Zwischenspeichers für alle view provider root nodes.
  • Zentralisiert: Manuelles Ausschalten des Zwischenspeicher für alle view provider root nodes and only cache at the scene graph root node. Dies bietet die höchste Render-Geschwindigkeit, hat aber eine langsamere Reaktion auf alle Szenenänderungen.
Anti-Aliasing / Kantenglättung Gibt an, ob und welche Art von multisample Anti-Aliasing verwendet wird.
Transparent objects / Transparente Objekte eingeführt mit Version 0.19 Legt die Art des Renderns transparenter Objekte fest. Die möglichkeiten sind:
  • Einzelner Render-Durchgang: Das Rendern wird in einem Durchgang ausgeführt (voreingestellt). Dies kann bei der Tiangulation zu Artefakten führen. Wenn diese auftreten, können sie durch die Zusätzlicher Rückseiten-Render-Durchgang vermieden werden.
  • Zusätzlicher Rückseiten-Render-Durchgang: Das Rendern wird in zwei Durchgängen ausgeführt. Rückwärts gerichtete Polygone werden im ersten Durchgang gerendert und vorwärts gerichtete Polygone im zweiten Durchgang.
Marker size / Markergröße Legt die Größe von Vertizes (Knotenpunkte) in der Arbeitsumgebung Sketcher fest. Der anklickbare Bereich der Punkte kann zusätzlich durch Vergrößerung des Auswahlradius erweitert werden .
Pick radius (px) / Auswahlradius (px) Stellt die Fläche zur Auswahl von Elementen in der 3D-Ansicht ein. Ein größerer Wert vereinfacht es objekte zu packen, kann aber dazu führen, dass einige kleine Objekte nicht mehr ausgewählt werden können.
Eye to eye distance for stereo modes / Augenabstand für Stereo-Modi Legt den Augenabstand für stereoskopische Projektionen fest. Der angegebene Wert ist ein Faktor, der mit der Größe der Bounding Box des aktuell dargestellten 3D-Objekts multipliziert wird.
Backlight color / Farbe der Hintergrundbeleuchtung Wenn aktiviert, wird die Hintergrundbeleuchtung mit der eingestellten Farbe eingeschaltet. Die Hintergrundbeleuchtung wird beim Rendern von Flächenrückseiten eingesetzt. Normaler Weise ist sie auf Solids nicht sichtbar, außer sie werden mit einer Schnittebene (auf-)geschnitten oder wenn Flächen nicht korrekt ausgerichtet sind. Es ist nur für Objekte aktiv, deren Eigenschaft Lighting (auf der Registerkarte Ansicht) auf One side gesetzt ist. Wenn deaktiviert, werden die Rückseiten von Objektflächen im Modus One side schwarz dargestellt.

Die zugehörige Einstellung Intensity legt die Intensität der Hintergrundbeleuchtung fest.

Camera type / Kameratyp Legt die Projektionsart der Kamera fest. Die Wahlmöglichkeiten sind:
  • Perspektivische Darstellung: Objekte werden Perspektivisch dargestellt.
(engl. perspective projection).
(engl. orthographic projection)

Preferences Display Tab 3D View.png

Navigation

Auf der Registerkarte Navigation kann Folgendes eingestellt werden:

Name Description
Navigation cube If checked, the Navigation cube will be shown in the 3D view.

Steps by turn defines the number of steps required for a full rotation when using the Navigation cube rotation arrows.

If Rotate to nearest is checked, the 3D view is rotated to the nearest most logical position, based on the current orientation of the cube, when a cube face is clicked. Else clicking a face will always result in the same rotation. introduced in version 0.20

Cube size defines the size of the cube. introduced in version 0.20

Corner defines where the Navigation cube is displayed in the 3D view.

Font name specifies the font used for the cube's text. introduced in version 1.0

Font size sets the size of the font used for the cube's text. introduced in version 1.0

3D Navigation Specifies a mouse navigation style. To see the details of each style, select it and then press the Mouse... button.
Orbit style Specifies the rotation orbit style used when in rotation mode. The options are:
  • Turntable: Moving the mouse will divide the rotation in steps, rotations around the different axes are performed sequentially.
  • Trackball: Rotations around the different axes are performed simultaneously.
  • Free Turntable: Like Trackball, but if possible the rotation axis is kept collinear with the global 3D view axis. introduced in version 1.0
Rotation mode Defines the rotation center. The options are:
  • Window center
  • Drag at cursor
  • Object center
Default camera orientation Specifies the camera orientation for new documents. This setting is also used by the Std ViewHome command.
Camera zoom Affects the initial camera zoom level for new documents. The value you set is the diameter of a sphere that fits in 3D view. The default is 100 mm. It also sets the initial size of origin features (base planes in new PartDesign Bodies and Std Parts).
Enable animation If checked, and 3D Navigation is set to CAD, rotations can be animated. If the mouse is moved while the scroll wheel and the right mouse button are pressed, the view is rotated. If one keeps the mouse moving while releasing the right mouse button, the rotation will continue. To end this animation left-click with the mouse.
Zoom at cursor If checked, zoom operations will be performed at the position of the mouse pointer. Otherwise zoom operations will be performed at the center of the current view. The Zoom step defines how much will be zoomed. A zoom step of 1 means a factor of 7.5 for every zoom step.
Invert zoom If checked, the direction of zoom operations will be inverted.
Disable touchscreen tilt gesture If checked, and 3D Navigation is set to Gesture, the tilting gesture will be disabled for pinch-zooming (two-finger zooming).

Preferences Display Tab Navigation.png

Farben

Auf der Registerkarte Farben kann Folgendes eingestellt werden:

Name Description
Enable preselection highlighting If checked, preselection is turned on and the specified color will be used for it. Preselection means that for example edges in parts will be highlighted while hovering over them with the mouse to indicate they can be selected.
Enable selection highlighting If checked, selection highlighting is turned on and the specified color will be used for it.
Simple color If selected, the background of the 3D view will have the selected color.
Color gradient If selected, the background of the 3D view will have a vertical color gradient. The first color is the color at the top of the 3D view, the second the color at the bottom.
Switch Press this button to switch the top and bottom colors of the gradient. introduced in version 1.0
Middle color This option is only enabled if Color gradient is selected. If checked, the color gradient will get the selected color as the middle color.
Object being edited Specifies the background color for objects in the tree view that are currently edited.
Active container Specifies the background color for active containers in the tree view. For example an active PartDesign Body will get this color.

Preferences Display Tab Colors.png

Netz

Diese Registerkarte wird nur angezeigt, wenn der Arbeitsbereich Mesh geladen wurde.

Auf der Registerkarte Netz kann Folgendes eingestellt werden:

Name Description
Default mesh color Specifies the default face color.
Default line color Specifies the default line color.
Mesh transparency Specifies the default mesh transparency.
Line transparency Specifies the default line transparency.
Two-side rendering If checked, the default value for the AnsichtLighting property is Two side instead of One side. Two side means the color of the interior side of faces is the same as the color of the exterior side. One side means their color is either the backlight color, if enabled, or black.
Show bounding-box for highlighted or selected meshes If checked, the default value for the AnsichtSelection Style property is BoundBox instead of Shape. BoundBox means a highlighted bounding box is displayed if meshes are highlighted or selected. Shape means the shape itself is then highlighted.
Define normal per vertex If checked, Phong shading is used, otherwise flat shading. Shading defines the appearance of surfaces. With flat shading the surface normals are not defined per vertex. This leads to an unrealistic appearance for curved surfaces. While Phong shading leads to a more realistic, smoother appearance.
Crease angle The crease angle is a threshold angle between two faces. It can only be set if the option Define normal per vertex is used.
If face angle ≥ crease angle, facet shading is used.
If face angle < crease angle, smooth shading is used.

Preferences Display Tab Mesh view.png

Arbeitsbereiche

Dieser Abschnitt der Voreinstellungen hat nur eine Registerkarte: Verfügbare Arbeitsbereiche.

Verfügbare Arbeitsbereiche

To preserve resources, FreeCAD does not automatically load all available workbenches. And only if a workbench has been loaded will its preferences, if any, appear in the Preferences editor.

In FreeCAD version 0.19 the tab has a different label: Unloaded Workbenches, and the tab displays a list of installed workbenches that have not yet been loaded. To load one or more workbenches select them in the list and then press the Load Selected button.

In FreeCAD version 0.20 the Available Workbenches tab displays a list of all installed workbenches. To load a workbench press its Load now button. If you check a workbench's Autoload checkbox it will autoload when FreeCAD starts up. Loading more workbenches will make the startup slower, but switching between workbenches that have already been loaded is faster.

If a newly loaded workbench has dedicated preference they will appear in a new section in the Preferences editor. Some workbenches add support for additional import and export formats. If there are any related preferences they will appear on one or more new tabs in the Import-Export section of the Preferences editor.

For a list of workbench related preferences see Workbench related preferences

Preferences Workbenches Tab Available Workbenches.png

Addon-Manager

Dieser Abschnitt der Voreinstellungen hat nur eine Registerkarte: Addon manager options.

Addon manager options

Diese Einstellungen steuern das Verhalten des Addon-Managers.

Auf der Registerkarte Addon manager options (eingeführt mit Version 0.20) kann Folgendes eingestellt werden:

Name Description
Automatically check for updates at start (requires git) If checked, the Addon manager will check for updates when it is launched. Git must be installed for this to work.
Download Macro metadata (approximately 10MB) If checked, macro metadata is downloaded for display in the Addon manager's main addon listing. This data is cached locally.
Cache update frequency Controls the frequency with which the locally cached addon availability and metadata information is updated. The options are:
  • Manual (no automatic updates)
  • Daily
  • Weekly
Hide Addons marked Python 2 Only If checked, addons marked as "Python 2 Only" are not included in the listing. These addons are unlikely to work in the current FreeCAD version.
Hide Addons marked Obsolete If checked, addons marked as "Obsolete" are not included in the listing.
Hide Addons that require a newer version of FreeCAD If checked, addons that require a newer FreeCAD version are not included in the listing.
Custom repositories Custom repositories can be specified here.

To add a repository press the List-add.svg button. Both the Repository URL and the Branch, typically master or main, must be specifies in the dialog that opens. introduced in version 1.0

To remove a repository select it in the list and press the List-remove.svg button. introduced in version 1.0

Proxy The Addon manager includes experimental support for proxies requiring authentication, set up as user-defined proxies.
Python executable (optional) The Addon manager attempts to determine the Python executable that should be used for the automatic pip-based installation of Python dependencies. To override this selection, the path to the executable can be set here.
git executable (optional) The Addon manager attempts to determine the git executable. To override this selection, the path to the executable can be set here. introduced in version 1.0
Show option to change branches (requires git) If checked, the Addon manager provides an interface on the addon's details screen that allows switching which git branch is currently checked out. This is intended for advanced users only, as it is possible that a non-primary-branch version of an addon may result in instability and compatibility issues. Git must be installed for this to work. Use with caution.
Disable git (fall back to ZIP downloads only) If checked, git downloads are disabled. introduced in version 1.0
Addon developer mode If checked, Addon manager options intended for developers of addons are activated. introduced in version 1.0

Preferences Addon Manager Tab Addon manager options.png

Import-Export

Die Import-Export-Einstellungen beeinflussen wie Dateien in FreeCAD importiert und exportiert werden. Sie sind auf der Seite Import Export Einstellungen beschrieben.

Arbeitsbereichseinstellungen

Einstellungen für die gebräuchlicheren Arbeitsbereiche findest Du nachfolgend verknüpft. Einige Arbeitsbereiche haben keine Einstellungen. Andere optionale Arbeitsbereiche sind möglicherweise nicht aufgeführt. Diese Verknüpfungen sind auch unter Category:Preferences aufgezeigt.


Skripten

Siehe auch: FreeCAD Grundlagen Skripten.

For a scripting example see Std DlgParameter.

Verwandt