Навигация в 3D пространстве
Обзор
Каждый стиль навигации определяет собой методы для навигации в трёхмерном пространстве, а так же методы взаимодействия с трехмерными объектами (перемещение, вращение и т.п.). FreeCAD поддерживает несколько стилей навигации и управления. По умолчанию установлен CAD стиль навигации, он очень простой и практичный, но FreeCAD так же предлагает альтернативные стили навигации, которые вы можете выбрать по своим предпочтениям. Назначенный пользователем стиль навигации будет использоваться для всех верстаков.
Дополнительные сведения о способах выбора объектов см. в разделе Методы выбора объектов.
Дополнительные сведения о способах преобразования объектов см. на странице описания команды Преобразование.
Выбор стиля навигации
- Выполните одно из следующих действий:
- Нажмите на кнопку
в Строке состояния.
- Щелкните правой кнопкой мыши в пустую область в 3D Виде, и выберите Стили навигации в контекстном меню.
- Откройте Редактор настроек через пункт главного меню Редактировать → Настройки... В нем выберите раздел Отображение → вкладку Навигация → пункт Трехмерная навигация.
- Нажмите на кнопку
- Выберите стиль из списка.
- При необходимости укажите стиль Ващения: нажмите на кнопку
в Строке состояния и выберите в контекстом меню пункт Настройки → Вращение. Подробности см. в описании Редактора настроек.
- При необходимости укажите Режим вращения. Подробности см. в описании Редактора настроек.
- Если выбран стиль навигации CAD: при необходимости укажите параметр настроек Включить анимацию. Подробности см. в описании Редактора настроек.
Доступные стили навигации
Во всех стилях навигации, за исключением выбора объектов на эскизе в режиме редактирования, для выбора нескольких объектов необходимо удерживать клавишу Ctrl.
Сочетания клавиш, доступные во всех стилях навигации:
- Ctrl +
и Ctrl +
или PgUp и PgDn для увеличения и уменьшения масштаба соответственно.
- Клавиши со стрелками,
, для перемещения изображения влево/вправо и вверх/вниз.
- Shift +
и Shift +
для поворота изображения на 90 градусов.
Навигация Blender
Стиль навигации Blender основан на модели управления используемой в редакторе Blender.
Навигация CAD
Это стиль навигации по умолчанию и позволяет пользователю простейшее управление видом, не требуя использования клавиатуры, кроме как для множественного выделения.
| Выбор | Масштабирование | Вращение обычное |
Вращение альтернативный метод |
Перемещение |
|---|---|---|---|---|
| Нажмите левую кнопку мыши над объектом, который вы хотите выбрать. | Используйте колесико мыши для увеличения и уменьшения масштаба.
Нажатие средней кнопки мыши центрует вид относительно положения указателя. |
Удерживайте среднюю кнопку мыши, затем нажмите и удерживайте левую кнопку мыши, после чего перемещайте указатель.
Если кнопки будут отпущены до того, как вы остановите движение мыши, Вид продолжит вращение, в случае если включен поворотный просмотр объекта. |
Удерживайте среднюю кнопку мыши, затем нажмите и удерживайте правую кнопку мыши, после чего перемещайте указатель.
При этом методе средняя кнопка мыши может быть отпущена после того как правая кнопка осталась нажатой. Пользователи, использующие мышь правой рукой могут счесть этот метод проще исходного. |
Удерживайте среднюю кнопку мыши, затем перемещайте указатель. |
| Ctrl+Shift+ |
Shift+ |
Ctrl+ | ||
| Масштабирование: удерживайте клавиши Ctrl и Shift, нажмите правую кнопку мыши один раз, затем двигайте указатель. | Вращение: удерживайте клавишу Shift, нажмите правую кнопку мыши один раз, затем двигайте указатель. | Перемещение: удерживайте клавишу Ctrl, нажмите правую кнопку мыши один раз, затем двигайте указатель.. |
Навигация жестами
Этот стиль был разработан специально для работы с сенсорным экраном с помощью стилуса или жестами. Тем не менее он также может применяться при управлении мышью, кроме того данный стиль управления рекомендуется использовать при управлении трекпадом в Mac.
| Выделение | Масштабирование | Вращение | Перемещение | Наклонить вид | |
|---|---|---|---|---|---|
| Нажмите левую кнопку мыши над объектом, который хотите выбрать. | Используйте колесико мыши для увеличения и уменьшения масштаба.
Нажатие средней кнопки мыши центрирует изображение относительно положения указателя. В качестве альтернативы, наведите указатель и нажмите клавишу H на клавиатуре. |
Удерживайте левую кнопку мыши, затем перемещайте указатель.
В Sketcher и других режимах редактирования это поведение отключено. Удерживайте Alt при нажатии кнопки мыши, чтобы перейти в режим поворота. |
Удерживайте правую кнопку мыши, затем перемещайте указатель. | Удерживайте левую и правую кнопки мыши одновременно, затем перемещайте указатель в сторону. | |
| Нажмите, чтобы выбрать. | Сведите или разведите два пальца (щипок). | Для поворота перетащите палец.
Удерживайте клавишу Alt, находясь в Sketcher. |
Перетаскивайте двумя пальцами.
В качестве альтернативы, нажмите и удерживайте палец, а затем перетащите. Это имитирует перемещение с помощью правой кнопки мыши. |
Вращайте воображаемую линию между двумя точками касания.
Этот метод по умолчанию отключён. Для активации в меню Правка → Настройки → Отображение → Навигация снимите метку "Отключить жест наклона для сенсорного экрана". | |
Навигация в стиле Maya
В стиле навигации MayaGesture, перемещение, масштабирование и вращение Вида выполняется при зажатой клавише ALT и нажатии одной из трех кнопок мыши, поэтому этот стиль навигации полноценно можно использовать только с трехкнопочной мышью. В данном стиле также можно использовать жесты из обычного стиля навигации жестами, так как этот стиль был разработан на его основе.
Навигация OpenCascade
Стиль навигации OpenCascade основан на модели управления используемой в OpenCascade.
Навигация OpenInventor
Стиль навигации OpenInventor основан на модели управления используемой в редакторе Open Inventor. Для выбора объектов, необходимо удерживать нажатой клавишу Shift или Ctrl.
Данный стиль управления отличен от того, что применен в Autodesk Inventor.
| Выделение | Масштабирование | Вращение | Перемещение | |
|---|---|---|---|---|
| Shift+ |
||||
| Удерживайте клавишу Shift, затем нажмите левую кнопку мыши на объекте, который хотите выделить.
Для выбора нескольких объектов удерживайте клавишу Ctrl. При использовании клавиш-модификаторов, установленных по умолчанию в Верстаке Draft, необходимо удерживать Ctrl для выбора точек комманд Draft. |
Используйте колесико мыши для увеличения и уменьшения масштаба.
Или, зажмите и удерживайте среднюю и левую кнопку мыши, затем перемещайте указатель. Нажатие средней кнопки мыши центрует вид относительно положения указателя. |
Удерживайте левую кнопку мыши, затем перемещайте указатель. | Удерживайте среднюю кнопку мыши, затем перемещайте указатель. | |
Навигация OpenSCAD
Стиль навигации OpenSCAD основан на модели управления используемой в редакторе OpenSCAD.
Навигация Revit
Стиль навигации Revit основан на модели управления используемой в редакторе Revit.
Навигация Siemens NX
Стиль навигации Siemens NX основан на модели управления используемой в редакторе Siemens NX.
Навигация SolidWorks
Стиль навигации SolidWorks основан на модели управления используемой в редакторе SolidWorks.
Навигация TinkerCAD
Стиль навигации TinkerCAD основан на модели управления используемой в редакторе TinkerCAD.
Навигация Touchpad
При использовании стиля навигации Touchpad для перемещения, масштабирования и вращения изображения требуется клавиша-модификатор совместно с тачпадом. Этот стиль также можно использовать с мышью.
Поддержка оборудования
В FreeCAD так же поддерживает некоторые устройства 3D ввода.
Рекомендуемый стиль управления для MacOS
На MacBook с трекпадом навигация жестами работает хорошо, но жесты имеют особое значение:
- Масштабирование: касание и перемещение двумя пальцами.
- Вращение: касание и перемещение тремя пальцами.
- Перемещение: Ctrl + касание и перемещение тремя пальцами.
- Начинающим
- Установка: Загрузка, Windows, Linux, Mac, Дополнительных компонентов, Docker, AppImage, Ubuntu Snap
- Базовая: О FreeCAD, Интерфейс, Навигация мыши, Методы выделения, Имя объекта, Настройки, Верстаки, Структура документа, Свойства, Помоги FreeCAD, Пожертвования
- Помощь: Учебники, Видео учебники
- Верстаки: Std Base, Arch, Assembly, CAM, Draft, FEM, Inspection, Mesh, OpenSCAD, Part, PartDesign, Points, Reverse Engineering, Robot, Sketcher, Spreadsheet, Surface, TechDraw, Test Framework