Preferenze di Importa/Esporta

From FreeCAD Documentation
This page is a translated version of the page Import Export Preferences and the translation is 59% complete.
Outdated translations are marked like this.

Introduzione

FreeCAD può importare ed esportare molti formati di file. Per alcuni formati esistono preferenze dedicate che si trovano nell'editor delle preferenze, nel menu Modifica → Preferenze → Import-Export.

Non tutte le schede delle preferenze di importazione ed esportazione sono disponibili di default. Per alcune bisogna caricare prima un determinato ambiente di lavoro.

This page has been updated for version 1.0.

Note

Pagine TechDraw

Le preferenze DXF e SVG elencate qui non vengono utilizzate dai comandi Esporta la pagina in SVG e Esporta la pagina in DXF dell' Ambiente TechDraw, o dall'opzione di esportazione di TechDraw: File → Esporta → Technical Drawing (*.svg *.dxf *.pdf).

IFC files

Some NativeIFC specific IFC import and export preferences can be found under the BIM Preferences.

file OpenSCAD

Le preferenze di importazione ed esportazione per i file OpenSCAD sono elencate in una posizione diversa nell'editor delle Preferenze. Vedere le Preferenze di OpenSCAD.

Correlazioni

Vedere le pagine seguenti per ulteriori informazioni:

Preferenze disponibili

DAE

Il formato DAE (Digital Asset Exchange) Collada è un formato di file standard per lo scambio di dati Mesh. FreeCAD può importare mesh da file .dae ed esportare oggetti basati su Shape nel formato .dae.

Nota per gli utenti Linux: per gestire questo formato di file FreeCAD richiede il modulo pyCollada.

On the this page you can specify the following:

Nome Descrizione
Fattore di scala Tutte le dimensioni nel file verranno ridimensionate con il fattore specificato.
Mesher Imposta il programma di mesh da utilizzare. Se si utilizza Netgen, assicurarsi che sia disponibile. Questo può essere verificato utilizzando Ambiente Mesh e creazione di una mesh utilizzando Netgen. Se non è disponibile un'altra versione di FreeCAD, compilata con Netgen, deve essere installata.
Tessellazione Il valore di tassellatura da utilizzare con il programma di meshing Builtin e Mefisto.
Raffinatezza Il valore di valutazione da utilizzare per la mesh utilizzando Netgen. Questo valore descrive la velocità con cui diminuisce la dimensione della mesh. Il gradiente della dimensione della mesh locale h(x) è limitato da abs(Δh(x)) ≤ 1/valore.
Segmenti per i bordi Il numero massimo di segmenti per spigolo.
Segmenti per i raggi Il numero di segmenti per raggio.
Secondo ordine Consenti una mesh del secondo ordine.
Ottimizza Consenti ottimizzazione.
Consenti i quadrilateri Permette facce quadrilatere.

DWG

DWG (dal disegno) è un formato di file binario proprietario, closed source per la memorizzazione di dati e metadati di progettazione 2D e 3D. FreeCAD richiede convertitori esterni per elaborare i file DWG.

Nota: Tutte le impostazioni per il formato file DXF si applicano anche a DWG.

On the this page you can specify the following:

Nome Descrizione
Metodo di conversione Seleziona il convertitore DWG da utilizzare:
  • Automatica: FreeCAD proverà a trovare automaticamente un convertitore seguendo l'ordine del resto di questo elenco. disponibile dalla versione 0.21: Per LibreDWG viene cercato il percorso di ricerca del sistema operativo (os.getenv("PATH")), per gli altri convertitori si assumono i percorsi di installazione predefiniti.
  • LibreDWG: LibreDWG è una libreria di lettura e scrittura DWG open source. Manca il supporto per diverse entità DWG e potrebbe fornire non sempre risultati fedeli.
  • Convertitore ODA: Il Convertitore di file ODA è un'utilità gratuita fornita da Open Design Alliance. Dà risultati molto buoni e affidabili.
  • QCAD pro: QCAD pro è la versione a pagamento della piattaforma CAD 2D open source basata su QCAD DXF. Il suo convertitore DWG utilizza le librerie Teigha di OpenDesign Alliance e quindi fornisce gli stessi buoni risultati del convertitore di file ODA.

disponibile dalla versione 0.21: il percorso deve contenere il nome file corretto.

DXF

AutoCAD DXF (Drawing eXchange Format) è un formato proprietario per lo scambio di dati CAD tra AutoCAD e altri programmi.

On the this page you can specify the following:

Nome Descrizione
Visualizza questa finestra di dialogo durante l'importazione e l'esportazione Se selezionato, questa finestra di dialogo delle preferenze verrà visualizzata durante l'importazione o l'esportazione di file DXF.
Usa il vecchio importatore python Se selezionato, viene utilizzato l'importatore Python, altrimenti il ​​più recente C++. L'importatore C++ è più veloce, ma non ha ancora tante funzionalità.

L'importatore Python utilizza la preferenza Modifica → Preferenze... → Draft → Impostazioni generali → Livello di precisione interno. Per un risultato di importazione accurato, impostare questo valore su 8 o superiore.

Usa il vecchio esportatore python Se selezionato, viene utilizzato l'esportatore Python, altrimenti il ​​più recente C++. L'esportatore C++ è più veloce, ma non ha ancora tante funzionalità.
Consenti a FreeCAD di scaricare e aggiornare automaticamente le librerie DXF Selezionando questa opzione, consentirai a FreeCAD di scaricare il convertitore Python per l'importazione e l'esportazione DXF. Questo convertitore non può essere fornito in bundle con FreeCAD perché ha una licenza software diversa.
Importa Seleziona cosa verrà importato.

Se testi e quotature è deselezionato, i testi e gli mtext non verranno importati.

Se punti è deselezionato, i punti non verranno importati.

Se layout è selezionato, verranno importati anche gli oggetti spazio carta.

Selezionare *blocchi se si desidera importare anche i blocchi anonimi (che hanno nomi che iniziano con un *)..

Crea Seleziona cosa verrà creato.

Se si seleziona forme semplici di Part, verranno creati solo oggetti parte standard. Questo è il più veloce.

Se viene selezionato Oggetti Draft, gli oggetti Draft parametrici verranno creati quando possibile.

Se si seleziona Sketch, gli schizzi verranno creati quando possibile.

Fattore di scala da applicare a file importati Fattore di scala da applicare ai file DXF durante l'importazione. Il fattore è la conversione tra le unità del tuo file DXF e millimetri. Esempio: per i file in millimetri: 1, in centimetri: 10, in metri: 1000, in pollici: 25,4, in piedi: 304,8.
Ottieni colori originali da file DXF Se selezionato, i colori verranno recuperati dagli oggetti DXF quando possibile. In caso contrario verranno applicati i colori predefiniti.
Unisci la geometria Se selezionato, FreeCAD proverà a unire oggetti coincidenti in fili. Nota che questo può richiedere del tempo!
Raggruppa gli strati (layer) in blocchi Se selezionato, gli oggetti degli stessi livelli verranno uniti in Blocchi Draft, che vengono visualizzati più velocemente, ma sono meno facilmente modificabili.
Usa la dimensione standard del font per i testi Se selezionato, i testi importati avranno la dimensione standard del Testo Draft, invece della dimensione che hanno nel documento DXF.
Usa i livelli Se selezionato, i livelli DXF verranno importati come Layer Draft.
Importa i bordi del tratteggio come wire Se selezionato, i bordi verranno convertiti in wire semplici.
Disegna le polilinee con spessore Se selezionata, quando le polilinee hanno una larghezza definita, verranno disegnate come wire chiusi con la larghezza corretta.
Tratta ellissi e spline come polilinee L'esportazione di ellissi e spline è scarsamente supportata. Utilizzare questa opzione per esportarli invece come polilinee.

L'impostazione Massimo segmento Spline è quindi la lunghezza massima di ciascuno dei segmenti di polilinea. Se è impostato su 0, l'intera spline viene trattata come un segmento rettilineo.

Esporta gli oggetti 3D come mesh poligonali multifaccia Se selezionato, tutti gli oggetti contenenti facce verranno esportati come polifacce 3D.
Esporta le viste di Disegno come blocchi Se questa opzione è selezionata, le viste di disegno verranno esportate come blocchi. Questo potrebbe non riuscire per i modelli post DXF R12.
Proietta gli oggetti esportati lungo la direzione della vista corrente Se selezionato, gli oggetti esportati verranno proiettati per riflettere la direzione della vista corrente. Questa opzione funziona solo se viene utilizzato il vecchio esportatore python.

IFC

Industry Foundation Classes (IFC) è un formato ad ampia diffusione per lo scambio di dati tra le applicazioni BIM. È usato in architettura e ingegneria.

Nota per gli utenti Linux: per gestire questo formato di file FreeCAD richiede il Modulo IfcOpenShell.

Importazione IFC

On the this page you can specify the following:

Nome Descrizione
Mostra questa finestra durante l'importazione Se selezionata, questa finestra di dialogo delle preferenze verrà mostrata durante l'importazione di file IFC.
Visualizza i messaggi di debug Mostra messaggi di debug dettagliati durante l'importazione e l'esportazione di file IFC nella Vista Report.
Crea dei cloni quando gli oggetti condividono la geometria Gli oggetti IFC possono condividere una stessa definizione di geometria tra più oggetti, solo il loro posizionamento è diverso. Quando questa opzione è abilitata, i cloni vengono utilizzati per ottenere lo stesso risultato in FreeCAD. Un oggetto è l'oggetto base, gli altri sono cloni.
Numero di core da usare (sperimentale) Specificare il numero di core della CPU da utilizzare per l'importazione IFC. Il numero massimo dovrebbe essere inferiore al numero di core effettivamente disponibili. Usa 0 per disabilitare questa funzione.
Importa gli oggetti IFC di Arch come Cosa verrà creato in FreeCAD per gli oggetti IFC arch.
Importa gli oggetti struttura IFC come Cosa verrà creato in FreeCAD per gli oggetti struttura IFC.
Elemento radice Verranno importati solo i sottotipi dell'elemento specificato. Mantieni l'elemento predefinito IfcProduct per importare tutti gli elementi dell'edificio.
Separa aperture Se selezionata, le aperture verranno importate come sottrazioni, altrimenti le forme dei muri avranno già le loro aperture sottratte.
Rileva le estrusioni Se selezionato, l'importatore proverà a rilevare le estrusioni. Nota che questo potrebbe rallentare le cose.
Dividi i muri multistrato Pareti divise composte da più strati.
Prefisso dei nomi con numero ID Se selezionato, i nomi degli oggetti saranno preceduti dal numero IFC ID.
Unisci i materiali con lo stesso nome e lo stesso colore Se nel file IFC vengono trovati più materiali con lo stesso nome, verranno trattati come uno.
Importa le proprietà IFC nel foglio di calcolo Se selezionato, ogni oggetto avrà le sue Proprietà IFC memorizzate in un oggetto foglio di calcolo.
Consenti forme non valide Se deselezionato le forme non valide non vengono importate.
Lista delle esclusioni Un elenco separato da virgole di entità IFC da escludere dalle importazioni.
Adatta la vista durante l'importazione Adatta la vista durante l'importazione sugli oggetti importati. Questo rallenterà l'importazione, ma si può guardare l'importazione.
Importa le definizioni parametriche complete di FreeCAD, se disponibili Crea un modello parametrico completo durante l'importazione utilizzando le proprietà dell'oggetto FreeCAD memorizzate.

Per ottenere le proprietà di FreeCAD, il modello deve essere stato esportato utilizzando l'opzione Esporta il modello parametrico completo di FreeCAD.

Sostituisci 'Progetto', 'Sito', 'Edificio' e 'Piano' con un 'Gruppo' Se selezionato, i gruppi verranno utilizzati per sostituire gli oggetti menzionati.

Esportazione IFC

On the this page you can specify the following:

Nome Descrizione
Mostra questa finestra durante l'esportazione Se selezionata, questa finestra di dialogo delle preferenze verrà mostrata durante l'esportazione di file IFC.
Tipo di esportazione Selezionare come esportare il modello: come Modello standard, Analisi strutturale o Standard + strutturale.
Forza l'esportazione come Brep Ad alcuni visualizzatori IFC non piacciono gli oggetti esportati come estrusioni. Usalo per forzare l'esportazione di tutti gli oggetti come geometria BREP. Ma evita di esportare come Brep se possibile poiché ciò rende gli oggetti non parametrici.
Utilizza le opzioni di triangolazione DAE Utilizzare le opzioni di triangolazione impostate nella pagina delle opzioni DAE.
Unisci le facce complanari durante la triangolazione Le forme curve che non possono essere rappresentate come curve in IFC e vengono scomposte in facce piatte. Se questa opzione è selezionata, vengono eseguiti alcuni calcoli aggiuntivi per unire le facce complanari.
Memorizza l'ID univoco IFC negli oggetti FreeCAD Quando si esportano oggetti senza un ID univoco (UID), l'UID generato verrà archiviato all'interno del Oggetto di FreeCAD da riutilizzare la prossima volta che l'oggetto viene esportato. Ciò porta a differenze minori tra le versioni dei file.
Se è disponibile, utilizza il serializzatore ifcOpenShell IFCOpenShell è una libreria per i file IFC. La sua funzionalità "serializzatore" può produrre geometrie IFC valide da forme OCC.

Si noti che questa è ancora una funzionalità sperimentale.

Esporta gli oggetti 2D come IfcAnnotations Se selezionato, gli oggetti 2D verranno esportati come IfcAnnotation.
Esporta il modello parametrico completo di FreeCAD Se selezionato, tutte le proprietà degli oggetti di FreeCAD verranno memorizzate all'interno degli oggetti esportati, consentendo di ricreare un modello parametrico completo al momento della reimportazione utilizzando l'opzioneImporta le definizioni parametriche complete di FreeCAD, se disponibili.
Riutilizza le entità simili Se selezionato, entità simili verranno utilizzate solo una volta nel file, se possibile. Ciò può ridurre notevolmente le dimensioni del file, ma lo renderà meno facilmente leggibile.
Disabilita IfcRectangleProfileDef Quando possibile, gli oggetti IFC che sono rettangoli estrusi verranno esportati come IfcRectangleProfileDef. Per le applicazioni che hanno problemi con l'importazione di queste entità, selezionare questa opzione per assicurarsi che tutti i profili vengano invece esportati come IfcArbitraryClosedProfileDef.
Rileva automaticamente ed esporta come casi standard quando applicabile Alcuni tipi di IFC come IfcWall o /RELEASE/IFC4/ADD1/HTML/schema/ifcsharedbldgelements/lexical/ifcbeam.htm IfcBeam hanno versioni standard speciali come lexical/ifcwallstandardcase.htm IfcWallStandardCase ​​o IfcBeamStandardCase. Se questa opzione è selezionata, FreeCAD esporterà automaticamente tali oggetti come casi standard quando vengono soddisfatte le condizioni necessarie.
Aggiungi un sito predefinito se non si trova nel documento (non standard) Quando si esporta un file IFC, se non viene trovato alcun sito nel documento FreeCAD, ne viene aggiunto uno predefinito. Un sito non è obbligatorio secondo lo standard IFC, ma è prassi comune averne almeno uno nel file.
Aggiungi un edificio predefinito se non si trova nel documento (non standard) Quando si esporta un file IFC, se non viene trovato alcun edificio nel documento FreeCAD, ne viene aggiunto uno predefinito.

Attenzione: Lo standard IFC richiede almeno un edificio in ogni file. Disattivando questa opzione, si produrrà un file IFC non standard.

Tuttavia, in FreeCAD riteniamo che avere un edificio non dovrebbe essere obbligatorio e questa opzione è lì per avere la possibilità di dimostrare il nostro punto di vista.

Aggiungi un edificio predefinito se non si trova nel documento (non standard) Quando si esporta un file IFC, se nel documento FreeCAD non viene trovato alcun piano di un edificio, ne viene aggiunto uno predefinito. Un piano di un edificio non è obbligatorio secondo lo standard IFC, ma è prassi comune averne almeno uno nel fascicolo.
Unità di file IFC Seleziona quali unità verranno utilizzate durante l'esportazione di file IFC.

IGES

Il formato di file Initial Graphics Exchange Specification (IGES) è un formato di file che consente lo scambio digitale di informazioni tra i sistemi CAD. Dopo la pubblicazione del formato di file STEP, lo sviluppo di IGES è stato interrotto nel 1996, ma è ancora supportato da molti programmi CAD. I file IGES hanno l'estensione .iges o .igs.

La scheda IGES viene visualizzata nelle preferenze solo se l'Ambiente Part, l'Ambiente PartDesign o l'Ambiente OpenSCAD è stato caricato nella sessione corrente di FreeCAD.

On the this page you can specify the following:

Nome Descrizione
Unità per l'esportazione IGES Seleziona quale unità verrà utilizzata durante l'esportazione di file IGES.
Rappresenta solidi e shell come Seleziona la modalità di output di solidi e shell.

Se Gruppi di Superfici accorciate (tipo 144) è selezionato, verranno esportati come superfici accorciate.

Se si seleziona Solidi (tipo 186) e Shell (tipo 514) in Modalità B-REP, i solidi verranno esportati come solidi manifold B-Rep, gli shell come shells.

Salta le entità vuote Se selezionato, le entità vuote non verranno importate.
Azienda Se non è vuoto, il testo inserito verrà utilizzato nell'intestazione del file IGES per l'azienda.
Autore Se non è vuoto, il testo inserito verrà utilizzato nell'intestazione del file IGES per l'autore.
Prodotto Se non è vuoto, il testo inserito verrà utilizzato nell'intestazione del file IGES del prodotto.

INP

INP è il formato del file di input per il software FEM Abaqus. Viene utilizzato per il risolutore CalculiX nell'Ambiente FEM .

La scheda INP viene mostrata nelle preferenze solo se l'Ambiente FEM è stato caricato nella sessione corrente di FreeCAD.

On the this page you can specify the following:

Nome Descrizione
Quali elementi di mesh da esportare Seleziona quali elementi mesh devono essere esportati.

Se è selezionato Tutti, tutti gli elementi verranno esportati.

Se viene selezionato Massimo, verranno esportati solo gli elementi più alti. Ciò significa volumi per una mesh volumetrica e facce per una mesh shell.

Se si seleziona FEM, verranno esportati solo gli elementi FEM. Ciò significa solo spigoli non appartenenti a facce e facce non appartenenti a volumi.

Esporta dati gruppo Se selezionato, vengono esportati anche i gruppi di mesh. Ogni vincolo e, se sono presenti materiali diversi, il materiale costituito da due gruppi di mesh, facce e nodi a cui viene applicato il vincolo o il materiale.

Formati mesh

Le mesh sono un tipo speciale di oggetto 3D, composto da facce triangolari collegate ai loro vertici e bordi. Sono ampiamente utilizzati nella produzione additiva. FreeCAD fornisce l'Ambiente Mesh per creare e gestire le mesh. FreeCAD supporta diversi formati di file mesh.

La scheda Formati mesh viene visualizzata nelle preferenze solo se l'Ambiente Mesh è stato caricato nella sessione corrente di FreeCAD.

On the this page you can specify the following:

Nome Descrizione
Massima deviazione della maglia Specifica della deviazione massima tra la mesh e l'oggetto.
Esporta i file AMF utilizzando la compressione Se selezionata, la compressione ZIP viene utilizzata durante la scrittura di un file mesh in formato AMF.
Larghezza Larghezza della pagina dell'asintoto.
Altezza Altezza della pagina dell'asintoto.

OCA

Il formato di file OCA è un progetto della comunità per creare un formato di file CAD gratuito, semplice e aperto. OCA è in gran parte basato sul formato file GCAD generato da gCAD3D. Entrambi i formati possono essere importati in FreeCAD e i file OCA esportati da FreeCAD possono essere aperti in gCAD3D.

On the this page you can specify the following:

Nome Descrizione
Importa aree OCA Se selezionato, verranno importate anche le aree (facce 3D).

STEP

Il formato di file Standard for The Exchange of Product model data (STEP) è uno standard ISO per la rappresentazione interpretabile da computer e lo scambio di informazioni sulla produzione del prodotto. STEP è comunemente usato per scambiare dati 3D tra software CAD. I file STEP hanno l'estensione .step o .stp. Per i file compressi viene utilizzata l'estensione .stpz.

La scheda STEP viene visualizzata nelle preferenze solo se l'Ambiente Part , l'Ambiente PartDesign o l'Ambiente OpenSCAD è stato caricato nella sessione corrente di FreeCAD.

On the this page you can specify the following:

Nome Descrizione
Unità per l'esportazione STEP Selezionare quali unità verranno utilizzate durante l'esportazione di file STEP.
Scrivi curve rispetto al sistema di riferimento della superficie Se selezionato, le curve parametriche (curve nello spazio parametrico delle superfici) verranno scritte nel file STEP. Deselezionare l'opzione può essere utile per ridurre al minimo le dimensioni del file STEP risultante.
Esporta oggetti invisibili Deseleziona questa opzione per saltare l'oggetto invisibile durante l'esportazione, utile per le applicazioni CAD che non supportano lo stile STEP dell'invisibilità.
Esporta posizionamento singolo oggetto Seleziona questa opzione per mantenere le informazioni sul posizionamento durante l'esportazione di un singolo oggetto. Tieni presente che quando reimporti il ​​file STEP, il posizionamento verrà codificato nella geometria della forma, invece di mantenerlo all'interno della proprietà Placement.
Utilizzare l'esportatore precedente Usa il vecchio esportatore.
Schema Selezionare il protocollo dell'applicazione STEP (AP) da utilizzare per l'esportazione.

AP 203 è il protocollo per la progettazione 3D controllata di configurazione di parti meccaniche e assiemi.

AP 214 è il protocollo per i dati fondamentali per i processi di progettazione meccanica automobilistica.

Attiva l'unione di composti STEP Se selezionata, verrà eseguita un'unione di compound durante la lettura del file. Questo è più lento ma si traduce in dettagli più elevati.
Usa LinkGroup Seleziona questa opzione per utilizzare i contenitori del gruppo App::LinkGroup invece dei contenitori del gruppo App::Part.
Importa oggetti invisibili Selezionarlo per importare oggetti invisibili.
Riduci il numero di oggetti Riduci il numero di oggetti utilizzando le matrici di collegamento.
Espandi forma composta Espandi le forme composte con più solidi.
Mostra barra di avanzamento durante l'importazione Mostra una barra di avanzamento durante l'importazione.
Ignora nomi istanza Non utilizzare nomi di istanza. Utile per alcuni file STEP legacy con nomi di istanza generati automaticamente non significativi.
Modalità Seleziona la struttura del documento richiesta.

Documento singolo

Assemblaggio per documento

Assemblaggio per documento nella sotto-directory

Oggetto per documento

Oggetto per documento nella sottodirectory

Azienda Se non è vuoto, il testo inserito verrà utilizzato nell'intestazione del file STEP per l'azienda.
Autore Se non è vuoto, il testo inserito verrà utilizzato nell'intestazione del file STEP per l'autore.
Prodotto Se non è vuoto, il testo inserito verrà utilizzato nell'intestazione del file STEP per il prodotto.

SVG

Scalable Vector Graphics (SVG) è un formato per immagini vettoriali per la grafica bidimensionale. Un'immagine vettoriale può essere ridimensionata a qualsiasi dimensione senza perdere forma o dettagli. Un'immagine SVG può essere convertita in formati bitmap come PNG o JPEG per la stampa.

On the this page you can specify the following:

Nome Descrizione
Stile d'importazione Seleziona come verranno importati i colori degli oggetti SVG e gli spessori delle linee.

Se viene selezionato Nessuno (più veloce), non verranno importate le impostazioni relative al colore o alla larghezza della linea.

Se viene selezionato Usa colore e larghezza linea predefiniti, FreeCAD utilizzerà il colore e la larghezza della linea predefiniti.

Se viene selezionato Colore e larghezza di linea originali, FreeCAD utilizzerà il colore e la larghezza di linea degli oggetti SVG.

Disattiva la scalatura delle unità Se selezionato, non si verificherà alcuna conversione di unità. Un'unità nel file SVG si tradurrà in un millimetro.
Stile di esportazione Seleziona come vengono esportati gli schizzi in SVG.

Se viene selezionato Tradotto (per stampa e visualizzazione), gli oggetti SVG vengono incapsulati in un gruppo che viene ridimensionato e spostato nella posizione corretta nel documento SVG per adattarsi a un'area stampabile.

Se viene selezionato Raw (for CAM), gli oggetti SVG vengono posizionati così come sono - alle stesse coordinate del modello FreeCAD (esportazione 1:1).

Trasforma le linee bianche in linee nere Se selezionato, tutte le linee bianche appariranno in nero nell'SVG per una migliore leggibilità su sfondi bianchi.
Lunghezza massima del segmento per gli archi discretizzati Le versioni di Open CASCADE precedenti alla versione 6.8 non supportano la proiezione dell'arco. In questo caso gli archi verranno discretizzati in piccoli segmenti di linea. Questo valore è la lunghezza massima del segmento.

VTK

Il Visualization Toolkit (VTK) è un sistema software open source disponibile gratuitamente per la computer grafica 3D, l'elaborazione delle immagini e la visualizzazione. I file VTK vengono utilizzati dall'Ambiente FEM per il post processing dei risultati della simulazione.

La scheda VTK viene mostrata nelle preferenze solo se l'Ambiente FEM è stato caricato nella sessione corrente di FreeCAD.

On the this page you can specify the following:

Nome Descrizione
Quale oggetto importare in Seleziona quali oggetti devono essere importati.

Se viene selezionato Oggetto risultato VTK, verrà importato un oggetto risultato VTK FEM di FreeCAD (uguale all'oggetto che è stato esportato).

Se viene selezionato Oggetto FEM mesh, i risultati nel file VTK verranno omessi, verranno importati solo i dati mesh e verrà creato un oggetto mesh FEM di FreeCAD.

Se viene selezionato Oggetto risultato FreeCAD, i dati importati verranno convertiti in un oggetto Risultato FEM di FreeCAD. Nota: questa impostazione richiede i nomi esatti dei componenti dei risultati e quindi funziona correttamente solo con i file VTK esportati da FreeCAD.