Dostrajanie parametrów

From FreeCAD Documentation
This page is a translated version of the page Fine-tuning and the translation is 97% complete.
Outdated translations are marked like this.

Wprowadzenie

Edytor preferencji FreeCAD w menu Edycja → Preferencje jest powszechnie używany do wprowadzania i edycji tabeli parametrów programu.

Jednak możliwy jest również dostęp, modyfikacja i ręczne tworzenie parametrów za pomocą Edytora parametrów znajdującego się w menu Narzędzia → Edycja parameterów.

Poniższa strona przedstawia listę parametrów, które nie są dostępne za pośrednictwem edytora preferencji aby dopracować instalację FreeCAD lub pokonać problemy. Wszystkie parametry można ustawić ręcznie w BaseApp/Preferencje/:

Informacje ogólne

  • Addons/developerMode (boolean): Ustaw wartość opcji na PRAWDA aby włączyć tryb deweloperski Menadżera dodatków. Zobacz stronę Metadane pakietu.
  • Bitmaps/Theme/ThemeSearchPaths (boolean): Ustaw wartość opcji na FAŁSZ aby FreeCAD używał dołączonych ikon zamiast systemowego motywu ikon w Linuksie.
  • Dialog/DontUseNativeColorDialog (boolean): Ustawienie okna dialogowego selektora kolorów. Ustaw wartość na FAŁSZ, jeśli chcesz, aby FreeCAD używał natywnego okna dialogowego koloru w twoim systemie, a nie okna Qt Color. Wartość domyślna to PRAWDA.
  • Dialog/DontUseNativeDialog (boolean): Ustawienie okna dialogowego pliku. Ustaw wartość na FAŁSZ, jeśli chcesz używać natywnego okna dialogowego Plik podczas otwierania plików lub PRAWDA, aby używać okna dialogowego Qt File Picker. Domyślne zależy od ustawienia podczas kompilacji: #define (USE_QT_FILEDIALOG).
  • Dialog/DontUseNativeFontDialog (boolean): Używane przez polecenie Kształt z tekstu. Ustaw wartość na FAŁSZ, aby użyć natywnego okna dialogowego Czcionka. Wartość domyślna to PRAWDA.
  • DockWindows/TreeView/Enabled (boolean): Ustaw wartość opcji na PRAWDA aby umożliwić dokowanie widżetu Widok drzewa niezależnie od Widoku Połączonego. Po zmianie wartości parametru potrzebny jest restart programu FreeCAD, aby widżet był dostępny na liście Panelu - Widok połączony.
  • DockWindows/PropertyView/Enabled (boolean): Ustaw wartość opcji na PRAWDA aby umożliwić dokowanie widżetu Widok właściwości niezależnie od Widoku Połączonego. Po zmianie wartości parametru potrzebny jest restart programu FreeCAD, aby widżet był dostępny na liście Panelu - Widok.
  • DockWindows/DAGView/Enabled (boolean): Ustaw wartość opcji na PRAWDA aby włączyć wersję testową dokowanego widżetu DAG view. Po zmianie wartości parametru potrzebny jest restart programu FreeCAD, aby widżet był dostępny na liście Panelu - Widok.
  • Document/AutoNameDynamicProperty (boolean): Ustaw na wartość PRAWDA, aby FreeCAD automatycznie zmieniał nazwy właściwości dynamicznych z niepoprawnie podaną nazwą zamiast wyrzucać wyjątek. Zwróć uwagę, że kod Pythona nie będzie miał dostępu do nowej nazwy.
  • Document/ChangeViewProviderTouchDocument (boolean): Ustaw wartość opcji na false aby zmiany widoczności elementów nie oznaczały dokumentu jako zmodyfikowany.
  • Document/SaveThumbnailFix (boolean): Ustaw wartość opcji na PRAWDA aby naprawić problem z Qt5, który uniemożliwia generowanie miniaturek plików .FCStd.
  • General/LockToolBars (boolean): Ustaw wartość na PRAWDA, aby uniemożliwić przeciąganie pasków narzędzi i ukryć małe uchwyty do przeciągania. Najczęściej używane w połączeniu z arkuszami stylów, które sprawiają, że paski narzędzi są pionowe.
  • General/RecentIncludesExported (boolean): Ustaw wartość opcji na PRAWDA to include exported files in the Recent Files list. Defaults to FAŁSZ.
  • General/RecentIncludesImported (boolean): Ustaw wartość opcji na FAŁSZ to exclude imported files from the Recent Files list. Defaults to PRAWDA.
  • General/ShowSplasherMessages (boolean): Ustaw wartość FAŁSZ, aby pominąć wyświetlanie komunikatów na ekranie powitalnym. Może to skrócić czas uruchamiania FreeCAD. Wartość domyślna to PRAWDA.
  • Macro/DuplicateFrom001 (boolean): Ustaw wartość opcji na PRAWDA aby zawsze rozpoczynać poszukiwanie sugerowanej nazwy pliku z duplikatem makra od @001 zamiast aktualnego @NNN (jeśli dotyczy). Domyślna wartość FAŁSZ.
  • Macro/DuplicateIgnoreExtraNote (boolean): Ustaw wartość na PRAWDA, aby zignorować dodatkową notatkę podczas sugerowania zduplikowanej nazwy pliku makra. Dodatkowa uwaga to tekst w nazwie pliku po "@NNN" i przed ".FCMacro". Przykład: "my_macro@005.my_note.FCMacro". Jeżeli ustawiono wartość PRAWDA, następną sugerowaną nazwą pliku będzie "my_macro@006.FCMacro". Jeżeli FAŁSZ, to następną sugerowaną nazwą pliku jest "my_macro@006.my_note.FCMacro". Aby tekst został rozpoznany jako dodatkowa notatka, powinien zaczynać się od kropki (".") po członie "@NNN". W przeciwnym razie, na przykład "my_macro@006_my_note.FCMacro" otrzyma "my_macro@006_my_note@001.FCMacro" jako sugerowaną nową nazwę pliku, co może być pożądane w niektórych przypadkach. Domyślną wartością jest FAŁSZ.
  • Macro/ReplaceSpaces (boolean): Ustaw wartość na FAŁSZ, jeśli nie chcesz, aby spacje w nazwach plików były automatycznie zamieniane na podkreślenia podczas tworzenia, zmiany nazwy lub powielania makra. Nie ma to wpływu na istniejące pliki, ma znaczenie tylko przy tworzeniu nowego pliku, zmianie nazwy lub powielaniu istniejącego. Domyślną wartością jest PRAWDA.
  • MainWindow/ClearMenuBar (boolean): Ustaw wartość na PRAWDA aby wyczyścić pasek menu przy zmianie środowiska pracy, przydatne gdy używasz globalnego menu, gdyż może ono nie aktualizować się przy zmianie środowiska pracy i szybko stać się zagracone wpisami w menu każdego środowiska. Domyślna wartość to FAŁSZ. Na macOS jest oczyszczane w każdym przypadku, aby obejść błąd w Qt.
  • MainWindow/ToolBarNameAsToolTip (boolean): Ustaw wartość na FAŁSZ, aby nie wyświetlać nazwy paska narzędzi jako etykiety. Domyślnie PRAWDA.
  • PropertyView/AutoTransactionView (boolean): Ustawienie wartość opcji na PRAWDA powoduje, że zmiany właściwości karty Widok są dodawane do stosu cofania (a więc można je cofnąć). Domyślną wartością jest FAŁSZ.
  • Selection/AutoShowSelectionView (boolean): Ustaw wartość opcji na PRAWDA aby panel Widok zaznaczenia wyświetlał się automatycznie po wybraniu obiektu. Domyślnie FAŁSZ.
  • Selection/singleClickFeatureSelect (boolean): Ustaw opcję na wartość FAŁSZ, aby wyłączyć możliwość wyboru elementu jednym kliknięciem w środowisku Projekt Części. Domyślnie PRAWDA.
  • TreeView/HideColumn (boolean): Ustaw wartość parametru na Prawda, aby ukryć kolumnę Opis w oknie Widoku drzewa. Domyślnie FAŁSZ.
  • TreeView/TreeViewStretchDescription (boolean): Ustaw opcję na wartość FAŁSZ, aby rozciągnąć kolumnę "Opis" w oknie widoku drzewa do prawej krawędzi panelu. Wartość domyślna to FAŁSZ.
  • View/AxisLetterColor (unsigned): Kolor liter układu współrzędnych wyświetlanych w prawym dolnym rogu widoku 3D. Domyślnie 255. Zobacz stronę Kostka nawigacyjna, aby uzyskać informacje na temat wartości koloru.
  • View/AxisXColor (unsigned): Kolor dla elementów osi X gizma Std: Przemieszczenie. Domyślnie 3425907456. Zobacz stronę Kostka nawigacyjna, aby uzyskać informacje na temat wartości koloru.
  • View/AxisYColor (unsigned): Analogicznie dla elementów osi Y. Domyślnie 869020416.
  • View/AxisZColor (unsigned): Analogicznie dla elementów osi Z. Domyślnie 859032576.
  • View/NavigationDebug (boolean): Włącza debugowanie stylów nawigacji (od wersji v0.19 tylko styl nawigacji Gesture ma coś do powiedzenia).
  • View/NavigationDebug (boolean): Udostępnia możliwość debugowania stylów nawigacji (od v0.19, tylko styl nawigacji Gesture znajduje zastosowanie).
  • View/SavePicture (string): Ustaw wartość opcji na FramebufferObject, PixelBuffer lub CoinOffscreenRenderer dla różnych metod tworzenia obrazów w oknie widoku 3D.

Domyślna nazwa pliku eksportu

.

  • General/ExportDefaultFilenameMultiple (string): Ustaw domyślną nazwę pliku, która będzie używana podczas eksportu wielu obiektów. Domyślną wartością jest %F.
  • General/ExportDefaultFilenameSingle (string): Ustaw domyślną nazwę pliku, która będzie używana podczas eksportu pojedynczego obiektu. Domyślną wartością jest %F-%P-.

Obie te opcje umożliwiają automatyczne wstawianie do nazwy pliku różnych informacji, przy użyciu następujących znaków formatu:

  • %F - nazwa pliku .FCStd (lub etykieta, jeśli nie jest jeszcze zapisana)
  • %Lx - etykieta wybranego obiektu (obiektów), oddzielona znakiem 'x'
  • %Px - etykieta zaznaczonego obiektu(ów) i ich pierwszego rodzica, oddzielona znakiem 'x'
  • %U - data i godzina, w UTC, ISO 8601
  • %D - data i czas, w lokalnej strefie czasowej, ISO 8601.

Wszelkie inne znaki traktowane są dosłownie. Jeśli wynikowa nazwa pliku jest nieprawidłowa, zostanie zmieniona przy zapisie, a nieprawidłowe znaki zostaną zastąpione znakiem podkreślenia ' _ ' .

Powiązane z myszką

.

  • General/ComboBoxWheelEventFilter (boolean): Należy ustawić wartość true, aby widżety nie przechwytywały zdarzeń związanych z kółkiem myszy i uniemożliwiały przewijanie obszarów, które można przewijać. Wymaga uwzględnienia ponownego uruchomienia programu FreeCAD.
  • View/GestureRollFwdCommand, View/GestureRollBackCommand (string): Komendy, które mają być wykonywane za pomocą gestów przewijania przycisków myszy w stylu nawigacji Gesture.
  • View/GestureMoveThreshold (integer): Odległość, jaką musi pokonać kursor myszy (px), aby wejść w tryb obrotu lub przesuwania w stylu nawigacji Gesture. Wartość domyślna 5.
  • View/GestureTapHoldTimeout (integer): Określa jak długo trzeba czekać (w milisekundach), aby wejść w tryb obrotu w stylu nawigacji Gesture. Pomocne może być zwiększenie wartości, jeśli przeciąganie geometrii w szkicowniku jest trudne. Domyślnie jest to wartość 700.

Skróty klawiaturowe

Klawisz ESC

  • General/TasksKeyEsc (boolean): Utwórz i ustaw wartość na false, aby wyłączyć wychodzenie klawiszem ESC z Panelu zadań we wszystkich środowiskach pracy (to znaczy, jeśli panel zadań jest aktywny).

Kostka nawigacyjna

Zobacz stronę Kostka nawigacyjna.

Szczególne środowiska pracy

środowisko pracy BIM

  • Mod/BIM/DefaultPageScale (float): Domyślne skalowanie dla nowych stron Rysunku Technicznego utworzonych z poziomu środowiska pracy BIM, w przypadku gdy szablon nie zawiera żadnego edytowalnego pola tekstowego "Skala" lub "Skalowanie" (wielkość liter nie ma znaczenia).

środowisko pracyCAM

  • Środowisko pracyCAM posiada przełącznik umożliwiający włączenie eksperymentalnych funkcji udokumentowanych na stronie Funkcje eksperymentalne.

środowisko pracy Rysunek Roboczy

  • Mod/Draft/DefaultAnnoDisplayMode (liczba całkowita): Ustaw wartość 1, aby tworzyć adnotacje Rysunku Roboczego (tekst, wymiar i etykieta) z ich właściwością WIDOKTryb wyświetlania ustawionym na Ekran. Ustaw na 0 dla nowych adnotacji z tą właściwością ustawioną na Świat. Domyślnie 0. dostępne w wersji 1.0
  • Mod/Draft/GridHideInOtherWorkbenches (boolean): Ustaw wartość FAŁSZ, aby utrzymać siatkę podczas przełączania na inne środowiska pracy niż Architektura, BIM lub Rysunek Roboczy. Wartością domyślną jest PRAWDA. dostępne w wersji 1.0
  • Mod/Draft/useSupport (wartość logiczna): Ustaw wartość PRAWDA, aby ustawić właściwość DANESupport obiektów Rysunku Roboczego utworzonych na powierzchni wychodzącego obiektu bazowego na ten obiekt bazowy. Było to standardowe zachowanie przed wersją FreeCAD 0.19. Należy pamiętać, że parametr ten może nie być obsługiwany w przyszłych wersjach. Wartością domyślną jest FAŁSZ.

środowisko pracy Część

  • Mod/Part/ParametricRefine (boolean): Ustaw wartość opcji na FAŁSZ, aby funkcja udoskonal kształt utworzyła niezależną kopię, a nie linkowaną. Domyślną wartością jest PRAWDA jeśli wartość nie jest dostępna.

środowisko pracy Projekt Części

  • Mod/PartDesign/AdditiveHelixPreview (boolean): Ustaw wartość opcji na PRAWDA aby zapewnić, że helisa addytywna, która nie przecina ciała, jest widoczna w podglądzie. Domyślną wartością jest FAŁSZ.
  • Mod/PartDesign/SubtractiveHelixPreview (boolean): Ustaw wartość opcji na PRAWDA aby upewnić się, że helisa odejmowana, która nie przecina ciała, jest widoczna w podglądzie. Wartością domyślną jest PRAWDA.
  • Mod/PartDesign/SwitchToTask (boolean): Ustaw wartość opcji na FAŁSZ, aby uniemożliwić przełączenie na panel zadań podczas uruchamiania Środowiska pracy Projekt części. Wartością domyślną jest PRAWDA, jeśli wartość nie jest dostępna.
  • Mod/PartDesign/SwitchToWB (boolean): Ustaw wartość opcji na FAŁSZ, aby zapobiec automatycznemu wywołaniu Środowiska pracy Projekt części, gdy aktywowana jest opcja zawartość. Wartością domyślną jest PRAWDA, jeśli wartość nie jest dostępna.

środowisko pracy Szkicownik

  • Mod/Sketcher/RadiusDiameterConstraintDisplayAngleRandomness (float): Ustawia losowość kąta na powyższej wartości. Wartość to zakres losowego kąta, wyśrodkowany na kącie bazowym. Domyślnie jest to .
  • Mod/Sketownik/RadiusDiameterConstraintDisplayBaseAngle (float): Ustawia kąt (od poziomu) używany do wyświetlania wiązań promienia/średnicy w Szkicowniku w czasie tworzenia. Domyślnie 15° (jeśli nie ustawiono wartości).
  • Mod/Sketcher/RoundRectangleSuggConstraints (boolean): Ustaw na wartość FAŁSZ, aby wyłączyć dodawanie dwóch dodatkowych punktów konstrukcyjnych podczas tworzenia zaokrąglonego prostokąta. dostępne w wersji 0.21

Kolory etykiet wiązań

Etykieta w Szkicowniku, która wyświetla aktualny stan wiązań (np. " Nie w pełni wiązany", " W pełni wiązany" itd.) jest stylizowana dla każdego stanu za pomocą arkusza stylów Qt lub preferencji użytkownika. Preferencje użytkownika mają pierwszeństwo, jeśli zostały ustawione (w Mod/Szkicownik/Ogólne):

  • Kolor komunikatu Pustego szkicu - domyślnie czarny z 50% kryciem.
  • Kolor komunikatu Nie w pełni związany - domyślnie czarny.
  • Kolor komunikatu Nieprawidłowo sformułowane wiązanie - domyślnie czerwony.
  • Kolor komunikatu Wiązanie konfliktowe - domyślnie czerwony.
  • Kolor komunikatu Wiązanie nadmiarowe - domyślnie czerwony.
  • Kolor komunikatu Wiązanie częściowo nadmiarowe - domyślnie królewski niebieski.
  • Kolor komunikatu Błąd solwera - domyślnie czerwony.
  • Kolor komunikatu Związany w pełni - domyślnie zielony.

środowisko pracy Start

Środowisko pracy Start nie jest już dołączane po wersji 0.21.

  • Mod/Start/DefaultImportXXX (string): Gdzie XXX to rozszerzenie pliku pisane małymi literami. Na przykład DefaultImportifc dla plików .IFC. Umożliwia ustawienie domyślnego modułu importu, który będzie używany po kliknięciu ikony na stronie startowej, gdy dostępnych jest kilka importerów. Na przykład ustawienie DefaultImportifc = ifc_import spowoduje użycie importera NativeIFC, jeśli jest dostępny. dostępne w wersji 0.21
  • Mod/Start/TimeFormat (string): Ciąg formatu czasu, taki jak %m/%d/%Y %H:%M:%S używany dla daty w podpowiedzi wyświetlanej po najechaniu kursorem na element na stronie startowej.

Moduł pomocy

  • Mod/Help/UseWebModule (boolean): Pozwala wymusić użycie modułu Web do otwierania zakładek MDI (Multiple Document Interface). Może to być przydatne do obejścia problemów QWebEngine w niektórych wersjach Qt5. Domyślnie Fałsz. dostępne w wersji 1.0