Привязка к объектам

From FreeCAD Documentation
This page is a translated version of the page Draft Snap and the translation is 3% complete.
Outdated translations are marked like this.

Description

In the Draft Workbench and the BIM Workbench you can create geometry by picking points in the 3D view or by entering coordinates in the task panel of commands. Another way of selecting points is by snapping. Snapping allows to select exact geometric points on, or defined by, existing objects or the grid. You can for example snap to the endpoint of a line, to the center of a circle, or to the intersection of two edges.

Snapping is available with most Draft and BIM commands.

Snapping to the endpoint of an edge

Snap tools

These tools are available in the Draft snap toolbar and in the Draft snap widget.

Note that circular edges do not have to be full circles.

  • Snap lock: enables or disables snapping globally.
  • Snap angle: snaps to the special cardinal points on circular edges, at multiples of 30° and 45°.
  • Snap extension: snaps to an imaginary line that extends beyond the endpoints of straight edges.
  • Snap parallel: snaps to an imaginary line parallel to straight edges.
  • Snap special: snaps to special points defined by the object.
  • Snap near: snaps to the nearest point on faces and edges.
  • Snap ortho: snaps to imaginary lines that cross the previous point at multiples of 45°.
  • Snap grid: snaps to the intersections of grid lines.

Advanced snapping

  • Additional snap points can be obtained by combining two snap options. For example combining Draft Snap Ortho and Draft Snap Extension will give you a snap point at the intersection of their imaginary lines.
  • Snapping can be combined with constraining.
  • Press Q to insert a "hold point" at the current location of the cursor. You can snap to the orthogonal axes of hold points, and to the intersections of these axes. If the Draft Snap Midpoint option is active, you can also snap to the midpoint between two hold points.
  • Press ` one or more times to snap to an object that is obscured by other geometry. This is called "snap cycling". Note that you must move the cursor by a small amount in the 3D view after pressing the key.

Snap cycling 1: The red rectangle was created first therefore it has snap priority. Without snap cycling you cannot snap to the green rectangle where it is overlapped by the red rectangle.

Snap cycling 2: After using the snap cycle key once the green rectangle receives snap priority. Snapping to the midpoint of the overlapped green edge is now possible.

Notes

  • Multiple snap options can be active at the same time, but it is advisable to only activate the snap options you really need. Activating too many can slow things down.
  • It is not a good idea to have Draft Snap Near permanently active as it takes precedence over many other snap options.

Preferences

See also: Preferences Editor and Draft Preferences.

  • When a Draft or BIM command requiring point input is active, the maximum distance at which Draft Snap Grid detects the intersections of grid lines can be changed on-the-fly by pressing P (increase key) or M (decrease key). This setting is stored: Tools → Edit parameters... → BaseApp → Preferences → Mod → Draft → snapRange. It can also be changed in the task panel of the Draft SelectPlane command.
  • To only snap when the Snap modifier key is held down:
    • Deselect: Edit → Preferences... → Draft → Grid and snapping → Always snap.
    • The default Snap modifier key, Ctrl, can be changed: Edit → Preferences... → Draft → Grid and snapping → Snap modifier.
  • To only show the Draft snap toolbar when a command is active select: Edit → Preferences... → Draft → Interface → Only show the Draft snap toolbar during commands. introduced in version 1.0
  • The snap symbols can be changed: Edit → Preferences... → Draft → Grid and snapping → Snap symbol style.
  • The color of the snap symbols and the dimensions of Draft Snap Dimensions can be changed: Edit → Preferences... → Draft → Grid and snapping → Snap symbol color.
  • The size of the snap symbols depends on: Edit → Preferences... → Display → 3D View → Marker size. introduced in version 1.0
  • The mentioned single character keyboard shortcuts can be changed: Edit → Preferences... → Draft → Interface → In-command shortcuts.